Harmony Stopped Working


#1

I haven’t had any issues using my Harmony hub with smartthings, but everything stopped working today. I can no longer switch lights lights with the harmony remote. I tried to re-add Smartthings on My Harmony, but I got authorization failed. Now I can’t add it back. Anyone having similar issues.


IFTTT (and other External Services) Authorization Issues
(Sully) #2

It’s a known thing. Pretty much all external integrations aren’t working right now.


#3

Where is this know and when did it happen. It was all working yesterday. I looked at the announcements and the device forums and didn’t see anything.


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #4

There is apparently an issue on smartthings side with cloud integrations.

External authorization with SmartThings is currently broken for several of the major integrations. SmartThings is actively working on it. (This is impacting IFTTT, Amazon Echo, SharpTools, SmartRules, etc)


(Sully) #5

Sorry, I meant known on the forums, a lot of folks have been talking about it today. Best I can tell it broke some time around 9 or 10 am PST today. I know it had been working an hour or two before that.

Sorry for the unclear wording.


#6

Also being tracked in the Known Issues category in the community-created wiki:

http://thingsthataresmart.wiki/index.php?title=Bug:External_Integrations_fail(Echo,_Harmony,_IFTTT,_SmartTiles)


#7

Thanks all, it was driving me crazy. I thought I had broke something. I with they would have acknowledged there was an issue and made a sticky thread. Would have saved me a lot of time tonight. Oh well. Hope they get it fixed soon.


(Ron) #8

@JDRoberts I just tried to create an account over at this wiki and it says “ron” username is taken and that my email address has an account pending but when I request password reset for “ron” is says there is no such user. Hmmmm…do you know who manages this wiki ?


#9

Wiki discussion in the following topic. :sunglasses:


(Brice; SmartRulesApp.com) #10

Hi @Ron. We were getting a lot of spam, so for now, I’ve enabled manual account confirmation until we find a better alternative. Your account was sitting waiting for me to approve it. It should be good to go now.


(Joshua Lyon (SharpTools.io Dashboard)) #11

FYI: I just pushed SharpTools 2.0 R3 to Google Play which works around the recent issue introduced for authorizing third party SmartApps! The SharpTools update should become available in Google Play over the next few hours.

PS. It feels a bit weird to be quoting my own text listed under someone elses name. Almost like I’m responding to myself. :stuck_out_tongue:

Edit: It looks like there are still some lingering platform issues. From what I can tell, SharpTools can control all NON-LOCAL devices. If a device is manually moved to the cloud, you will regain control of it.


(Bobby) #12

Hey Joshua, I guess the recent problems are affecting reauth? I just updated and reauth my things, but now I get a big 0 devices authorized…


(Joshua Lyon (SharpTools.io Dashboard)) #13

Yes, the problems are affecting authorization among other things. It looks like there may be issues with third party SmartApps controlling non-local devices as well.


#14

I must just have bad luck as I was setting smart things up for the first time last night and ran into the issue where Alexa was controlling my lights fine only that then fail and drive me crazy trying to troubleshoot. Alexa control is now back up this morning but I’m still unable to authorize my harmony hub with smart things. Is there still a problem with authentication on some services?

Smart things has been incredibly easy to get up and running compared to my vera set up. I’m now at the point though where I need to set up scenes for my lighting, which appears to be a lot more complicated in smart things. Reading the forums it is a bit confusing on what is the current method versus the first hub or before other software changes. Can someone point me to the best Smart app to set up simple scenes? The community seems amazing so thanks in advance.


(Marc) #15

I never had any issues with external services yesterday. I am on a V1, did anyone with a v1 have issues?


(Bobby) #16

Welcome to the ‘beauty and the beast’ horror show! You definitely picked the worst day possible to start your adventure. SmartThings’ platform has had all sorts of issues for the past two days. It is a ‘beauty’ when it works, but is such a ‘beast’ when it doesn’t.


(Bobby) #17

Now that is interesting and it almost makes me dust off my v1, but I am really on the fence about it because everything running local has been solid for 2 months now…


(Marc) #18

v1 has also been very stable for past couple of months (except for cloud delays here and there!)


(Joshua Lyon (SharpTools.io Dashboard)) #19

There were at least two issues:

  • The authorization workflow was broken for many third party integrations (those using HTTP GET instead of HTTP POST for the OAuth code exchange)
  • Third party SmartApps were unable to control local devices

Since you were already authenticated, the first item wouldn’t have applied to you and since you are on a hub V1, the second item likely wouldn’t have applied to you either! :slight_smile:

For what it’s worth, it seems there may have been other issues too as some “rule” SmartApps weren’t working properly and Routines were having troubles too.


New design interface for smartthings (diy gui) all platforms
#20

Yea I was really impressed with ease of set up before the services went down. Can anyone point me to current post explaining how to do scenes. Everything else has been pretty intuitive to me.