All Z-wave devices stopped working - Help!

Wait…you “reset” the hub? Or you just powered it off and then on again? Those are very different processes with very different results. :thinking:

Anyway… at this point, I would wait and see what support says. There may be something going on with the hub that they can see.

I am at firmware 45.00011 and starting yesterday afternoon my GE switches did the same thing along with all of my Aeotec plugs. I was already starting to move over to Hubitat so I guess this forces me to go forward with my migration.

@Jody_Tipton this is probably because you moved key devices that were being used in your Zwave mesh.

@Tamerfakhry How many devices do you have in your network? How many devices are Zwave? How many of those GE switches did you exclude? Which driver are the switches rejoining as? Again, you have to be patient, you have to join the GE switch that is closest to your hub first and make sure it works before you move to the next one and then keep moving along. From you screenshot that doesn’t look like the right driver that they are pairing with! Are you getting errors when you run the Zwave repair after each or every other switch? Make sure you have the Zwave Switch Edge driver installed on your hub. If you don’t know how to do it then reply back and I will explain.

I have 195 zwave devices on my Smartthings network. I moved 10 Zwave devices 2 weeks ago over to Hubitat.All of my devices are running Edge drivers. I ran a repair this morning and it ran for 2 hours but never completed and I had errors for a number of Aeotec devices and GE devices.

I didn’t move any switches. The hub is within 4 feet of these switches as they are all central around the hub.
All switches were working fine till the added one more. To me this isn’t a distance issue. This is more software related than anything. I will do one last test by disconnecting the most recent switch from power and see if I can add the other ones back with no issues. But the fact that I am not the only one with this specific issue, tells me there is something more to it.

Also I have contacted Samsung support for help. I have 0 issues in my other house. So this is hub related to the Z-wave network.

1 Like

Were you adding a new switch?

My guess (just a guess based on other reports from other community members about GE switches that stopped working recently) is that when the OP added the new switch it picked up a new stock driver and it’s possible that may also have triggered the transition of other devices on their account. And the new stock driver is not working properly. If so, just powering off the device won’t make any difference.

I know a number of people have said that the stock driver was not working right for them with GE switches, and they ended up using either Phil H’s or one of Mariano’s and suddenly everything was fine again.

Which is weird, but there has been more than one report about it.

To be honest, I haven’t been feeling very well for the last couple of days, and I just didn’t want to start a whole conversation about custom edge drivers if that wasn’t necessary.

But here’s the link to Phil’s driver which did fix issues for a number of people:

[ST Edge] Driver for GE/Jasco/Honeywell Z-Wave Switches, Dimmers, Fans, Outlets, and Plug-Ins

And here’s the link to the community FAQ on edge for those who don’t know how to use custom drivers yet:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

But I’m not myself up to answering any follow up comments on this possibility, I’ll have to leave that to you and other people. :sleeping:


Those Zwave questions were for @Tamerfakhry .Your Zwave mesh is broken, probably because you removed those devices and they were Key repeaters. You need to fix your mesh, I have 151 devices and it takes lee than 5 minutes to run a Zwave repair. I have never heard of 2 hours! With that many devices make sure you have at least 3 or 4 powered Zwave switches near your hub. You need to get the Zwave repair to run successfully before moving forward. When you start migrating to Hubitat again, you need to start with devices farthest from your hub and then move backwards towards your hub until you finish.

I was a certified zwave network engineer before I got my own first smartthings hub back in 2014. The zwave repair utility can take anywhere from a few minutes to several hours depending on the number of errors encountered, because errors will initiate retries. I’ve run some myself which took more than an hour. It’s rare, but it happens.

Right now, smartthings is making so many changes to its own overlay architecture that it’s very hard to tell exactly what’s going on. There are a number of people who haven’t changed their device set up at all, and therefore should not have changed their mesh at all, who are still reporting problems with some devices as those devices transition to edge drivers. It’s just a complicated time. :thinking:

I agree that being aware of the impact on the mesh is always important when you are moving devices from one hub to another, but there are lots of different ways to plan a transition depending on the exact layout. You just need to be sure that there is a strong backbone going from the hub to whatever the farthest away device is that you are trying to reach. While the safest way to do that is to start with devices physically closest to the hub and work your way out, it’s not the only way to do it. Sometimes people want to begin testing a new hub in an outbuilding or a back office or a basement rec room and as long as you have a good repeater path to that area, that’s enough.

Regarding having repeaters close to the hub, again, it depends on the exact layout of what you’re trying to do. I was a field tech for years, and there are a lot of different ways you can do it. And “close to the hub” just means “within one hop.” Because Z wave antennas are omnidirectional, there might be a repeater within one hop that is one floor above or below the hub, for example. To the human mind, that’s not “close“ but from a network perspective, it may well be.

So there are just a lot of different variables. But at this particular moment in time, I wouldn’t jump to the conclusion that it’s a weak mesh issue. I think it’s about 50-50 that it’s an edge driver issue.

Everything you’re saying would absolutely be the first things I would look at if these were normal times, it’s just that these aren’t normal times.

Just my own opinion, of course.

1 Like

JD agreed, there is a problem with the Zwave Switch Edge driver, I had to remove most of my devices that were auto migrated to it and rejoin them to fix it. Now im still using that driver and everything is working fine. A lot of people that were having issues with Zwave were fine after a Zwave repair.

1 Like

I have done the zwave repair and it runs successfully within 30 seconds. I didn’t remove any switches. I simply added one then it all stopped working. I don’t think it is Zwave network issue. I ordered a new hub to test things on it. In the mean time, I will various troubleshooting steps that I haven’t tried yet

ok, let us know how this works out for you.

1 Like

HUGE THANKS TO YOU ALL. All the switches are working now. It was the driver!! @JDRoberts incredible suggestion!

Now the lock is having the same issue which makes me think SmartThings drivers are having issues with the new migration!

Wondering if any of you know of Edge drivers for Zwave!


@Tamerfakhry Jd gave you a link for the drivers. Look at his post above.

I used the link for the switches. It doesn’t have any drivers for zwave locks

1 Like

If you read the edge FAQ that I previously gave you the link to, it tells you how and where to find drivers. Right now, there are four sources.

  1. stock drivers automatically updated to your hub. This will happen automatically, little by little, with no advance notice.

  2. stock drivers currently available in the smartthings beta channel. This gives you early access to the stock drivers that will later be distributed automatically, but they may have glitches. Also note that sometimes fingerprints are listed there but they are commented out because they aren’t ready for release yet.

Preview | SmartThings-managed Edge Device Drivers

  1. the table of edge drivers in the community - created wiki. Lets you look for drivers by model. It’s a good table and includes both stock drivers and custom drivers, but it’s very new and definitely incomplete. So if you don’t see your model there. It doesn’t mean there isn’t a custom edge driver for it, it just means the table hasn’t been updated yet.

  1. The quick browse lists in the community – created wiki are more up-to-date, but are just by device class. So there’s one list for locks, one list for sensors, etc. then you have to look through the matching topics to see which might match your device. So it’s more work than a table, but more complete.

And again, if you read the community FAQ on edge, it has all of this information and more. :sunglasses:

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

Thank you for these comprehensive lists. I went through them all in detail, my lock is part of the fingerprint and it is included in the list. At his point SmartThings drivers are not working for me at this location for whatever reason. So I am trying to find a custom driver and I can’t seem to find any. So I will keep searching. My other house uses the smartThings z-wave lock driver with no issue! wondering what’s deal with this locations. Maybe it has something to do with their migration to a new platform.

1 Like

search the forums for your lock fingerprint and see what you get. Sort the results by latest post. Also make sure you dont have a DTH installed for the lock as that will keep it from using the edge driver.

1 Like

Which list?

Also, check carefully to see if the finger print is commented out. Sometimes they will be in the code when an author, including smartthings staff, starts work on the device, but until the comment is removed, they won’t actually work.

The list “link” you posted.

I removed the driver and paired the door lock the old way. It worked right away. I will let SmartThings migrate it themselves.

1 Like