All my Aeotec Z-Wave Smart Switches not working


#1

New issue developed just today.

All of my Aeotec Z-Wave Smart Energy switches Model DSC06106-ZWUS are not working via app or alexa. The app just says “Turning On” or “Turning Off”. Alexa, just says OK. However, in the IDE they show up as online, and they do update their switch status. If I turn one on manually, it shows as on, turn it off manually, it shows as off.

I have tried restarting the Hub (v2). I am still on the classic app and I have not yet received any notice to migrate.

Any ideas?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

Live Logging output?


#3

I’m sorry. I am not an advanced user. When I look at the Live logging tab there is nothing significant there. if you mean event list for the device(s) it shows things happening. Power, Energy, switch position (assuming it is from me pressing the manual switch)


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

If there’s nothing unusual in Live Logging but “normal” events are being shown, then SmartThings Support can possibly assist you. They have access to more detailed internal logs.

https://support.SmartThings.com


#5

I have sent them an email with this info. I will see what they have to say.

Thank you!


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #6

Be sure to try completely removing and re-adding, at least one of them, from/to SmartThings.


#7

Actually, just tried to hit the device on the app, and got this in live logging: same thing on all my aeotec switches. i get one each time i try to use the device from the app.

5:59:10 PM: error java.lang.NullPointerException: Cannot invoke method contains() on null object @line 295 (encap)


SmartThings App (classic) loss of control along with automations (19 June 2018)
(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #8

What happens when you click on the long-number (the device ID) to the LEFT of that message in Live Logging?

That will confirm which Device Instance this message is coming from.

You can then contact Developer of the Device Type Handler with that exact error message. They can diagnose line 295. Are you using a Custom Device Type Handler (i.e., pasted into the IDE or linked via GitHub)? If not, then SmartThings is the Developer.


#9

clicking on that long id string just makes the other entries go away, nothing new, other than the device name appear up top, next to ALL. It is a smartthings handler. I have never pasted anything. Very basic here.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #10

That’s good. It confirms exactly which device that error is from.

SmartThings Support ought to be able to help diagnose, since the current source code may not be openly published for anyone in the Community to attempt to diagnose.

I still recommend removing and re-adding, though.


#11

it is actually 6 devices, all of them using the same switch type (Aeotec), handler: z-wave metering switch. I will try to remove and re-add.


#12

I have removed and re-installed all the switches and they are now working!!!

Thank you so much!! You are awesome!!!


(Eric Seckinger) #13

All my Aeotec stopped working sometime after 8am as well. All 6 of them. ST must have triggered something for this to occur to multiple people.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #14

That’s certainly possible: I believe that “Tuesday” is rollout day across the platform; though I thought that all “firmware updates” were pre-announced… Not every platform change is announced; So it makes it impossible for us folks out here to figure out what happened(s).

There’s a slight chance the just doing a full hub power cycle (i.e., remove batteries and power for 15 minutes), could also force the failing devices to reset and reconnect in the correct state, without a full-remove.


(Eric Seckinger) #15

I have mine in lots of routines if anyone figures out a way besides deleting and re adding. This is actually the first problem I have EVER had with my V1 hub and I mean EVER.


(Eric Seckinger) #16

I did reboot but not for 15 minutes. Let me try that Terry.


(Eric Seckinger) #17

I had the exact same symptoms as yours and same model number.


(Herbert Carroll) #18

Also having this problem as described in the OP. The one switch that continued to work was the one where i was running a custom device handler. Aeon Labs Smart Energy Switch. You should be able to find it pretty easily. Switching to that device type from Z-wave Metering Switch fixed all the others. I simply dont have the patience to add/remove all of them and local processing be damned.


(Eric Seckinger) #19

Can you post that handler please


(Herbert Carroll) #20