Aeon Smart Energy Switch 6 (gen5) + DSC06106


(Jonathan Bisson) #1

Here’s my contribution for the Aeon Smart Energy Switch 6 (gen5) as well as his older version brother, the Aeon Smart Switch DSC06106 device handler.

List of features:

  • On/off switch mode
  • Energy cost (current and cumulative) based on how much you pay in your country/state/province
  • Led color configuration
  • Report frequency configuration (how often does the different values get updated)
  • Secure mode inclusion support
  • Disable switch configuration so it always stay on/off, if needed
  • Report can either be configured to always be sent on a fixed time or when there is a delta difference in change %

You can find my code repo here:
Aeon Smart Switch 6 (gen5):

Aeon Smart Switch DSC06106:

------------------------


Aeotec Aeon Smart Switch 6
JUST power monitoring plugs/extension sockets?
Aeotec Aeon Smart Switch 6
#2

Awesome! I was in need of disabling the switch and hadn’t found a DTH to do that yet. Very timely. Thanks much!


(Simon) #3

Thanks :slight_smile:

As we discussed in the other thread, I had to include at least one of my switches (gen5) in unsecure mode to get it to work. But it’s wierd I got 2 others to work in secure mode.

My question is, can I see anywhere is my switches are included secure or unsecure?

If unsecure, should I then remove/reset the deice and include it again in secure mode?
What do I actually gain of benefits of including in secure mode?


(Jonathan Bisson) #4

@simonselmer One way to check if it secure or not is to login in your smartthing page https://graph.api.smartthings.com/login/auth go to my devices and click on your device. In the raw description, you’ll see a bunch of number. If you see 98 in cc: section, it means that it got pair into secure mode, if not, it means it was unsecure.

here’s a look of mine (unsecure one)
zw:L type:1001 mfr:0086 prod:0103 model:0060 ver:1.03 zwv:4.05 lib:03 cc:5E,25,26,33,70,27,32,81,85,59,72,86,7A,73 ccOut:5A,82 role:05 ff:8700 ui:870

You will get into secure mode if you quick tap twice (instead of once) when your pair it at first.The benefit of having secure is that z-wave traffic that goes bettween smartthing hub and your device will be encrypted, so no one should be able to see it (ie: neibours or something). Note that it only affect the link communication between the device and the hub.

Note that I had an issue (I’m not sure if it’s a hub bug or the device bug) where it would pair in secure mode but would only work in unsecure mode device handler. I had to unpair it and re-pair it and it work…

In an ideal world. you should not need to configure the device in secure or insecure, this was a work-around as I don’t know if there is way to detect it (through code). I asked the question in this topic: How to know if device secure inclusion as well as this one New Z-Wave Fingerprint Format but didn’t get any response (yet).


(Simon) #5

Thanks, I will check up on that.

In order to re-pair it, do I have to remove the device in the SmartThings app, and then hold the action-button down on the device for approx 25 seconds to reset it?

And then I can re-pair it?!


(Jonathan Bisson) #6

Go in the smartthing device handler config and click remove (at the bottom). You’ll need to press on the switch to unpair it.

I’ve included the switch manual on the git repo, it tell you how to to secure inclusion or unsecure (Basically, one press for insecure and two short presses for unsecure):
https://github.com/jbisson/SmartThingsPublic/blob/master/devicetypes/jbisson/aeon-smartSwitch-6.src/Aeon%20Labs%20Smart%20Switch%206%20gen5.pdf


(JEFF) #7

Thank You for this device handler it seems to be the most complete, I do have one issue in that it does not display correctly on my phone…the “since” box does not have enough room and the intensity bar does not appear. It works perfectly on my tablet.

Also in working with Aeon support they gave me another DH that did not work correctly so I turned them onto your DH and they added it to their website a few minutes ago.
https://aeotec.freshdesk.com/support/solutions/articles/6000086383

Samsung Galaxy S5

Samsung Galaxy Note Pro 12.2


#8

What is the minimum sensitivity of the switch hardware? I get a real measurement for voltage but zero values for all others.

Raw description from the hardware:
zw:L type:1001 mfr:0086 prod:0103 model:0060 ver:1.01 zwv:3.99 lib:03 cc:5E,25,70,27,32,81,85,59,72,86,7A,73 ccOut:5A,82 role:05 ff:8700 ui:8700

Does this indicate a misconfiguration, a faulty switch, or simply a load that is too small to register?

I’m trying to monitor pipe warming tape in a crawlspace. The tapes have a small baseline load from their indicator lights but they haven’t really been called into warming mode yet this winter.

debug got wattage 0.000
trace cmd: 'MeterReport(deltaTime: 0, meterType: 1, meterValue: [0, 0, 0, 0], precision: 3, previousMeterValue: [0, 0, 0, 0], rateType: 1, scale: 2, scale2: false, scaledMeterValue: 0.000, scaledPreviousMeterValue: 0.000, size: 4)'
trace parse: 'zw device: 09, command: 3202, payload: 21 74 00 00 00 00 00 00 00 00 00 00 00 00 00 00 '
debug got kwh 0.000
trace cmd: 'MeterReport(deltaTime: 300, meterType: 1, meterValue: [0, 0, 0, 0], precision: 3, previousMeterValue: [0, 0, 0, 0], rateType: 1, scale: 0, scale2: false, scaledMeterValue: 0.000, scaledPreviousMeterValue: 0.000, size: 4)'
trace parse: 'zw device: 09, command: 3202, payload: 21 64 00 00 00 00 01 2C 00 00 00 00 00 00 00 00 '
debug got amperage = 0.000
trace cmd: 'MeterReport(deltaTime: 0, meterType: 1, meterValue: [0, 0, 0, 0], precision: 3, previousMeterValue: [0, 0, 0, 0], rateType: 1, scale: 5, scale2: false, scaledMeterValue: 0.000, scaledPreviousMeterValue: 0.000, size: 4)'
trace parse: 'zw device: 09, command: 3202, payload: A1 6C 00 00 00 00 00 00 00 00 00 00 00 00 00 00 '
debug got voltage 123.066
trace cmd: 'MeterReport(deltaTime: 0, meterType: 1, meterValue: [0, 1, 224, 186], precision: 3, previousMeterValue: [0, 0, 0, 0], rateType: 1, scale: 4, scale2: false, scaledMeterValue: 123.066, scaledPreviousMeterValue: 0.000, size: 4)'
trace parse: 'zw device: 09, command: 3202, payload: A1 64 00 01 E0 BA 00 00 00 00 00 00 00 00 00 00 '

(Jonathan Bisson) #9

@SwitchbackTurbo yeah, it seems to be a platform display issue, It’s not the only text issue I find, the smartthing engine should really scale down to make it fit. I’ll give more room on my next update, will give 2 spot, that should fix it as a workaround.

@hkelley It could either be that the load is too small or you have a faulty switch. Can you plug something else in the switch that you know that takes a bit more juice like a lamp or something? Are you sure the switch is on?


(JEFF) #10

Jonathan,

I modified the code for my own use and made some changes you may or may not want to incorporate in your release.


#11

I plugged a worklight into the device and got a measurable load so I know the device is not completely faulty. Then I moved the device back into the crawlspace and it went to zeros again. I ran a Z-Wave repair from the SmartThings IDE and the switch is more reliably connected now.

Originally I didn’t think this was a signal problem because:
a) I was getting voltage readings
b) I have an Aeon Multisensor 6 in the crawlspace right next to the switch, and the multisensor connects to the hub just fine.

Any thoughts? I wonder if the switch is a less reliable Z-Wave device than the sensor.


(Jonathan Bisson) #12

Just to summarize:

You could see a load from location A but with the same load connected to the switch, if you move the device to a different (ie: location B), you can’t see “debug got wattage 0.000” in the logs and can see the voltage not being 0? If that’s the case, I would contact the manufacturer, might be a faulty switch.

If you are getting debug got wattage 0.000, it’s most likely not a signal issue, as the switch reported something to the smartthing hub.


#13

Yes, if I put a good sized load on the device I get normal reporting from the crawlspace.

Regarding Communication:
The only remaining oddity is the Z-wave repair. When I press the refresh button in the mobile app it seems to break the communication and it’s not restored until I run the Z-wave repair for the hub.

Regarding Data
This is what I see under typical (very minimal load) conditions. It’s odd that I get zero values for current and power, yet a non-zero value for kwh.

11:03:00 AM: debug got voltage 123.819
11:02:47 AM: debug got kwh 0.599
11:02:43 AM: debug got wattage 0.000
11:02:42 AM: debug got kwh 0.599
11:02:38 AM: debug got amperage = 0.000


(Jonathan Bisson) #14

Do you have a voltmeter or an amp-meter that you could verify the load? I’m wondering if your load is bellow 1watt. If you leave the load for longer than an hour, do you still get 0.599 as the kwh ?

The kwh is probably the average power of the last hour, if I would guess so if you had any load within the last hour, that would explains why you have something on the kwh but not on the wattage.

Again, best would be to check the load in an amp-meter to see how much you get there. It might just be because your load is less than 1 watt ?


(Matt) #15

I might be a bit slow, but how do you change the LED color? I see the dial, but when I move it, the color of the switch doesn’t change.


(Daniel) #16

@jbisson, I have both of these devices and I like these DTHs. I have one request. Can you add a “Cost” tile. The cost/kWh can be an input and the tile can display the cost based on the total power consumption. When the Energy consumption is reset, the Cost would be reset too.


(Daniel) #17

You can only change the color in Nightlight mode:

  • The brightness intensity only works in energy mode (does not work in nightlight mode)
  • You can only change the led color in nightlight mode

(Matt) #18

Yeah, I got that. I put it in nightlight mode, select a different color on the dial and nothing happens.


#19

I’m trying to get this device handler to work but I get the following error when I try to turn on or off the switch.

groovy.lang.MissingPropertyException: No such property: value for class: physicalgraph.zwave.commands.switchbinaryv1.SwitchBinarySet @ line 255

it is properly reporting the energy values

I’m new to this and would appreciate any help!


(Matt) #20

@jbisson @Alwas So I think I figured out what the issue was with the nightlight.

I looked at the device handler and I didn’t see “command “setColor”” listed with the commands. I added that after command “nightlight” and it’s working for me now. I did try a different device handler for a bit first though so I don’t know if that had any effect.