SmartThings Community

All devices show "disconnected" except new TV


(D Sterne) #1

I have been using SmartThings for a couple years and started the migration to the new app. Everything still works in the old app, but the new app shows all my hub connected devices as “Disconnected”, and I cannot figure out a way to fix this. I recently got a new Samsung Q6F TV which works just fine in the new app, yet the other devices all still show “Disconnected”.

Is there any way to force a refresh or anything to get the devices to function properly in the new app?


(jkp) #2

If the devices are using custom device handlers, there are some you can edit and add some new code to get them to work in the new app. Read the following post


(D Sterne) #3

Some of the devices are using custom device handlers, but not many. The devices are GE Z-Wave dimmers, Wemo switches, Wemo outlets, Sonos speakers, Ring Doorbells, Philips Hue, and a few other types.


(jkp) #4

The wemo outlets, sonos speakers, hue bulbs and ring doorbell should all work in the STSC app using stock device handlers from ST. One thing you might try is opening the device in the ST classic app, click the cog in the upper right of the screen and click Save. Then refresh the STSC app and see if the device is working.


(D Sterne) #5

I tried the cog->save->refresh, but still nothing. All devices except the TV show “disconnected”.


(jkp) #6

Contact ST support at https://support.smartthings.com

They should be able to help identify the cause.


(David Sacks) #7

This is exactly what happened to me. My SmartThings hub and devices have been working flawless for years. I just bought a Samsung Q6F TV and now everything shows as disconnected. I’ve tried rebooting, re-adding and nothing seems to work. Did you find a solution?


(Stephen Hewetson) #8

Did you manage to fix this? I’m having the same issue with my hue bulbs showing as disconnected but they still work fine in the old app. My TV works fine in the new app though.


(Roger) #9

I have the same problem, everything but the TV is disconnected. Even the hub, but it’s all good in classic.


(Mario Alvarez) #10

REPLY

i have both apps and i can see and manage all my switchs and hub on the old app but on the new one they said disconnected. a lot of them.


(jkp) #11

(Tom Capote) #12

I have the same issue, all my devices work fine in Classic, but not in Connect, many, not all, show disconnected? This is on iOS, i’ve done basic troubleshooting, no luck.


#13

Same issue here, I rebooted my hub and most of the disconnected devices now show up. Only two are stubbornly showing as disconnected. Otherwise everything is working ok, all commands work, even to devices shown as disconnected. Smart things Classic app and IDE show all devices connected, it’s only a problem with the Smart things Connect app.

Same with both the Android and iOS versions of the app


(Kevin) #14

Hi let me know if you get a solution. I found that the device handlers disappeared from the HUB https://graph.api.smartthings.com/ that were there and now the new connect app shows them disconnected. I suspect because the now have some generic device handlers.

I wonder what happened with the device handlers that where working as of a few days ago.

Thank you,


(Shawn) #15

I now have about 85% of my devices all showing disconnected in the SmartThings application. Funny thing is that they are still automated and controlled by my routines in the Classic applications. How can I fix this?


(Thomas Jose) #16

I have the same problem. Almost all my devices show as disconnected in the Samsung Smartthings app. The only devices that do not show as disconnected are my Samsung TV and my devices under Nest Manager.

Even though devices show as disconnected my routines still work. I can also still control the devices through the Samsung Smartthings app such as turning on and off outlets and switches even though it shows as disconnected.

Using the older Smartthings all of the devices show up normally.


(Don Caruana) #17

Not only am I seeing this, but it’s happening with standard devices (like the smartthings plug that came with my original kit) as well as custom. My zooz switches are fine, my ge switches are not. It’s a mix of custom and standard handlers. I can find no common thread - routines, integration, device type, etc. It seems completely random.

The weirdest part is that even though they show as disconnected, I can still control them from the new app.

I also noticed that the new app isn’t reflecting the current device names as well. A few new ones I changed after adding them and the new names aren’t in the new app.

Of course, everything is perfect in the classic app.


(Chris Pickering) #18

Same here. Frustrating


(Carl Folke Henschen Edman) #19

Ditto. Over hundred devices almost all of which work under the Classic app and other sources, like ActionTiles (highly recommended, BTW), with the remainder explained reasonably (e.g., being temporarily unplugged and the like).

However, under the new SmartThings App under iOS (current and going way back), more than half of the devices are listed as disconnected and cannot be controlled.

I doubt it is custom device drivers or network problems. They respond just fine under the other software and sometimes completely identical devices feet apart in the same room (and officially supported by SmartThings without any device drivers ever) will have one shown as connected and one shown as disconnected.

Rebooting the hub, repairing the Z-Wave network, setting it and the Zigbee network to the most permissive mode, attempting to reconnect to the hub all failed.


(Jimmy) #20

Has anyone gotten a response from support? Especially is device names don’t match. Especially is you’re using standard device h handlers. Sounds like there is something out of sync between the two environments. When I first started using the new app many devices were plain missing and support was able to run a sync job and everything is golden now between the two apps as far as status goes.