Problems with missing devices when transitioning from classic to new app

Hi all - I’ve been a SmartThings user for many years, but have always stuck with the Classic app as I found the new app to be clunky and unresponsive.

With Samsung booting us off of the old platform, I’ve finally made the switch. However, I’ve got a pretty big problem – half of my devices disappeared after making the switch. However… they haven’t disappeared so much as they’re just not accessible from the new app.

On the left is a list of devices available in the new app. On the right is a screen from the settings in one of my SmartApps, where it shows a number of additional devices - but this is the only area I see them within the new app. They are not on the Home screen or in the Devices tab at all.

I also oddly have a HUGE amount of what look like virutal devices - perhaps these are artifacts from my SmartApps, or from the IDE? I’m really not sure, but there are hundreds of them and they all show as “Offline”:

As for the switches that are missing, I’ve found a pretty consistent pattern that the switches that are bound to at least one SmartApp are not showing up. The devices that are not associated with any SmartApp are showing up. All of my SmartApps still function properly - I just can’t seem to get to the devices they control.

I’ve tried contacting SmartThings support - so far I haven’t managed to hatchet through the back-and-forth obvious requests to delete and re-install the app, log out and back in, reboot the hub, etc.

Do I need to delete and re-install my SmartApps? Or do they need to synchronize something on the Samsung servers? Is there any way to remove the “virtual” devices?

Any help would be appreciated!

P.S. - if anyone has any tips or tricks for optimizing the performance of the new app (which so far has been a big step down from the Classic app) please point me to them!

i would switch to different platform just like in old days during MS browser war

The syncing processes from legacy to current environment are imperfect. It seems you are one of those that have encountered the edge conditions that cause problems.

The strange devices on the app are probably old devices you have deleted, or something like that. I had loads when I started using the app instead of Classic. Imperfect syncing again.

Your SmartApps are running in the legacy environment so see all your legacy devices.


It appears all devices have disappeared now and my hub is reporting as offline. SmartApps have stopped working.

I tried power cycling the hub and rebooting it via the IDE (My Hubs > Utilities > Reboot Hub) with no luck. The light on the unit is solid green. I have the wifi/hub combo, and the wifi portion is working fine.

@Brad_ST Could really use your or one of your colleague’s help…

Which hub do you have?

As for the missing devices, try opening the devices in IDE, change the device type, save, change tHe device back, save.

Can you add a room in tHe new app?

Here’s the weird part - all of my devices aside from those collected by third parties (Arlo, Ecobee) have also disappeared from the IDE. They’ve now vanished from both the IDE and the app.

I’m pretty sure I have the 2018 hardware… it’s the hub that’s combined with the mesh wifi:

Here’s the firmware information being reported by the app:

Yes, it appears I can add a room in the new app.

Have many locations do you see in IDE?

Just one location in the IDE, “Home”.

It appears the last ping response from the hub was last night, at around the same time that I logged into the IDE for the first time in a while. I wonder if there’s something to that or if it’s a coincidence? I’ve read that some sort of connection is made upon logging into your Samsung account.

Under “My Hubs” in the IDE, I just noticed the hub’s status is listed as “INACTIVE”.

I can suggest a few things to try but I believe you will need ST support at this point.

  • unplug the power cord and Ethernet cable (if using)
  • wait a few minutes
  • reboot router or modem
  • power ST wifi back up, perhaps switch out the Ethernet cable and/or move it to a different port on switch or router

Tagging @Brad_ST

I’ll give that a shot, thanks. The fact that the wifi portion of the unit is still working fine means it presumably still has a network connection, but I’ll power cycle everything to see if it helps.

My hunch is that there’s some sort of data synchronization issue between the unit and the Samsung servers. Support appears to be completely overwhelmed, though, and getting a case escalated seems to be near impossible.

I agree it sounds like a sync issue but the hub being offline is strange and the devices missing from IDE.

It does look like the hub portion of the device may have been reset. Arlo and Ecobee are cloud-to-cloud and wouldn’t be impacted by a hub reset. Did you try powering off the hub/router for a few minutes and then power it back up? Do you see the router device in the new app? If so, can you tap on it and then tap “Use SmartThings Hub”? I am curious if the toggle shows as enabled. I hate to say it but as the hub-connected devices are gone, they’ll need to be reset/re-added and it may be best (and quickest) to delete the hub from the IDE and then re-add it as well.

I did try powering the hub off and on and it didn’t help. Is there a particular time I should keep it unplugged?

I see a “SmartThings Hub” in my list of devices in the new app. It shows as “Offline”. When I tap on it, I get this screen:

When I click the 3 ellipses in the upper right, I get the following options:

Z-wave utilities

When I tap the “Edit” option, I can rename the device. I can also change its location or room, but these options are grayed out and disabled.

I can’t seem to find any option in the new app to “Use SmartThings Hub”.

Do I need to factory reset the hub, or can I just delete it from the IDE and re-add it from the new app? I’ll need to exclude each device before including it again, right?

Do you have any idea what happened so that I don’t do it again?

This was the toggle I was referring to but I was able to get a SmartThings Wifi into a similar situation and could match your screenshot above but the app didn’t show the screens below.

I can’t tell what ultimately caused the issue. The logs appear the same as if a physical reset was performed. It definitely doesn’t sound like you caused that to happen though. My best guess is that there was a discrepancy between the Classic and new apps. I do think something unique/odd was at play. I’ve never seen anywhere near that many simulated devices before.

Once reconfigured and properly synced, I really don’t foresee further issues like this. Definitely frustrating and I am very sorry but am happy to help where I can. I can check everything is synced properly as well. I did try for quite some time to see if there was a way to recover without a reset but I wasn’t ever able to get something to work.

The hub will need to be blinking red/green to re-add and I am almost certain the only way to do get there is to factory reset the hub. The Z-Wave devices will need to be excluded first. Again, super sorry for things to come to this but I feel strongly this was a extremely rare one-off issue. Let me know if I can assist in any way!

Thanks - I do appreciate your help. No worries, I understand that systems like these are hard to manage and things can go wrong.

I believe I’m back on track now. You’re right, I did not see those screens in the state I was in, but after a factory reset, I see them now.

Aside from factory resetting the hub, I also had a phantom simulated device showing up in the new app that I could not delete, and it wasn’t showing in the IDE at all. With the advice I found on the forums, I had to create a new location to get rid of it. After deleting my old location and all of my installed SmartApps (figured I may as well do a clean sweep) I’ve begun the process of excluding/including my devices at my “new” location and so far it has been smooth sailing.

Regarding what happened, I do recall the moment the hub “died”. I was trying to figure out where the phantom devices were coming from and logged into the IDE to investigate. Not too long afterwards, I got a notice that my internet had dropped. Since I have the wifi/hub combo, I assume the unit had rebooted. Shortly after, the wifi portion came back but the hub never did.

Regarding the huge amount of phantom devices: I write my own SmartApps, and I recall doing a lot of testing using the IDE’s simulator feature. Many of the names assigned to these phantom devices in the new app were identical to the names given to the fake devices in the simulator. Perhaps there’s some connection there?

One benefit to doing this is that the new app is quite a bit snappier now that it doesn’t have to try refreshing the status on around 100 devices that don’t actually exist! :rofl: