Nothing but problems with new App (June 2021)

Lost devices won’t connect takes forever to load you name it this update is terrible!

The new app is very poorly designed and it loads very slow and is pretty much in useable as it is come on ST fix this !

1 Like

samethings with me, hope they will fix this soon, itès terrible take too much time to load with my sound bar samsumgs 950T

Same. I can’t add IKEA outlets anymore or ecolink zigbee door contacts which I had no issue adding on the previous app.

Is there another way to add devices?

Since it was updated to the new latest app, which looks nice, but it continually tells me there is a connection error…which I’ve never had before it was updated…I thought maybe if I sign out and back in that might help…I now have no devices showing at all EVEN WORSE!!
I have emailed support but still not heard anything…

1 Like

I have the same issues and it’s gotten worse over the last several days

1 Like

Likewise. Cannot connect to any devices at all.

2 Likes

Yeah same here. Noticed the app had changed when I went in randomly tonight. I now cannot see the status of any of devices in any of my 3 hubs. All 3 hubs in different locations. How do they manage to trash my system with every update? Shall I just wait for a fix or does anyone know any way of fixing this ourselves. It feels like they are trying to drive people off their platform. There’s something seriously wrong with Samsung’s QA.

Had issues at first, then simply reinstalled the app (ios) and now everything is about 10x better than before. Buttons load up and respond instantly, and even the wife is happy!

1 Like

Ok I tried the reload the ap and yes it made some issues better for sure, but why in the hell doesn’t ST tell us that, I still have devices that it has not found and lost set ups for Aerno Remote and other items even ST motion sensor is not connecting. Gee wiz every update is a crap shoot if anything will work.

1 Like

Before deleting the app from my iPhone, I checked on my girlfriends iPhone and she didn’t have the same issue, so this looks localized to specific clients (in this case my iPhone). I have no idea why the new SmartThings app would bork on my phone and not my girlfriends (same iPhone model and iOS version) but anyway, after deleting the app (and the data) and reinstalling from the App Store, I can now see the status of my SmartThings devices. I wish Samsung would email their customers before doing such updates so we can at least brace ourselves for the havoc.

Like others, I can attest to the fact that on my iPhone Xr, the solution that worked was this:

  1. I did not sign out of the app.

  2. Deleted the app from the phone completely.

  3. Reinstalled app from the app store.

  4. Launched the app, got the welcome tour, was presented with sign-in button, and everything was back where it belonged.

What a process; at least nothing was lost.

I have an iPhone Xs, on latest 14.6 ios. I have two hubs at two locations. One of the locations lost all of the devices except for one. The other seems fine.

I followed steps by ScottSn, but it did NOT fix my issue.

I’ll deal with it in the morning… Big sigh

Ok, it’s morning. I checked in the smarthings IDE and all the devices were there. So I rebooted the hub, it’s a hub v2, US customer Rev E. Now I can access the other devices.

OK gee wiz this just continues to be a problem, loosing my devices, can’t see them in the new app. Things take to long to load and it goes on and on. Come on SmartThings fix this new application it is terrible, and it just gets worse day by day with the stuff not working, were going back to the beginning of ST, lots of issues never get it fixed the first time.

Hi,
I have performed this step twice already with iphone x but I keep having problems.
I see the devices correctly but if I try to use some switch it doesn’t respond and says “network problems” or as soon as I open the app it’s as if it doesn’t update the status of the device.! Desperate how can I do?

1 Like

Same issue here… Everything before was working (albeit slow), but at least the status of a device was correct.

Half of my devices on the main screen and rooms show as “On” even though they are off.

If I click to see more (rather than tapping the tiny power button), this loads the correct status. If I come back out of that, then the main screen still shows incorrect status.

I think I have finally got to the point where I am going to ditch the ST ecosystem, Smart tech should be almost set and forget with the knowledge it is running properly and doing what it is meant to.

When iver Goodbye or goodnight etc run, I feel the need to double check its done everything it should have done which obviously means I have zero trust in it.

So I’m with you, the new app sucks and keeps getting worse. My question is what’s the alternative. I’ve been using smart things for years I’m working really well and now I’m fth

For a short term fix, try a an App called Home Remote

No doubt Samsung are trying to fix the app but until it is a better version Home Remote should help

It ties into ST giving access to all of your devices, you cannot edit or create automations though

Since this terrible, horrible, no good, very bad app has been released I’ve been relying mostly on
a) ActionTiles for accurate device status
b) webCoRE for automation

Also, Google Home and Alexa apps can now tie in with SmartThings for status and/or automation purposes, although I haven’t tried these two apps for automation yet.

It’s just pitiful that Samsung/ST have not even at least said, hey, we’re working on the app issues. The silence is deafening and frankly, insulting after all the promises over the past several years, especially with what some of us have invested in this platform.

But hey, we’re getting hub FW updates that have ‘improvements.’

Guys, if ANYONE is listening, please please address the atrocious app response/update issues. All the other ST updates are pointless if you can’t get the basics working properly.

This is not rocket science. It’s about applying the right priorities. Something Samsung/ST appear to have terribly mixed-up.

@Brad_ST @jody.albritton @SamsungZell @blake.arnold

1 Like

Agreed it’s is rendered the system useless thanks SmartThings time to move on ! This has been a total failure!