Device driver v1 for aeon smart switch 6 gen5

aeotec
dth_pocketsocket

(Larry) #1

This is a work in progress more features coming
I am modifying the stock smarthings device type code to support many more features of this switch

Specifically there are multiple modes

  1. energy - the default where the color changes based on device draw.
  2. momentary where the above happens and the light shuts off so you an use it without annoyance.
    and
  3. night light. where the light stays on a specific color as a night light.

I got the above working with a toggle state tile.

I also added is support for a voltage tile

also now in v2 got the color changer in night light mode (only) working, and the brightness slider
in momentary or energy modes working. They only work in these modes as this is a limitation of the device. Not sure why they did it this way as brightness would be nice in night light mode also.

http://www.pepper1.net/zwavedb/device/722
I added a factory reset under a reset api./tile and it also reset overall kw hours.
Also implemented the refresh api…

Also added a configure api which configures the device to enable certain fx’s (i got the starting code from someone else and changed it where it was incorrect, it configures the device to enable the voltage readings etc.)
here is the current source code and a couple of picts.

V3 will have some neat new features … stay tuned

http://mail.lgk.com/myaeonswith6v2.txt


(Larry) #2

new version slight layout change as also now got amperage working.
A couple of bugs fixed… was resetting to night light mode left in for debugging in one place.

still dimming and rgb not working…

version 1.1

http://mail.lgk.com/myaeonswith6v2.txt

also increased poll time to 2 minutes… was doing it every 3 seconds before… watts is still instant but the others are every 2 minutes.


(Tyler) #3

Hi Larry,

Side-topic question: Does a more frequent poll time slow down network traffic across the Z-wave mesh?


(Larry) #4

Not sure but I imagine it sliws down stuff depending on hub load. Also definitely internet as it is all sent out to the cloud eventually.


(Larry) #5

got this completely working here is version 2… thank to ron for help…
The issue was a strange one… could not have anything in the color or brightness fx after the configuration setting… not even a debugging statement go figure…

anyway I got the color and brightness sliders working and the icons now save state between runs.

Also I will be working on V3 now with some fancy color changing stuff when in night light mode
stay tuned…
Also as before is has voltage, amps and watts monitoring.

http://mail.lgk.com/myaeonswith6v2.txt


(Rick R.) #6

Works great here, thanks a bunch for this.

One thing to mention, this only works if the device is added through a regular include (single tap). If you add the Smart Switch 6 with a secure include (double tap), SmartThings picks up the device as “Aeon LED Bulb” and nothing works correctly. Changing the device type doesn’t work as well. I imagine there’s something different needed for encrypted Z-Wave communications available with the Z-Wave Plus specs.


(Larry) #7

How did you even get it to join as secure I tried and tried to test alternative function and never could get it.


(Rick R.) #8

Sorry just saw this, didn’t mean to ignore you. Hit the action button on the Aeon twice within one second and it does a secure include. It’s buried in their manual (admittedly not very detailed manual):

In order to take full advantage of all functionality the
Smart Switch, you may want your Smart Switch is a
security device that uses secure/encrypted message to
communicate in Z-wave network, so a security enabled
controller/gateway is needed and then you need to
press the Smart Switch’s Action Button 2 times within 1
second when your security controller/gateway starts the
network inclusion.


(Larry) #9

Ya tried it right next
next to hub …never got it to work.


(Rick R.) #10

That’s strange. I have one I haven’t put in service yet. Just tested the double tap, the Hub sees it as “Aeon LED Bulb” just like the rest. I’m testing one floor up from the hub, so probably about 15 feet away. If I single tap your device type I have installed picks it up. Exclusion is always a single tap, regardless of whether you double-tapped or single-tapped for the include. When excluded the LED cycles through the rainbow, if you’re not seeing that you might want to factory reset it.

Other than that I am not sure what to say, maybe a defective unit? Or have SmartThings support take a look? I have eight total and they all have worked the same for me.


(Justin F) #11

Sorry if this is off topic, but I’m trying to get my hands on this device. Where did you guys buy your Smart Dimmer 6??


(Ron) #12

Not sure why he calls it a “smart dimmer” it is a Smart Switch. The “nightlight” feature is supposed to have dimmer capability but this is NOT a dimmer switch if that is what you are looking for. If you know this is a smart energy meter switch then you can buy it at amazon.


(Rick R.) #13

@Ron is correct, this is a regular on/off switch. The LED has dimming capability but this does not extend to the load.

Aeon Labs has announced a dimming version, but to my knowledge this has not been released yet. The device type in this thread is for the regular Smart Switch 6, NOT the as-yet released Smart Dimmer seen here: http://aeotec.com/z-wave-plug-in-dimmer


(Hugh Ehrenberg) #14

This is all kinds of awesome. Thanks for saving me from returning these really nice plugs. I changed the Device Type in the IDE, and now see all the functionality tiles you mention. But when I hit “configure”, and look for the sliders you mentioned, nothing happens. Do I need to reboot the hub or the app to get this to work completely? I’m just so happy to have the thing work!!


(Larry) #15

you should be running v2… what is the version


(Hugh Ehrenberg) #16

000.014.00022. And yes, hub v2, with version 2 of the device posted above. I found (duh) the color wheel by scrolling down on the app. I have some odd behavior of these switches still. They do not report their status change after following a command. They turn on or off via an automation, but whatever their last state was remains on the app, and manual switching isn’t working. They follow rules fine, but cannot be operated otherwise. And then sometimes after being turned off manually (when it works), it reverts and turns back on. So odd.


(Ron) #17

You are correct. I didn’t notice that because I never use the manual switch. Seems harder to bend down to press the tiny button on the plug when I can just press the button in the app or better yet ask Alexia to do it :smile:

I will have a peek at the code and see if I can figure out why it isn’t reporting state. Hopefully it is just a device code error and not a firmware glitch which isn’t sending the zwave signal.

UPDATE: Bad news, I put logging in each of the zwave events including unknown. When manually pressed the plug does not send a zwave event. I notice if you press refresh the correct state is displayed. So this in not good because it means the device relies on it’s polling method to maintain state. With SmartThings you are out of luck if your device requires polling because the ST engineers have been incapable of fixing polling since before I joined ST over 1 year ago. Pollster works sort of but not great. There is an app out there that I have not tried yet that uses another device on your network which sends regular events to trigger other polling. I haven’t tried it yet because I don’t know which device I have they regularly reports. You could also add code to the device to schedule polling. Scheduled events are slightly better these days but they still fail randomly. Another think ST engineers have not been able to fix even with the V2 hub which was supposed to be able to handle events locally getting rid of the cloud issue. V2 scheduled events should be very reliable if they only implemented that.


(Hugh Ehrenberg) #18

That’s another wrinkle entirely. Very interesting. Like you, I’m not getting behind the bed to hit the button manually. I’m talking about through the app. I can turn something off that is on, or on that is off, but that’s it. The app does not recognize the change in state that has just happened after a command got sent, and then it won’t follow another command sent by the app to do the opposite. The only command it follows is through an automation, but again, not recognized by the app. It’s the same problem, but different?


(Hugh Ehrenberg) #19

when the device type is changed in the IDE, should the hub be restarted?


(Rick R.) #20

To add another wrinkle here.

Prior to last week’s 14.22 firmware update, when I would send an off to these devices, it would turn off, and then an ON event would be reported, followed by another off event. I assumed this related to either the LED changing state or the device still sending metering data. It was an annoyance, the state of the load plugged in to the switch didn’t change, so I didn’t pay it much attention.

Beginning sometime last week, the switch does the same behavior except it shows up in ST as remaining on. If I toggle it off in the app it shows up as on within a few seconds, but the load remains off.

I can’t say for certain the behavior changed after the firmware update, but I don’t remember ST showing the switch as on when it really wasn’t prior to last week (other than the brief on then off scenario described above).