Aeon Labs Z-Wave Smart Energy Switch not working properly


(Tyler Jensen) #1

I have a handful of smart energy switches (model #DSC06106-ZWUS) that suddenly started having problems after the new app rolled out a few weeks ago:

  • Often times the app thinks the switch is not in the correct state (.e.g. shows it’s off when it’s actually on)
  • If the switch is used within a smartapp or hello home action, the app/action will turn the switch on, but will not turn it off
  • Hitting the ‘refresh’ button on the switch doesn’t actually show the correct state.

Has anyone else seen issues like this? It’s really annoying since a lot of my stuff now doesn’t turn off when I get to bed or leave the house.


(James Pansarasa) #2

Are you using the SmartThings device type code or the custom device type from the thread “Aeon Labs Smart Energy Switch DSC06”?


(Tyler Jensen) #3

I used whatever the device identifies as within the app. The developer page shows the type as “Z-Wave Metering Switch” with a description of “0 0 0x1001 0 0 0 a 0x25 0x31 0x32 0x27 0x70 0x85 0x72 0x86 0xEF 0x82”


(James Pansarasa) #4

The you are using the SmartThings provided device type.

If you feel adventurous, try switching the device type as referenced in the other thread. I am the author of that device type and it was written specifically for the device you are using. Most people who use it find it do be more reliable than the stock “Z-Wave Metering Switch”.

There are several steps to adding a custom device type using the SmartThings developer IDE (which I won’t reiterate here since I am sure someone on this community has a better explanation on how to do it than I will do here). It is not that hard to do to be honest.

Good luck.

James

EDIT: Here is a link to the documentation
EDIT 2: Here is a good article FAQ: An Overview of Using Custom Code in SmartThings


(Tyler Jensen) #5

I added your code as a custom device type and switched them over. It does seem to work a lot better, but one switch in my bedroom is still having issues. Initially I thought its placement was affecting it (it’s buried under my bed in the far corner of my room), but it only seems to be a problem with turning off, it always turns on fine. With the new device type it’s either really delayed or or doesn’t turn off at all, so I’m a little closer. I have a spare switch I’m going to swap out in case it’s faulty hardware. I’ll let you know how that goes, thanks!


(Stacey Dyson) #6

Did you get this figured out? I just received my smart energy switch today. It consistently turns on okay, but it will not turn off using the app on my phone. I tried the code linked to above and that doesn’t work either.

The weird thing is that it works perfectly in my living room, but when I move the device to my garage it will only click to the on position and will not turn off.


#7

I’m having the same issue. Tried both https://github.com/jpansarasa/SmartThings/blob/master/DeviceTypes/AeotecDSC06.groovy and Mr. Lucky’s modification. The device turns on via the hub, displays power usage, but doesn’t turn off always, or only sometimes. I tried excluding/re-adding device, but it didn’t help.


(Jeff L) #8

I think these switches have some problems. Mine is less than 30’ from my hub and after assume period of time it just goes dead. No response from ST. If I manually cycle the switch it starts working, but after a while sitting… It goes dead again. Very frustrating. My older generations aeotec switches all work flawlessly all over the house.