Apparent 1 way communication to zwave device

Hi all,

I am new to this forum & have recently purchased a smartthings v2 hub & configured 2 of the following devices:

Aeon Labs Smart Energy Switch DSC06

One of my switches I am using to power a relay that turns off/on my electric water heater. The other switch I am simply using as a repeater as my water heater is in the garage & I was concerned about the distance from the hub to the switch, although it seemed to work fine without the repeater switch.

While in my home where I have the smartthings hub & switches all worked fine without a glitch for at least 1 week after installation.

Then, when I left to return to my principal home, which is 700+ miles away (last monday 1/18/2016) it started acting up.

No matter what I do the switch seems to remain in the on state. I have verified this by looking at the events received. Energy and power events continue to update showing a constant power of 4 watts despite attempts to turn it off. Also refresh events do not clear out the cummulative energy usage counter, but are shown in the app and in the IDE web based interface.

I have since installed a new custom device provided by JAMES PANSARASA (jpansarasa), which shows up in my app, but does not improve or fix connectivity. Thanks very much James for your hard work on this custom device!!

I have tried pinging my hub, which seems to work just fine.

I have tried rebooting my hub, which works but doesn’t fix the problem.

I have also tried repairing my zwave network which doesn’t help either unfortunately.

On interesting tidbit is that on tuesday 1/19/2016 I discovered it not working, but on wed 1/20/2016 it started working again for a few hours, then starting yesterday it is not working anymore.

I suspect that events are being sent from the switch/device & received by the hub & forwarded to the clould & my app. However, My suspicion is that the events coming from my app for off/on, refresh, etc. are not making it to the device/switch, although the events are definitely shown in the event log.

Any ideas as to why this is happening & any possible remedies I might have at my disposal would be most appreciated. I am hoping that this is something that might be able to be fixed remotely, although that is probably just a dream;-)

Thanks so much!

Brian Hiltscher