Aeon Labs Energy Meter clamps

I am working on this project right now. Was there any progress on an Energy/Power Meter? I’ve got the Arduino board and several CT sensors that I’ve wired up to measure power to individual circuits at the breaker. I’m very close to having everything working without the SmartThings shield and code–still ironing out a cumulative power error I found in my code. Should be spending time on it this weekend. Would love to know if other are working or have worked on this.

I’m hoping that I can send data from 16 CT sensors back to my SmartThings app on my phone! Maybe I can have icons for each circuit color coded??

Aeon Labs Smart Energy Meter won’t connect to my ST’s hub. Any ideas???

@urman – hey! Any word on metering (of any kind)? I just reviewed the last 6 months of my electric bills and it’s UGLY…

@radiogavin the CentraLite (new SmartPower Outlets we sell) have active power metering. As far as the old SmartPower Outlet (SmartenIT) we’re waiting on the broad roll out of new firmware.

But the Aeon whole home energy clamps have been reported working.

OH also Wattvision is looking solid.

What we don’t do well right now is graphing. Need to figure that out.

1 Like

Any updates on the Aeon Z-wave Smart Energy Switch? Is power monitoring working with smartthings yet?

@somas1 the Aeon Z-Wave Smart Energy Switch has worked for a while I believe.

I have my Aeon Labs Home Energy Meter ( http://amzn.com/B00DIBSKFU ) working! Using the Aeon Labs Minimote ( http://amzn.com/B007J26PIS ) made it easy to get the energy meter to connect to my smartthings hub.

Has anyone noticed the Aeon Energy Meters reporting phantom readings? When I plug in the clamps this meter reports between 7-14 watts of power flowing even if the clamps are not installed. If I unplug one clamp the phantom reading is cut in half and unplugging the other clamp the reading drops to zero. The wattage error isn’t that much but over a months time it adds up to to many kilowatts above what I actually use.

Paul,

Based on your comment I bought a aeon minimote, that connected no problem, but I still can’t get the energy meter to connect. Any suggestions?

Just received my smart energy meter v2. Keen to read bout how to pair it and to use it with Smartthings.

I just got one today, was able to pair but SM app thinks its a outler switch. To pair I had to plug and unplug and then one time plugged in, held button on back until red light flash fast let go, held again for one second , light continued to blink slowly then blinked fast and paired, maybe 10 seconds.
Any app help?? or configuration help. I do not have the mini hub, do I need one of those to get readings?
Thanks!

You need to change it to the Aeon Energy device type in the IDE, if it’s a V2 you’ll probably need to install that custom device type first and then change to it.

2 Likes

mattjfrank, thank you very much. had to google “smartthings ide” did not know what it was or that it existed!!! Changed the device type like you said and now it looks like it is reporting - 1014 watts, if I go to activity feed it is up and down and looks to be reporting multiple times a minite. Very Cool!!! Thanks again!!!

1 Like

im considering getting one, what kind of information is being displayed in the ST app?

HEM v1 shows kwh and watts. I was able to pick one up on amazon for 35.00. HEM v2 shows amps, volts, kwh, and watts among other improvements.

There are extended apps for both that will show cost and extra info using the data from either.

1 Like

I got one of these (Aeon Labs HEM v1) and updated the firmware and was able to get it connected to hub and the Device Type associated… but not currently working.

I’ve had a couple messages in an old thread electric company related thread, which I’m moving to here because it is more topical:


I’m no expert on my circuit breaker box, but have a basic understanding of what two phase house input wires should look like … two thick wires incoming from the electric company meter (and one thick common neutral).

Close enough (but not exactly) what is depicted on Aeon website:

There may be some more detailed PDF documentation somewhere (not in the package!), but this seems clear:

http://aeotec.com/z-wave-home-energy-measure/918-home-energy-meter-instructions.html

However: Let’s say only one clamp is working – would that clamp be able to read anything from the one phase? Or must both clamps be functioning?

Is there anyway to build a test setup against a standard 120v extension cord (well… one clamp around the hot wire, other around the neutral, …?).


Thanks for the link – It is much more practical (and safer!) to debug this with a little 120v cord line rather that poking around in main circuit box.


The Device was recognized automatically by SmartThings as:

No configuration errors, but no meaningful events:

But I don’t know if the selected Device Type is the correct one (it is a v1 of the meter, and I upgraded the firmware before adding to network). I only see one Aeon Home Energy Meter Device Type available published.


Yup. “Clicking” the configure tile does not appear to do anything, but that’s a user-interface limitation, I suppose. It should change color for a few moments or something!

But the detailed event log shows configure requests. I’ll have to put this aside for a bit until I splice up an old extension cord to test & debug with…

…CP / Terry.

1 Like

Found this…

Looks like what ya need

Can someone help me with upgrading my firmware for this Aeon HEM?

I’ve uploaded the latest firmware to my web drive; but you could / should check the Aeotec official support page. Make sure you know if you have v1 or v2 of the HEM.

DISCLAIMER: Also … I have no idea if this “new” firmware breaks or improves functionality with SmartThings.

http://www.cosmicpuppy.com/SmartThingsAssets/Home%20Energy%20Meter%20V3_64%20US_200A%202_phase%2020120615.exe

…CP/Terry.

Thanks…! But that Device Handler (with fingerprint set to v1) gives an error in the configure() method…

81d9181d-48cb-4caa-9b35-567c90d55103 4:29:24 PM: error java.lang.NullPointerException: Cannot invoke method toByteArray() on null object @ line 796
81d9181d-48cb-4caa-9b35-567c90d55103 4:29:24 PM: debug configure()

But it is reading 47W on a test lamp and extension cord I’ve rigged up… so that’s good!!!
Correction: Barry’s version of the HEM driver hadn’t quite clicked in yet, perhaps; now all the tiles are “–”.

More debugging, I guess…

Who is Barry A. Burke: Not atburke85 … There isn’t a “@Sandood” here…
Ah – it’s @storageanarchy!!!

Thanks Cooper and Barry and all!
…CP / Terry.