Troubleshooting Aeon Labs Home Energy Meter v1


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #1

I just got two of these (the old, v1 version) recently, and can’t get either of them to report.

When I pair them, they pair immediately as what seems like it should be the correct device type automatically (Aeon Home Energy Meter).

However, they never report.

I have also tried a couple of other community-created device types. With one of them, it changes the look of the device in the ST app, but doesn’t report, and with the other one, it completely disables my ability to even go into the Things list in the ST app, and I have to go to the IDE to change the device type to something else to get back in with the ST app.

Since neither of them are working, I sort of assume I’m doing something wrong, but perhaps they are defective?

I started a support case with SmartThings, and they are working with me on it.
They suggested that I also start a thread here to see if anyone can lend a hand while I am waiting for them to respond (backlog).

So…would anyone familiar with (and who uses these) be willing to help me troubleshoot?


Aeon Labs Home Energy Meter
NEW: Aeon Home Energy Monitor v2 Device
#2

@sgnihttrams, sure! A few questions to start:

  1. Are you running on batteries or AC power?
  2. Depending upon the device type you are using, have you tapped on the Configure tile for the device in the phone app?
  3. What events does the IDE show for the HEM?

I’ve been using a device type I cobbled together from many other Community members, if you’d like to try that as well:

https://raw.githubusercontent.com/constjs/SmartThings-Devices/master/aeon_hemv1_v3.device.groovy


(Herbert Carroll) #3

I’ve had mine for a while and it suddenly started acting weird and no longer reported values either. I’m using sandood’s device type and realized the events that reported power were values of at least 6 digits. All the events were being ignored because they exceeded the MAX_WATTS value.

I changed the code to divide the results by 100 and I got values that looked correct. So I’m using it now but the kWh cost is totally off. Assuming some similar problem.

I meant to ask if anyone else was experiencing this. I assume something might have gone wrong with my device, but I wouldn’t be totally surprised if it was due to some server side change.


#4

Yes, and with my device type based off of the same device type as yours. I have an energy alert smartapp set up to notify me when watts exceed anything above normal for my home. I haven’t experienced that in a very long time with the HEM v1, but I do get it a lot with my Aeon Metering Switch switches I have on my washer and dryer.


(Bruce) #5

I’ve had pretty rock solid performance with my HEM V1 setup. I’ve been using a modified device type, tracks the energy usage on monthly basis and daily high/low wattage. You might give it a try, see if it helps?


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #6

I have tried it both ways. In fact, at the moment, one is plugged in and the other is on batteries. The only configuration I haven’t tried yet is plugged in with also having batteries in it. I will test that next if anyone thinks that’s the ticket.

Yes. However, I’m not exactly sure what that is supposed to do with this one. As I understand it, that button on some devices sends the config data to the device, but the device needs to be ‘listening’ for it. With this device, I don’t see how to get it to listen. If I press the little black pairing button, it only blinks crazy for about a second.

I honestly haven’t checked yet. I will though. Should I post that here if still problematic after my next round of testing or in a PM?

Thanks. I just changed both of them to this device type to see what happens.

I’m not up on coding enough yet. Any chance you could share more on what you mentioned that you did to resolve your issues?

Thanks. I will test it next if the other one from above doesn’t work…or, I guess I should just test it anyway, and use whichever one I like better if they both work. :smile:

UPDATE: OK, I’ve had the first device type posted above in place for a while, and still neither is reporting anything at all. How can it be that the exact same device can be so goofy with exactly the same device type? I can only assume I must be doing something wrong. lol

I will let them sit over night and see what happens…


(Herbert Carroll) #7

Im suspicious my problem is most likely different than yours since youve tried other device types.

Nonetheless, in case they have the same check that @sandood 's device type does…

comment all lines that are if ( newValue > MAX_WATTS) { return }

You’ll need to make other changes for HEM v1 so look through the code for the comments on what to comment and uncomment out.

if you start getting values they’ll like be very high. I’m dividing them by 100 and the result seems accurate. Occasionally I used to get high alerts when my house was using very low energy and I first noticed the problem then. The high number would be 100x greater than the number reported before and after it. Now it every time so I just hacked the code in the meantime to suit my needs.

Also I noticed my HEM doesnt report details as often as I set it to any longer. I think the thing is just flaky now and I’ll need to order another off amazon soon. Might be a good excuse to upgrade to v2 so I can get negative values from my solar panels.


(Greg) #8

I just installed one of these a week ago. And it wasn’t reporting anything. I was using this device type
https://github.com/constjs/SmartThings-Devices/blob/master/aeon_hemv1_v2.device.groovy

But I couldn’t get anything to work until I edited as described here

Now it is reporting, except my minimum is still showing null.


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #9

OK. Thanks, guys. I will get to checking on / testing all of this today.

In the meantime, why the h3!! are so many different people having so many different problems of different sorts with exactly the same product? Why wouldn’t the problems all be solved by the same ‘fix’?

Is this related to the fact that there is now a newer, WAY more expensive version (i.e. they finally took the time and spent more on R&D to get it right)?


(Ray) #10

Just something to keep an eye on. Where do you place the module? If inside the metal breaker box then there could be a chance it does not get enough signal strength to the hub.


#11

@greg @sgnihttrams, I just double checked, and made sure the code (both v2 and v3) have the edit described in the link above.


(Greg) #12

Yeah I don’t know if perhaps I grabbed it before it was changed. I had the device awhile before I installed it to my mains.

John, is there a post that describes the differences between v2 and v3?


#13

Hi Greg, no unfortunately, and I should probably get into the habit of using the wiki and/or updating comments in GitHub. The only difference in the code fix you pointed out, and removing the “House is currently using…” statement because it’s redundant information that the main tile is already showing.


(Greg) #14

so would you recommend v3? and that is the one you would likely update if you ever did?


#15

Yep, that’s the one I’m using now. I also don’t care about cost and energy, just watts, so only data related to watts is what the device type displays, but it could easily be modified.


(Greg) #16

oh, well I’m on your v2 and it is showing me kWh and cost


#17

Yep, I took that out for v3 for my use, but I’m adding that back in right now. My wife actually just said she liked that, so I do what she says… Stay tuned, shouldn’t take me long at all, especially since she’s waiting!


(Greg) #18

Awesome. looking in my IDE I’m using 2 of your apps and 4 of your device types. I appreciate your work. I don’t see a pay pal on your github. Would be happy to contribute.


#19

@greg, Thanks, but no worries on PayPal. I really enjoy contributing to the community and watching it grow, and I’m glad I’ve been able to help folks like yourself.

Code has been updated:

https://raw.githubusercontent.com/constjs/SmartThings-Devices/master/aeon_hemv1.device.groovy

Here’s what it looks like:


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #20

@johnconstantelo Thanks!
Now for a stupid question… with this particular device (the v1 model), do we need to ‘Configure’ after updating the device type in the IDE? I have done that for some other devices, but on this one, it only blinks for about a second when I press the little black pairing button. Do we need to press that button to get it to take on this new config, or not…and if so, do we need to press the Configure button while it’s blinking, or what?