Aeon Labs Energy Meter clamps

Oh … I think I found a bug fix posted by Jody…; testing now.

Too many threads on the same topic, hmmm? :neutral_face:

But getting this error now:

907ab32b-141b-4391-aa2e-7274fa9ef735 5:06:59 PM: error groovy.lang.GroovyRuntimeException: Ambiguous method overloading for method java.math.BigDecimal#multiply.
Cannot resolve which method to invoke for [null] due to overlapping prototypes between:
[class java.lang.Character]
[class java.lang.Number] @ line 263

Status: I’m getting good data in the simulator (main tile) and some tiles are good in Android, but the main tiles show -- on Android.


Seems like an Android App Bug… (v1.6.8)

iOS (iPad) works great (no screenshot); and the Simulator also has display (but big fonts, doh!)

I will email support@ ; low priority. In case it’s a known Android Mobile App bug.

…CP / Terry.

Yes it is an Android bug, I found this months ago… I just commented out the background colors to make it display properly.

1 Like

Thanks! This is an excellent example of a “known issue”, then, I suppose, which I hope we will eventually be able to find in a well categorized and searchable issues / knowledge / bug-fix-in-progress page (which I know @Ben and @Tyler are on top of :wink:).

Guess I’ll find out if Support has an update, based on my Ticket # 81323.

…CP.

The easiest way that I know how to resolve this type of problem (I run into it a lot!!) is to figure out which variable it is in the equation that is “null” and add this before the equation:

if(!nullvariablename) { …equation… } or
if(!nullvariablename) { nullvariablename=0.0 }

That satisfies physicalGraph…

1 Like

Yup… Thanks! I’ve also done it the Java way with try / catch exception handling around risky blocks with null or possible datatype, class issues…

Roger that! Try is just a few extra characters… :slight_smile: Also not so good if you do want the “0.0” for the multiply and it fails :smile:

Hi all,
My HEM V1 updates once every 5 mins. Can I get it to update more frequently? It’s running on USB adapter.

Turns out the config for v1 might be slightly different. In the config function, parameter 112 looks like it controls the time before the Watts are sent. I changed it to 30 sec, and now it updates every 30 sec. Here are the values I use:

    zwave.configurationV1.configurationSet(parameterNumber: 3, size: 1, scaledConfigurationValue: 1).format(),      // Enable selective reporting
    zwave.configurationV1.configurationSet(parameterNumber: 4, size: 2, scaledConfigurationValue: 50).format(),     // Don't send unless watts have increased by 50
    zwave.configurationV1.configurationSet(parameterNumber: 8, size: 2, scaledConfigurationValue: 10).format(),     // Or by 10% (these 3 are the default values
    zwave.configurationV1.configurationSet(parameterNumber: 101, size: 4, scaledConfigurationValue: 10).format(),   // Average Watts & Amps
    zwave.configurationV1.configurationSet(parameterNumber: 111, size: 4, scaledConfigurationValue: 300).format(),   // Total Cumulative kWHr Every 5 minues
    zwave.configurationV1.configurationSet(parameterNumber: 102, size: 4, scaledConfigurationValue: 4).format(),    // Average Voltage
    zwave.configurationV1.configurationSet(parameterNumber: 112, size: 4, scaledConfigurationValue: 30).format(),  // Watts every 30 sec
    zwave.configurationV1.configurationSet(parameterNumber: 103, size: 4, scaledConfigurationValue: 1).format(),    // Total kWh (cumulative)
    zwave.configurationV1.configurationSet(parameterNumber: 113, size: 4, scaledConfigurationValue: 3600).format()   // Battery reporting - every 60 minutes
1 Like

An option instead of Energy clams for a more precise reading.

I just purchased the Eagle Smartmeter Gateway for $99.
http://rainforestautomation.com/rfa-z109-eagle/
It Integrates with the Smartmeters here in Texas using zigbee.
It has cloud Apps that are available for it ( at least 3 )
from Google play.

I have Solar and Grid and wanted to determine usage from what
source. Their apps show that. Another advantage is Instantly
showing what device in the house is using the most power.

I would prefer to use Smartthings !

so I was checking into how I could get it into my smartthings
Network. Any Ideas

1 Like

Definitely integratable via their REST-API.

I wonder if they would pay a reasonable professional services fee to have one of us write the Device integration and then they could claim SmartThings compatibility.

Doing this for “free” is fun, but why give the effort away to for-profit companies?

1 Like

I completely agree on this one…and I don’t even code here. What a great idea, though. There are some very talented coders here. Companies should be pulling from the community for assistance.

1 Like

Well… I’ve got some “available” time (not necessarily “free” time…) and it looks like this product may work on California Smart Meters, so I’ll send a proposal over to them and see how they respond.

1 Like

Hi,
I have HEM v1. I created a new device type from the original template, changed config per above and assigned it to my existing “Energy Monitor”. How do I make these new settings take effect? It currently still updates everything on the 5 minute interval.
Thanks!

-----FROM tinypocket’s post------------------
Turns out the config for v1 might be slightly different. In the config function, parameter 112 looks like it controls the time before the Watts are sent. I changed it to 30 sec, and now it updates every 30 sec. Here are the values I use:

zwave.configurationV1.configurationSet(parameterNumber: 3, size: 1, scaledConfigurationValue: 1).format(),      // Enable selective reporting
zwave.configurationV1.configurationSet(parameterNumber: 4, size: 2, scaledConfigurationValue: 50).format(),     // Don't send unless watts have increased by 50
zwave.configurationV1.configurationSet(parameterNumber: 8, size: 2, scaledConfigurationValue: 10).format(),     // Or by 10% (these 3 are the default values
zwave.configurationV1.configurationSet(parameterNumber: 101, size: 4, scaledConfigurationValue: 10).format(),   // Average Watts & Amps
zwave.configurationV1.configurationSet(parameterNumber: 111, size: 4, scaledConfigurationValue: 300).format(),   // Total Cumulative kWHr Every 5 minues
zwave.configurationV1.configurationSet(parameterNumber: 102, size: 4, scaledConfigurationValue: 4).format(),    // Average Voltage
zwave.configurationV1.configurationSet(parameterNumber: 112, size: 4, scaledConfigurationValue: 30).format(),  // Watts every 30 sec
zwave.configurationV1.configurationSet(parameterNumber: 103, size: 4, scaledConfigurationValue: 1).format(),    // Total kWh (cumulative)
zwave.configurationV1.configurationSet(parameterNumber: 113, size: 4, scaledConfigurationValue: 3600).format()   // Battery reporting - every 60 minutes

I had the same issue as well after changing the default 300 seconds to something much smaller (60 or 30). Regardless it only seems to get updates once every 5 minutes. Limitation of the v1 model maybe?

I have a v1 model, and it updates as data changes. Here’s the device type I’m using. Just tap on Configure once you’ve included the clamps and/or updated the device type.

https://github.com/constjs/SmartThings-Devices/blob/master/aeon_hemv1.device.groovy

2 Likes

Anyone able to get this working? I am getting a ? mark for the tile on Android and “Unkown” on IOS.

Thanks

Hi @cuboy29, sounds like you may need to exclude and re-include the device, or go indo the IDE and manually set the device type.

@johnconstantelo thanks for the reply. I am able to see the data coming in when looking at the device in the IDE. I think it’s a matter of the android displaying the tiles issue. If i switch the device type over the the generic on in the IDE then it works fine.

1 Like

Ah, OK. That’s odd but then again it shouldn’t surprise me. Certain tiles for me look different across several of my Android devices. My water valve device is different on my Note 4 phone vs my Galaxy S4 for example.

Are you using the device type I posted above or someone else’s?

I am using your device type but for now I’ve switch back to the stock ST one. With your device type, all i get is a question mark. Not even the little gear to get into the sub screen.