Zwave lock problems all of a sudden

Thanks, I thought so, but I just had to check.

1 Like


The Schlage equivalent is the Connect deadbolt:

Unfortunately we don’t have Smart Key, quick way to rekey, we used to but their was a lawsuit from that other lock company many years ago. The deadbolts are easy to rekey but you would need a pinning kit. Honestly I never rekeyed mine. I have multiple entrances into the house in case batteries would die or one would quit working I can always use another entrance. I do monitor battery life, plus the deadbolt will inform you when batteries are getting low. I’ve been using these for 7.5 yrs at home and I’ve not had any issues. Granted I do have many wired light switches throughout the house that act as repeaters.

Hope this helps.


Yes, the local state is getting out of sync with the cloud for sure. The issue for me is I have routines created with the Smartthings app, to lock the door if the door is closed and the lock has been unlocked for more than 15 minutes. That’s how I noticed I had a problem. I’d unlock a door and go outside, fully expecting that if I didn’t come back for more than 15 minutes that when I came back the door would be locked, except frequently it wasn’t. That’s ultimately what I am trying to solve.

My guess is that the routines use the cloud-based status for their decision making and the fact that the local status differs from the cloud is why the routines aren’t kicking in (i.e. the cloud still thinks the lock is locked when in fact it was manually unlocked).

I agree there is some kind of breakdown in my local network that must be at the root of things. I think this can all be solved if I can figure out what that breakdown is and how to solve it.

1 Like

Ah! This could be quite a different problem than just saying that “manual unlocking of the door is not recognized.”

When you manually unlock the door, does it show as unlocked in the app within a minute or so?

If so (and I’m guessing it will), then my guess would be that the problem is in the routine, where smartthings has been doing a lot of behind-the-scenes work recently and a lot of things have been changing and sometimes breaking. Timers included.

In other words, I’m guessing that the issue isn’t that the local state and the cloud state are out of sync, but rather that the duration condition in the routine isn’t working.

Can you post the screenshots of the routines that are not working? And then maybe @jkp or @Automated_House or one of the other people who are very up-to-date and experienced with using the built-in rules engine in the app will see something that might be creating the issue you are seeing.

OTOH I see another user just posted that they are having problems getting the status from kwikset locks and that this is also a recent change for them, so maybe it does have something to do with the lock state. Or maybe in your case it’s both. :scream:

Man, I wish we had better diagnostic tools. :thinking:

The routine is simplicity itself. I used to use webcore for this but when it stopped working recently I uninstalled all the webcore stuff and switched to the in-app routine functionality since it seemed to have evolved enough that it could handle at least this very simple case, which is all I really need.

Oh, and 15 minutes ago I manually locked my front door lock but the in-app status is still showing it is unlocked, as-is the ide. Also, I manually unlocked my garage door lock, but the in-app and ide status is still showing locked. If I hit the lock/unlock button in the app for the front door lock, the status correctly gets updated to locked. If I do the same for the garage door, the status correctly gets updated to unlocked and both are back in sync.

Here’s the routine

Bob - Just found your thread… I posted the exact same problem an hour ago and someone pointed me to yours. Kwikset lock has been working fine for years and suddenly lock/unlock status reporting is inconsistent. Will be watching this thread…

Kwikset z-wave lock not reporting locked/unlocked status consistently - Devices & Integrations - SmartThings Community

1 Like

Honestly I really think something broke in SmartThings recently wrt correctly detecting and/or reporting of zwave events (maybe only from battery powered devices since the Minoston outlets seem to be behaving just fine). I’ve still got a ticket open with support but it’s still in the early information gathering stage. If that follows the typical pattern its going to take weeks to get to come to the level of understanding we’ve gotten to here in this thread, so I don’t have much hope it will get me anywhere.

1 Like

Maybe also try opening a ticket with support. One report perhaps they can ignore, but two in a short interval, maybe it will make someone suspicious. It should, anyway. Of course 100 would be better :wink:

1 Like

Good point… just submitted a ticket. I agree, it seems like something changed with ST where it’s not picking up status changes correctly. I’ve made no changes to my ST/Z-Wave environment recently. Seems strange the lock would stop working after being rock solid for years.

1 Like

I wouldn’t troubleshoot anything until the current outage is cleared

Are you getting any response? I haven’t heard anything back from support since late last week. The problem persists and has not improved at all since I added the Minoston plugs.

I just responded to their first email yesterday. Their email have the below, so maybe they are seeing a pattern.

  • I’ve noticed some of the users facing similar issues with Kwikset locks, Can you please help me with some details so that I can have our developers look into this?
1 Like

Ok thanks for the update, that’s vaguely encouraging.

1 Like

So just in the past few hours something appears to have changed and now I am seeing much better behavior with respect to SmartThings noticing manual lock status changes. I did nothing. I’m curious if you are seeing the same, wpierson.

One odd thing. Whenever my routine to lock the lock if it hasbeen unlocked too long fires and the lock locks itself, the lock emits a loud, long beep (at least two or three seconds). Any idea why it might be doing that?

1 Like

I just tested it out and seems like it’s much better. Only failed to pick up one status change out of 20 lock/unlocks. Maybe ST changed something on their end?

I haven’t gotten a beep from the lock.

1 Like

My schlage does this when the batteries are getting low.

Thanks. If it got better for both of us then clearly something changed at the SmartThings end. My ticket is still open. I will see if support has an explanation.

1 Like

I’ve started to see a lot more missed status changes and my automations have been failing more frequently today. So while things may have gotten better late last week, they are getting worse now. Aarrgh.

Hmm. It got better again. Perhaps the relapse was temporary. Time will tell. Fingers crossed.

1 Like

Ok just following up. The support agent I worked with on my ticket confirmed that the engineers did make a change to fix this issue. So, it had nothing to do with my local environment after all, as I always suspected. So I didn’t need the repeaters in the end, but no matter, they’re nice little devices that will come in handy going forward. Thanks to everyone who chimed in on this thread. It was all very helpful and educational.