All my zwave door locks are offline (Jan 2024)

Hello. I am new to the community. I’ve been having a lot of problems with my ST V2. All my zwave door locks are offline and other devices are on and off intermittently. Just want to make sure that support is aware of this situation and is working on this issue? Just making sure so that I can stop trying to fix something that is not broken on my end. Thank in advance for your response.

1 Like

Hi @hmt Welcome to SmartThings Community

Could you share the following information?

  • device information
  • the driver that you are using for the device

If the devices are offline and you send a command, do the devices come online, or do they not respond?

1 Like

Hi Alejandro,

Samsung hub is ST V2. Zwave locks are kwikset. Switches are mostly GE, some Leviton and Zooz. All of these had worked perfectly for years until last few weeks. I believe it’s when firmware 0.51.02 was pushed out. I didn’t report anything because the push was paused, but then few days later it was released again. Waited 2 more days after the release completed to see if thing would be fixed, but they weren’t. When they’re offline, they don’t respond to any command. Tried to reboot, router, modem and ST hub (also took the batteries out) a few times and it still didn’t fix the problem. One thing I noticed that after each reboot 1, 2 doors were online and working for few minutes, then became offline again.

Attached is my hub’s firmware version.

Thanks for looking into this.

I will need to check it, please reconnect the devices,when the devices go offline, please share the following information:

1- Hub logs when devices go offline
2- Support access
3- The time and the date when it happens

Support access

  1. Confirm the email account registered in the forum is the same one you use for SmartThings. If not, please share it with me over DM.
  2. Enable support access to your account:
  1. Go to the SmartThings Web (
  2. Log in to your Samsung Account
  3. Select Menu (⋮) and choose Settings
  4. Toggle on Account Data Access
  5. Select the time period and confirm - In this step, please select “Until turned off”, once the team finishes, we’ll let you know so you can disable it again.

Provide the Hub logs through the

  1. In the my.smartthings, enter “your hubs”
  2. Enter the corresponding Hub
  3. Click on “Dump Hub Logs”
  4. Change the reason for requesting hub logs if needed
  5. Click on “Dump Hub Logs”
  6. Confirm that the request is submitted
    Note: If you have more than one Hub, the name of the one involved in the issue.

All done. Please let me know when I can turn it off. If I don’t hear from you by tomorrow, I’ll turn it off.


1 Like

@hmt thanks I will create a report, Do you remember when the devices went offline?

I honestly don’t know for sure. If I have to guess it’s late Dec, early Jan.

Thanks and please let me know when I can close the session. Not comfortable leaving it open like this.
Hope you understand.

no problem, sure I will share the updates with you


So can I close the remote session then if you’re done gathering logs and stuff?

Hello. Did you find out why these locks (and some other devices) are offline? Thanks

@hmt Sorry for the delay, unfortunately, I don’t have any updates, the team is continuing to investigate what happened, but I will ping them. I have already created the report, so you can disable the support access, If we need more information, I will reach out to you


Hi. Do you have any updates on this issue? It’s very frustrating that this is not working.

1 Like

Hi @hmt the team is still investigating. For the moment, the reason why the devices are going offline is a problem related to ping failures, but they are actively exploring the root cause.


Update from our side: the team has identified problems with your Z-wave network. Have you tried repairing your Z-wave network using the hub utilities?


Thanks for the update. If by repairing you meant run the Repair Z-Wave network from the hub’s setting then yes. I did multiple times and just did again after receiving your update. What I found interesting is that it didn’t even try to repair the locks. I just tried to repair the other devices (outlet/switches, etc.) that are failing.

Not sure what’s changed, but I’ve had this same exact setup for years and everything had worked just fine until the last update came out late (05.12 I believe). I haven’t changed, add, or removed anything.

Try to exclude the locks, factory reset and re-pair them. I noticed something recently where existing locks were suddenly changed to a different device. No explanation, it only seemed to impact my locks and nothing else for some reason.


Good advice! Make sure you are within a few feet of the hub when you pair them again. Also, in my opinion, the Kwikset Z-Wave locks suck! I converted all of mine to Zigbee with a radio card replacement and haven’t had a problem since. If you’re going to stick with Z-Wave, you have to have a beaming Z-Wave plug within a few feet of the locks to wake them up, or they will just not work well at all.

Slightly off-topic: did you notice an improvement in battery consumption after you converted? I have one of each, 15ish feet apart and both in the same room as the hub. The z-wave needs battery replacements much more frequently, but it probably gets used 4-5 x as much. It’s way louder than the zigbee as well - I assume that’s a difference in models / production years, but a more powerful motor may also be contributing to the faster drain. If a radio change would do anything to counter those two factors it’d probably be worth the effort for me.

Yes, I have four locks and the batteries last a while. here are the last few replacement dates.

Front Door Lock 5/31/2022 1/5/2023 10/17/2023 shows 70% now

Breezway Back Door Lock 4/9/2022 1/5/2023 shows at 70% now

Breezway Front Door Lock 4/9/2022 1/5/2023 shows at 60% now

Garage Door Lock 5/31/2022 1/5/2023 show at 20% now


Excluded, removed the lock and re-added. It showed it’s connected (online), but can’t get status of it. Waited for 1 hour, but still not getting any status, so can’t lock or unlock.

Excluded, removed, factory reset. Now trying to add it but not successful. The app keeps spinning, searching while the lock is in “pairing/adding” mode. Tried at least 6 times with no success. I will leave it overnight and will try to add it again tomorrow and update.

Thanks for the suggestion.