Z-wave issues/limitations VS issues with Hub and or App?


#1

I’ll probably need to edit this post. Typing it up late…

This is with any/all switches but all my switches are Enerwave or GE.

  1. Sometimes, when I turn a device off in the “things” or “room” view the device will turn off and the status button shows as such, if you then go to actual device view, it then shows the device as still being on. Hitting refresh sometimes nets you a correct status update, sometimes it doesn’t.

  2. Same thing, run a routine such as (all devices off or whatever), the devices turn off, you can see them turn off in the things view, you can then “quit” the app (this is with android) but when open the app back up and go into the things or room view, the devices, not all of them and there is no pattern while showing off when exiting the app, will now show as being on. I don’t understand why the device status will read differently in different views of the app.

  3. Again, some devices that you turn on, don’t go on but the app shows the device as on, hitting refresh does nothing.

Are these functions of the ap or do certain Z-wave devices not report their status that often? Is it a mix of both?


#2

If it shows with different statuses in different parts of the mobile app, it’s smartthings, not the device. This problem has been reported by several people in the forums for a few weeks. Hopefully the new platform changes they are rolling out this week (I believe the first ones were released today) will fix this. :sunglasses:

If you’re interested in the previous trouble reports, see the following thread, but again they are releasing changes this week so it may be best to just go forward from here.


#3

Thanks JD.

What we really need (or what I would find incredibly useful) would be some information on how Zwave actually works and the different characteristics or certain device brands and types. This should be a “sticky”.

With the hub still basically in development, it’s hard for me to tell if I am having local signal and range issues on Zwave or issues with the App/hub.

I would like some tools on the hub that would let me know if the signal just sent to a switch is a stuck in another switch or if has reached the switch and the switch is bogged down/locked up…ya know like when you run routines and certain devices don’t turn off? Is it because the signal never reached the device because of a zwave issue, a reception issue or because the hub needs work…that kind of thing.


#4

There’s some information in the logs:

But to be honest, SmartThings has very limited network analysis tools. I think this is because from the beginning they made a philosophical decision that customers would not have to know whether a device was using zigbee or zwave or whatever. So we get things like SmartThings saying that zwave has “clusters” (it doesn’t; that’s a zigbee term) because they try to universalize everything at their own top level.

It makes me crazy, as I’m sure it does other people with a network engineering background, but it doesn’t really cause any harm. The payoff is that we get the really pretty amazing ability to set up a device as a “button controller” (another SmartThings term) which can control a mixed group of Zigbee and zwave devices. That’s both very unusual in home automation and very valuable.

If you have any questions about any specific devices, just start a thread for those and you’ll usually get an answer. Or if you want a more solution-oriented discussion regarding a specific project you have underway, put that in the project section and lots of people will join in. That’s where we usually address things like too much lag between a switch and a light coming on and all that. Because there isn’t just one answer that fits every situation, it’s more likely to be the specifics of your own set up. “All home automation is local” and all that. :sunglasses:

There are also a couple of FAQs on protocol-specific questions that come up a lot in the FAQ subforum of the devices section of the community, if you find that kind of topic of interest.

https://community.smartthings.com/c/devices-integrations/faq

#5

Oh, and before I forget, the following project topic had a lot of discussion about the various features of different device classes that might be of interest:


(Jason) #6

They only have 1 man working on this, and He likely won’t get back to it anytime soon. I believe the zwave issues aren’t as important to them because most of their customers are using zigbee devices bought from their site. This coupled with the fact that the average user only has 15 devices, and the zwave issues are more frequent to people with over 20 zwave devices. These tools will probably never happen.


#7

Absolutely pure speculation. How in the world can you back any of that up (except the one man show statement)?


(Jason) #8

Did you read the thread I posted? Also I’ll look it up but it was either Ben out Alex who said Duncan’s the man…edit it was Ben.


#9

Yes I did read that, and that’s why I said in parenthesis the one man show.


(Ben Edwards) #10

Yeah I would say the priorities bit is a simplification and not correct. We probably have more Z-Wave devices connected to the platform than ZigBee. When I am back at a computer I could probably verify. Current priority is stability of overall platform.


(Jason) #11

This (annoying character limit)


(Jason) #12

It’s more of an educated guess. If your store sold apple phones and supported android, which one would you put more focus on?

I’ll find it, but i think it was Tim who just said it somewhere.

Edit, I was wrong it was Jody:


#13

No worries @Ben. I’ve been avoiding jumping into a lot of the community discussions regarding recent events and tried to stay focused on a few projects in flight.


(Jason) #14

I don’t doubt this, nor did I mean to imply that. I have no idea how many of what type of devices people have.

I can’t say it enough how much I Appreciate this effort. The wife put the kabosh on expanding the system until what we do have works, and… I… don’t… want to stop…:smirk:


(Jason) #15

I just re-read this after putting the kid to bed and not on the phone. What I really meant is that they are likely trying to push customers to using zigbee devices bought from their store, which have more limited alternative hubs to migrate to.


#16

As long as the alternative hub supports the same zigbee spec you can rejoin/move those device. Check out what Iris (next gen) now supports. Look all the way down at the bottom of the list:

http://support.irisbylowes.com/ics/support/KBAnswer.asp?questionID=653&hitOffset=2+1&docID=2196

Centralite makes the devices for both ST and Iris, so this doesn’t surprise me.


(Jason) #17

One alternative seems pretty limited. Zwave has many alternative options.

It’s also worth noting that alternative only has basic remote control function free. Automation’s cost a monthly fee (unless that’s changed I haven’t looked at them in a while)


#18

So as an example, the issue still persists I.E. showing off in one part of the app but still on and Vice versa.

I have some switches that are probably on the edge of the radio range. One of them worked tonight twice with the timer routine…first time it has turned off (it always turned on). Some other switches in that area, when commanded on, came on but now won’t turn off.

Then, when I go and try and turn other switches off/on that are close to hub (definitely within range) they don’t respond either. This what I am talking about. My thinking is that it’s an intermittent issue I.E. my fault but then when I go to “check” the switch by switching other switches that are definitely within range, they don’t respond either…

hub issue? Cloud issue? A mix? Does hub choke down when a switch doesn’t respond and make other switches not respond as well? When I run a network repair the devices sometimes show as a failed to update “mesh info” and other times show fine. In either case they sometimes respond and sometimes don’t. One would expect that if the switch doesn’t show up on the repair process that it’s within range and talking to the hub yet it doesn’t respond to commands.


#19

I’m sure that’s frustrating. :scream:

Specific brand and model of the switches that fail?


#20

Enerwave and/or Ge. The Enerwaves are the multiple (2) switches in one little box. The GE’s are dimmer or regular switches.

So now, I wait 20 minutes and the switches respond. No activity for anything is showing in the log (on my PC) other than ping. Even though the switch just turned off, it shows it’s last activity as 20 minutes ago.