SmartThings Community

Android 1.7.33-26 devices shown as offline

I recently tried to make the move from the SmartThings Classic app to the new SmartThings app (both Android). All seemed to have gone ok, except that I have a number of devices whose tiles are showing their status as “Offline”. If I click the tile, there is a “Device disconnected” warning message at the top, but all controls function properly. In addition, there doesn’t appear to be any rhyme or reason as to the device. I have a number of GE Z-Wave smart switches, all the same model, and some appear as online and others offline. Same with SmartThing’s own Zigbee multi-sensors. I have tried turning off device health in the classic app, opening the device settings and re-saving them, and even doing a Z-Wave repair, but no luck. Has anyone else seen this or have anything else to try. Again, the devices function just fine…it’s just annoying to see them shown as offline because it means you can’t do a quick on/off toggle from the tile without going into the device page itself. Thanks in advance.

All the time. Welcome to the new ST app. There are several discussions describing your scenario, as well as the methods you’ve tried to remedy the device status. For me, the new app also crashes 99% of the time and is completely useless, so I stick with Classic while ST support keeps trying to resolve my issues (unsuccessfully so far).

try rebooting your hub from the IDE.

1 Like

In addition to the above, check that these devices are using the same device handler.

A bit embarrassed that I didn’t try that as well. But that actually seemed to fix the issue (for now). Thanks.