Devices starting to go unavailable

So I have been using Smartthings for about 2 years now and have just over 100 devices. I use both the newer and classic apps. Over the last several months my outlets and switches have started going unavailable. All my switched (on/off, dimmer) and outlets are GE/Jasco brand.

While they are unavailable in the app I can use the app to turn that switch/outlet on, but not off. The switch status never changes. Even weirder is that they are all still fully functional with Alexa, Google Home and WebCore.

I have tried disconnecting the power to the outlet for over an hour, tried excluding and including it to the network and messed around with settings in the Smartthings IDE. Nothing works! A couple of my outlets that went out months ago all of a sudden were working in the app again only to do the same thing a month later. I’ve even rebooted the hub many times and attempted to repair my z-wave network which never seems to do anything anyway.

So, before I go spending hundreds of more dollars buying new switches I am curious if there is a known issue and fix that I am not aware of yet or if maybe I need to get a new hub. Has anyone had the same issue I have described? If I have to replace the hub is this an easy task or will I have to start from scratch with adding my devices and rewriting all my WebCore routines?

I am so frustrated!

I feel your pain. One of my bulbs became unavailable but was still controllable. Status in IDE was HUB_DISCONNECTED. I discovered that by turning off “Device Health” in the app the bulb came back in the app, although IDE status was still HUB_DISCONNECTED.

I also had all presence sensors going off-line at once and also Xiamoi contact senors as well.

The platform is becoming a little unreliable now.

I’m having EXACTLY the same issues, including newer GE zwave switches. I’m replacing mine with zigbee switches. The funny/odd thing I also experience is that as I replace these devices, more of the remaining zwave devices start going offline that never ever did before, including newer zwave fan controllers. I have 4 devices offline right now as I write this reply.

The excuse support tells me is that I have a bad device somewhere, but that’s BS in my opinion because I’ve already replaced over 40 switches throughout the house, and this problem just continues with every single remaining zwave device eventually going offline (mostly GE, but I’ve had Aeon devices go offline too).

Something changed somewhere a while back, perhaps in their attempt to prepare for S2 implementation, but we’ll never ever be told what it was. If you search around, we’re not the only ones talking about this. Submit a support ticket, even if you get useless help. At least you’ve voiced your issue.

Also, just to vent a little more, the GE zwave switches I removed that kept going offline (sometimes daily) with SmartThings have been working perfectly fine with another hub brand without any issues at another location.

@Kianoosh_Karami @Brad_ST

1 Like

What is their status in the IDE when they show as disconnected in the app?

All 5 devices that are affected at this time say OFFLINE. One did say HUB_DISCONNECTED yesterday when I posted this but is now miraculously back online.

It was expensive enough to do what I have done already. I think I would sooner go to a new type of hub before spending hundreds or thousands on new zigbee switches. There has to be a cure!

A few of us here had the same symptoms with Leviton switches and dimmers. For those, the cure was updating the firmware on the devices.


I have not seen any way to update the firmware on these GE/Jasco devices and my hub is saying it is up to date. Any idea?

SmartThings hubs don’t provide a way to update z-wave device firmware.

For three Leviton devices, I had to buy a z-wave USB stick and the Z-flash utility from Homeseer.

You might look at the Homeseer webpage for their Z-flash utility. It lists the versions of firmware they include. Check that against your devices.

My Leviton devices were purchased well after their newer firmware was made available but still shipped with older code.

Turning off device health worked for me. Found the answer in an old post.

1 Like

Until there’s stability with ST’s implementation of zwave, you’ll have to either power cycle the switches at the breaker panel, or use the air gap switch on the front to cycle power.

I’ve tried that with no success.

I’ve tried that too and while it removes the red dot and takes away the unavailable notification it still does not make the outlets operate correctly from the ST app.