Z-Wave Dimmer identifying as a Switch after conversion

I have several Minoston or GE Z-Wave Plus In-Wall Dimmer Switches which were running generic “Dimmer Switch” drivers, they automatically converted to Edge Z-Wave Switch drivers.

In the app there is a dimmer slider and it does work but previously if you turned them on (voice or simple on command from a routine etc) they remembered the last brightness setting, as they do if you use the paddle wall switch but now they always go to 100% brightness (for other Brits, my house is now like Blackpool Illuminations).

Yes I can change the routines to include a dimmer value but is there a way to get it to function like before where ON would simply restore the last setting? It appears to be sending ON + 100% rather than just ON. Is it as simple as changing the driver to a Z-Wave Dimmer rather than what it automatically picked up or is that not possible?

The Edge driver “Zwave Switch” includes support for dimmers too. There’s no separate dimmer driver.

As to why they aren’t returning to their previous value, I do know that different dimmers treat zwave commands differently. Some interpret an “on” to always mean “on to 100%” vs “on to whatever the last value was”. It sounds like the stock drivers are either not handling those differences for your devices or they just force do it one way or the other.

For your GE models, you can try Phil’s GE switch/dimmer community Edge driver, available here. See if that helps or makes a difference.


Thanks. I could previously use the wall paddle or Alexa voice command to set a brightness and they would still automate (on and off) but keep whatever was set so I know the device is capable, this must be an issue with the driver forcing a 100% ON command.

I could understand if these were previously using a custom DTH but as they were using the stock ST driver I would not expect a change in behavior, very annoying and hopefully something that can be fixed.

You would expect that, but a lot of the “tribal knowledge” that was in the older stock drivers has been lost when the new drivers were written. Stuff that used to work no longer does because the reason it worked wasn’t documented or was by accident.


This issue popped up a couple months ago with the GE dimmers and IIRC it was caused by the type of zwave command that was being sent for on/off. I think the correct approach that the old DTHs used was to send a Basic:Set while the stock handlers for edge drivers now try to use one of the more sophisticated zwave commands.

This should now be fixed in my driver, which @csstup linked above. I haven’t worked on any Minoston dimmers so I don’t have a solution to offer for those.


The GE and Minoston look identical and I don’t remember which dimmers are the original or were replaced due to a power spike. If I change the driver to yours and it doesn’t work I assume I can just change it back to the stock driver?

Here’s the IDE output for each.

GE In-Wall Smart Dimmer
manufacturer: Jasco Products
MSR: 0063-4944-3038
zw:L type:1101 mfr:0063 prod:4944 model:3038 ver:5.26 zwv:4.34 lib:03 cc:5E,56,86,72,5A,85,59,73,26,27,70,2C,2B,7A role:05 ff:8600 ui:8600

Minoston Dimmer Switch
manufacturer: null
MSR: 0312-FF00-FF04
zw:L type:1101 mfr:0312 prod:FF00 model:FF04 ver:1.02 zwv:5.03 lib:03 cc:5E,26,85,8E,59,55,86,72,5A,73,70,5B,9F,6C,7A

The driver menu in the ST app has a driver swap utility, and you’ll be able to swap back and forth between any drivers that support its fingerprint. The Minoston fingerprint isn’t included in my driver so it won’t show as an option. For the GE, the only warning I’d give is that my driver exposes all of the device’s configuration parameters in the settings menu, but it will likely reset them all to the default settings when you switch to it.


Switched to your driver and it works perfectly, thank you!

It doesn’t give me much confidence in the ST default drivers. Now I just need to find a driver that does the same for Minoston brand.