Eva Logik Dimmer Setting

My EVA Logic Z-Wave plug always turns on at 1% dimmer setting no matter what I set it to previously. It won’t remember the last setting. Its been working fine for months until today. Any ideas on how to fix this? I’m assuming its an edge driver issue.

1 Like

Tagging @philh30 who has worked with this issue for some other brands.

Do you know the name of the edge driver that it selected?

It says Z-Wave Switch


Having the exact same problem. Here is a screen shot of the driver info from the SmartThings app.

I have a Aeotec hub

What I’ve seen before is Jasco dimmers coming on at 100% every time they were turned on by z-wave. In that case, the old DTHs we’re sending a Basic:Set command for on/off, which the device interpreted as “turn on using default device settings”. The default libraries for Edge drivers now try to use the most complex on/off command supported by the device, and only fall back to a Basic:Set if nothing more complex is supported. The more complex z-wave commands override the device’s default behavior, which causes the undesirable results. The fix was a custom driver for those devices that sends Basic:Set for on/off.

If yours are coming on at 1% instead, it’s possible that it’s the same root cause but different behavior since it’s a different brand.

1 Like

I reached out to EvaLogik with a description of the issue and they were able to track it down to a bug in the driver. They updated the driver and provided the following instructions to add the new driver to the SmartThings hub. I successfully did this and the 1% issue at turn on is solved.

1 Like