Z-Wave Connect Add (after delete)

I have a couple of Fibaro FGS-213 smart switches (Z-Wave). They have worked fine (on a custom driver), for years, but we had a power trip a couple of days ago, as a result, my SmartHub V2 rebooted, and (I suspect) upon reboot, an update kicked in, and suddenly neither of these devices worked (nor did my 2x nGLEDOPTO GL-C-007P devices). They all defaulted to ‘default’ Zigbee and Z-Wave device handlers, but they do not work properly for these devices.

I had this same problem when I originally installed the devices years ago and set up custom handlers/drivers for them, so I suspected I just needed to point them at the right drivers to fix it. When I went to see what drivers I could switch one of the Fibaro devices to, there were no options in the list, and I thought perhaps the best thing to do was simply delete the device, and re-add it. So I deleted it, it said I should do the proper device removal sequence for the hardware, but I didn’t bother doing this. From this point onwards, the device has been removed from my SmartThings but refuses to be found when I try and add it again. I have done the Z-Wave Exclusion stuff, tapping the button three times on the Fibaro controller, the app tells me it has removed the device, but it still makes no difference when it comes to adding the device. It simply doesn’t show up.

After realizing the error of my ways, I reinstalled the correct EDGE drivers for both GLEDOPTO and Fibaro (the Fibaro one being here: (EDGE Driver-Mc): Z-Wave Edge Drivers and others with FIBARO devices:). Once I had done this, I could tell the existing devices (that I hadn’t deleted from my SmartThings) to use the new driver, and hey presto they all work correctly - both the GLEDOPTO devices and my second Fibaro device.

But it leaves me with this one Fibaro controller, that I just can’t make work. Z-Wave exclusion hasn’t helped, the device has a reset option which I have issued and that doesn’t work. It doesn’t get detected when adding a new device. It doesn’t appear on the current list of devices on mobile, the web interface, or in the command line ‘smartthings’ development tools.

Can anyone suggest some steps I can follow to try and bring this controller back from the dead? It costs around £50, so I am keen not to have to simply repurchase…! The controller appears to be working, I can tap the button on it to make it switch on/off, which works, I can go through the different reset sequences, as per the manual, which all work.

It’s almost as if my SmartThings refuses to add it as it somehow thinks it already has added it, even though it doesn’t appear anywhere. Possibly because I didn’t remove it ‘correctly’.

After messing around with this for many hours today, I just tried adding the device, but rather than scanning, specifying it was a Fibaro Single Switch, it asked me to triple-tap the button on the device (which does the exclusion mode stuff I believe) and hey presto, it found the device, has added it, it’s now using the right EDGE driver and appears to be working.

It’s the classic: you spend 5 hours on something, make no progress, then they second you post about it, you get an answer…!