Yale Z-Wave Assure Lock Keypad added as a dimmer light in SmartThings

We bought Yale Z-Wave Assure Lock Keypad from Amazon https://www.amazon.com/dp/B06X1C4PTC. We tried to connect to a Aeotec Smart Home Hub: Amazon.com : aeotec smart home hub. In SmartThings app, we selected add Yale Z-Wave lock, which prompted us to press lock master code and * 7 *1 to enable networks so that it can be added to the hub. It was added to the hub successfully, but works like a dimmer light with on/off and dimmer. But it cannot be locked/unlocked. We tried to reset the hub and reset the lock to add again. It was the same result. It’s added as a dimmer light. Any idea how this can happen and how to fix it?

This is not the first time I setup Yale Z-Wave Assure Lock + Aeotec Smart Home Hub in SmartThings app. But this is the first time I meet this problem.

I suggest installing the Z-Wave Lock Edge Driver from @philh30 and reinstalling the lock if you can’t switch drivers from the Driver option in the 3 dot menu on the device panel.

1 Like