Yagusmart switch driver?

Hi all, I have various Yagusmart switches (1 and 2 gang) that have recently been migrated from a device handler to a driver. There was an issue with these switches turning off after 2 minutes. This was fixed with a custom device handler, but now that they have been migrated to a driver, the problem has come back. Does anyone know of a working driver for the ‘2 minute’ problem? I have tried various -MC drivers without success. Thanks.

Hi, did you manage to find a solution to this, I’ve got exactly the same issue, was previously using the custom DH (from the thread here) but obviously not working now it’s been migrated to a Driver and I’ve had no luck finding a community driver that supports. Thanks.

Removing and re-adding the switch to my hub, but still using the MC drivers worked for me in the end.

1 Like

I have yagusmart switches, but I didn’t have this problem.

Try “Default Clusters” or “Personal Tuya Devices”.

Thanks @yosarian / @w35l3y , I’d been trying to use the “Zigbee Switch Mc” from this channel, I’d rebooted the hub, switched the driver on the switch, rebooted hub again… but not removed and re-added the switch!

I think that’s done it, it’s now automatically picked up the “Zigbee Switch Mc” (Manufacturer: _TZ3000_9hpxg80k Model: TS0011) and has been on for over 2 minutes :grin:

Need to go to bed (suddenly started obsessing about this this afternoon), will check again in the morning, thanks for the help!

1 Like