Yagusmart - Multi Switch

evening all, I was wondering if some one might be able to help please.

I recently bought a Yagusmart Multi Switch and have connected it to Smartthings as I have always done in the past, i.e. add it as Zigbee Multi Switch and then it auto adds the 2nd button as Child Switch Health. The actual hard buttons on the switch work independently, however in the ST app, if I turn either of the switches on or off, it controls both of them at the same time.

I have several of these switches that I bought a couple of years ago and they all work fine, so I think something has changed in their firmware since then.

I tried adding and removing it about 10 times
I tried Virtual switches as mirrors

…besides these, would any one have any advice on what to try? The switch is outside of the return window, so I can’t even return it :frowning:


I’m thinking it’s picked up ST’s edge driver instead of a device handler, assuming you don’t have a custom DTH for these switches. In the IDE, does it say “placeholder” for the Type?

Hi, no I never needed to use any custom DTH for these switches, it was always the ST ‘Zigbee Multi Switch’ one that worked. At the moment it shows Type as ‘Zigbee Multi Switch’ as that I what I changed it to, after adding it to ST.

What was the device type before you changed it?
What the original device type “Placeholder”?

I just removed and re-added it, and the default Type shows as ‘Thing’

@Mariano_Colmenarejo has a couple Edge Drivers that might work with that switch. Post the fingerprints from the “Data” section of the IDE for that switch.

Hi @Mariano_Colmenarejo , below are the fingerprints from the Data section (while it is added as a Zigbee Multi Switch). Do you have any Edge Drivers that could help get it working? Many Thanks.

  • application: 52
  • endpointId: 01
  • manufacturer: _TZ3000_u4kojtqz
  • model: TS0002
  • onOff: catchall
  • zigbeeNodeType: ROUTER

Hi @impee

Added to this driver version

Name Zigbee Multi Switch and Child Mc
Version 2022-10-09T11:37:31.008409199

  • id: “TS0002/_TZ3000_u4kojtqz”
    deviceLabel: TS0002 Switch
    manufacturer: _TZ3000_u4kojtqz
    model: TS0002
    deviceProfileName: two-switch

@ Mariano_Colmenarejo thank you for the update.

I have installed it, but the problem still seems to be present, that if I press switch 2 in the app, it powers both 1 & 2 switches on\off.

Do I ned to change any of the settings in the driver to get it working? I tried a few combinations, but nothing seemed to work.

Hi @impee

If something has changed in the firmware, now have this problem that I don’t know how to solve, I’m sorry.

I recommended other users with the same problem to try them with Tuya hub to see if they can be configured correctly, but I don’t know if they have done it and if they have been successful

its ok, many thanks for your help.

I will use this broken switch in the garage, where I only have 1 light connection :slight_smile: