Dual Gang Yagusmart Zigbee Switch goes offline after an hour and needs reset


I’m pretty new to all this, but I’m a software developer by trade, so I hope should be able to grasp anything technical.

I needed to download the edge driver (MC?) to get my zigbee dual-gang switch working.

It works a treat…for about an hour (not sure of exact timing) then nothing. The switch plate still works manually, but app connectivity is gone. I can turn the power off and back on again and it’s good for another hour.

Is there anything I can try to recify? I see on Amazon comments somebody else seems to be having the same issue with Echo, so seems like the hardware itself is having the issue?

The switch is Yagusmart “Zigbee 2Gang Smart Switch”, model LXZB-42-AJ

That’s a common issue with some tuya made models. They have an internal timer feature which turns them off after an hour. You need a custom edge driver which resets that parameter. Have you looked for custom edge drivers yet?


Check the quick browse list for lighting and look for one for Tuya or yagusmart. Then check the individual thread to see if your manufacturer name and model number is listed. (it must match exactly.)

If it’s not there, but it looks like a similar device, you can ask in that author thread if they can add your device’s fingerprint.

I took a quick look, and didn’t see a driver listed that seemed to match.

If you don’t see one on the quick browse list, check the following thread. If no one has requested that model already, you can add a post there. That isn’t anything official, but most of the community developers do check that thread to see what there’s a demand for.

Post Requests for Edge Drivers Here (community-created)

(Also, I assume you know, but if not, smartthings is in the middle of a huge architecture transition, from groovy “device type handlers“ that ran in a Samsung hosted cloud to Lua edge drivers that run on your own hub.

The problem you describe was previously solved with custom DTHs written, and shared by community members. I just don’t know if anyone has yet written an edge driver to set the same parameters. :thinking:


I did install a driver that worked in that it let me control both switches.

It’s currently offline due to work being done in there (man cave.) Will check what the driver is later on today when back on line. Was something like “Mc*”?

Incidentally, how did you check? Is there a way to search across the drivers for a signature?


MC stands for @Mariano_Colmenarejo , one of the more active community developers. He appends that to most of his edge drivers to make sure they have a unique name. :sunglasses:

And all I did was skim the quick browse list for lighting. There’s no official database that lists all the fingerprints, unfortunately, and while there is a table in the community-created wiki, it’s very new and incomplete. The information that’s there is accurate, but a lot of entries haven’t been made yet.


Most community developers list the fingerprints they support in the first post of their author thread announcing a new custom edge driver, or at least link to the file of fingerprints that they are using.


Also, since you do have a strong technical background, have you seen the community FAQ on edge yet? You would probably find it interesting.

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

Thanks, yes, very cool.

I did get tempted to start looking at writing a driver myself, but I just don’t have time right now.

1 Like

Am thinking about replacing this switch with something else, but how to know what works? These things aren’t exaclty cheap to keep messing with

By the way, it’s also possible that This has to do with a different problem with the same symptoms that occurs when a Zigbee device attempt to check in and re-join fails. That commonly happens once an hour, although it can be set for different times by different manufacturers.

In any case, the solution is the same: find someone who has written a custom edge driver for that model which is working. Or a similar model that you can have them add your device’s fingerprint to.

1 Like

That’s pretty straightforward.

  1. avoid anything from Tuya or that works with the Smart Life app (which means it’s a rebranded Tuya device). They use a ton of proprietary code and it’s just really hard to integrate.

  2. if you can wait a few months, wait until there is something available with the matter logo. One of the main purposes of that initiative is to make devices easier to onboard by enforcing interoperability for basic features.

Matter - smart home connectivity standard (formerly Project CHIP)

  1. if you can’t wait, only choose specific models which are listed in the smartthings app when you look under add a device by brand. But always remember the first rule of home automation: “ the model number matters.“ just because one model of a brand is compatible, it doesn’t mean another one is. (This is the problem that matter is supposed to solve.)

  2. only buy from places that have a good returns policy. Because smartthings has a lot of quirky idiosyncrasies. The good news about smartthings is that unlike many other platforms, it doesn’t limit you to a set list of models. The bad news is that that very flexibility means it can be difficult to tell in advance What will work and what won’t. (Again, matter is supposed to solve this.)

  3. and you can always ask in the forum to see if other people are using a particular device and what they think of it. Be very specific in your thread title for these topics. This is a very busy forum and a lot of people will skip threads unless they know it applies to them. So threads with more specific titles actually tend to get read more. :sunglasses:

1 Like

Thanks, that’s all great advice. I really appreciate the help!

Waiting is always an option as I have manual control atm. I do have the Aeotec Zigbee dual gans switch that sits behind the box, so will give that a go…You would expect Aeotec gear to work???

I don’t think Aeotec makes a dual gang Zigbee switch, do they? Originally they only made zwave products, and then they made a deal with smartthings to take over manufacturing of the smartthings Branded Zigbee line, but there were no light modules in that group. :thinking:

In any case, because of the hardware partnership between the two companies, I do expect aeotec devices to mostly work. But again, the model number matters.

What country are you in?

And—you never know. Smartthings has a history of dropping support for its own branded products from time to time. So even that is no guarantee. They just dropped app support for the 2016 Samsung smart television models, for example, even though a lot of people keep televisions for 10 years. And a couple of years back they dropped an entire model line of dual logo ADT/SmartThings devices about three years after launch, with many products still under warranty. :disappointed_relieved:

Ah, might be z-wave. Yes is is - Dual Nano: https://www.amazon.co.uk/gp/product/B016ZWZVI2

I’m in the UK.

Yikes, hopefully Aeotec are better at long-term support

1 Like


I Need the fingerprints and endpoints of device to see what can happen

1 Like

Can you point me at some instructions to do that? Complete newb here :slight_smile:

Install zigbee Thing Mc driver in your haub from my channel

The device must be online, since it is a AC powered device you can try to refresh in the app by sliding your finger down in the device details view

Make a change to this driver from the app in the device’s driver menu.
Close and open the device in the app and all the information will appear

1 Like


Hope what you need is attached.

I noticed I was using an old version of the driver, so installed the new version. Unfortunately still has the same behaviour.

Exactly what is the behavior?

As per my original post.

After a period of time (not sure it is 1 hour - seemed to do it after 10 mins the last time), it loses the ability to turn the switch on/off. Spinning circle of doom, lost connectivity to the switch. Other devices on the hub continue to work just fine.

After resetting the power to the switch, it starts to work again, then…same happens

Are device marked as Offline?