Yagusmart Single switch turns off after 2 minutes - Since Edge


I had issues with a Yagusmart switch turning off after 2 mins. That was in 2021. Then realised that its started happening again. I assume after the Edge update.

Ive tried a custom driver from Mariano_Colmenarejo but still turns off.

Anyone else fixed this issue?

Hi @Mark_Brown1

Will it pair with a driver change from a different one?

For the configuration of these devices to work you have to uninstall it and pair it directly with my driver.

1 Like

hi found this it worked for me with my switch so hope it helps.


Many thanks….that worked first time.

So I ensured it was using your Zigbee Switch MC, then removed it from the SmartThings app.

Then re paired. It chose the same driver and now it works and doesn’t turn off after 2 minutes!

Great stuff!


This seems to have come back for me again in the last few days. Using v6.6 of the driver. I have tried removing and re-adding the devices but it still happens. Does anyone else have the same problem?