Withings Scales integration (May 2020)

This thread is where you can post questions or reviews of the WithingS Scales integration.

1 Like

Well it works and is pretty easy to setup, but only displays weight (in kg even if you change it to lbs) and BMI… I’m not sure how valuable that data is to automate with. Looks like the co sensor is not exposed.

i’m not sure if Phil is on here, but here’s some pics he posted on Twitter:
Joining

Device

Automation

Image #2 —> home security?

On Android that’s “Location - Room”

I was just making fun that a scale was added to security

1 Like

As I previously commented, installing the ‘Withings Scale’ creates a connected service that connects to a single user profile in a single Withings account. As every individual in a household should have either their own user profile in a shared account, or their own user account, this is quite restrictive. It is also annoying that the settings don’t show that there is an active connection, they just invite a login.

My ‘Body’ scale gives a device showing weight readings in kgs or lbs (or ‘Lbs’ as they put it) but not stones and pounds as can be displayed by the scale itself. It also shows BMI and claims my battery, currently at 42%, is at 100%.

I weighed myself on the scales but nothing changed on the device.

It may be that things aren’t quite ready yet, but my argument is that, if the device is listed, they should be.

1 Like

It looks like some other cloud integrations only refresh data every 6 hours (Netatmo), so I wonder if that is the case here.

as far as unit of measure, it looks like SmartThings only supports kg, lbs, or 斤

This morning I deleted my device. There was no way to recreate it without also deleting the connected service. The flow is a bit odd. However that did mean I knew it was set up cleanly. This time the weight and BMI measurements came through when I weighed myself. So either it would have worked all along as long as I didn’t touch anything, or the updates have been enabled.

1 Like

I’ve enabled the integration through the new ST app, but my scales are only visible through the old app :confused:

Changing to lbs only sticks for that view of the device. Going back to view the device it returns to kg.

The device shows in my Classic app as a ‘placeholder’ device type and only battery % is shown.

I also see the sporadic updates in ST when using the scale. Some updates never come through.

Adding the integration via Connect caused my rooms to get messed-up. I believe this is not unique to this Withings device though …

Note, in fixing my rooms mess I had to do the following:

  1. Delete the room that all devices had been added to (because selecting that room actually showed no devices and thus I could not move them out of the incorrect room).
  2. Recreate the deleted room.
  3. Remove the Withings scale device from every room.
  4. Re-add devices to their correct rooms.
  5. Only once you have removed the Withings scale device from ALL rooms should you add it to the correct room (as each time you delete it from any room it will delete from all).

Finally, even once the Withings scale device is added to the correct room it still shows up as an available device for adding to rooms.

Is there a update on this? Iv had to remove the app as all the data was wrong and went really weird, However Iv gone to re-add via the connect and looks like this has been removed? Not sure if this is because of the bug of messing up all the rooms and devices that also happend to me… But wondered if there is another way of adding or if this withings managers been worked on ? Cheers