Windows Phone App Issues [URGENT - Broken for 28 days - Fix it!]


#1

I’ve raised a support ticket for this, but I wanted to check with the rest of the community members who are using the Windows Phone app on Windows 10 Mobile whether they are facing similar issues. I’m relatively new to SmartThings and it was all working great for me for about 3 weeks, which left me feeling confident enough to invest in more devices and that the Windows platform would be supported.

My problems started about a couple of weeks ago where I was unable to reorder my things tiles on the app. It was a minor annoyance, so I created groups to organized my things instead. Raised a ticket about that and support responded after 6 days that they’ve identified the issue and will have a fix with the next update.

I then got an email yesterday that their latest update on the Android app fixed the issue, and I responded that my problem is with the Windows Phone app. Got a reply apologizing for the mix up and according to him, the reordering works fine for them and that I should uninstall and reinstall the app to get the latest version. So I uninstalled and reinstalled the app, as per the recommendation, and this is where things start to get really bad.

After reinstalling the app, I noticed I could not even get into my groups to get to my things, so I removed all groups and it was a disorganized mess of tiles that I couldn’t reorder and I also could not create new groups. That’s when I noticed if I went into any SmartApp, my things were now displaying what I assume are the UIDs for every device I have linked to SmartThings (example 077f1cb9-d332-4908-b243-19da7193a83a). The app is pretty much unusable for me at this point.

Anyone else facing similar issues?

Update 2/26/2016 - This thread has been open for 28 days, which means the Windows Phone app has been broken for at least 28 days with no action from SmartThings/Samsung. There are many Windows users who have chimed in on the thread, confirming that the GUID issue has rendered the app unusable and broken. “Borrowing” an iOS/Android phone from a family member is not an acceptable workaround since SmartThings claims to support Windows.

SmartThings support has been slow to respond and even when they do, it’s a canned response that they are working on a fix. It should not take this long to fix the issue since it is not an issue on iOS or Android! We are clearly very low on the priority list. Additionally, the status site misrepresents the true situation by reporting that everything is operational. I am extremely disappointed with the company as I had high hopes when I first invested in their products.


Smart things February Report Card A Big Improvement!
Windows Phone App Not Listing Things
Smart things February Report Card A Big Improvement!
(Dean Smith) #2

The “reorder” thing has always been there, from Windows Phone 8 to Windows 10 Mobile. I just accepted it as part of the price for being a second class citizen in the great iOS / Android domination. A “fix with the next update” is funny, because the last update was a while ago. The difference between the Windows app and the iOS / Android apps is very large.

Everything else you’ve listed happened just this week for me. I’m pretty much convinced it’s related to the iOS and Android updates.


#3

The reordering used to work for me… for about two weeks… then it never worked again.

Sounds about right that whatever they did for iOS and Android has left us Windows Phone users in limbo :worried:


(Dean Smith) #4

Yesterday I tried to install a new SmartApp on my Windows Phone.

I started on the main page and pressed the plus button:

I was presented with an unexpected error:

I raised this as support ticket 184648.

This morning I tried again, still no success. I uninstalled the app and reinstalled, then tried to access my Things:

I received an unexpected error:

Before being presented with a blank page, no Things listed:

I went to my existing SmartApps to view them. I noticed in both SmartTiles:

And IFTTT:

There were only GUIDs rather than names. When I click on this to edit the names, the App crashes back to the start screen. I have updated support ticket 184648 with this information.

Today I am having an ecobee3 installed. Today I find out that SmartThings is not usable to me. I strongly suspect that this is due to updates to the iOS and Android apps, which have caused an issue with the Windows one. Please, can someone raise the priority of ticket 184648 so it gets looked at as soon as possible.


(Flip Taylor) #5

+1 Loads of issues here to, Lumia 830 running Windows 10. The app is broken, same issues as pictured above.

If I try to add ‘Only when in mode’ to any smart app, I’m told that no smart apps are installed, even though they are.

All working fine on my iPhone so deffo a Windows app problem.


(Dean Smith) #6

I have no other devices I could use. Oh, apart from an Xbox One, a desktop PC and a tablet running Windows 10, and a phone running Windows 10 Mobile. But, nothing else.

Please, SmartThings - please fix this. I just got my ecobee3 installed and I want to connect it.


(Khai Vu) #7

I am having the exact same issue on my Windows Mobile. Please fix this Smartthings. It’s bad enough that the MS app doesn’t get any TLC at all and now this.


(Flip Taylor) #8

Have you tried adding it here https://graph-eu01-euwest1.api.smartthings.com/

Temporarily you could then control it with smarttiles on your phone and PC


(Stuart Buchanan) #9

yup mine has broken since the ios and android apps have rolled out, can’t Smartapps, or view devices in groups etc… All red banner city as previously shown.

Come on sort it will you. Geez I cant believe this platform! Ridiculous! The number of problems since I purchased just prior to christmas is a joke. Its embarrassing reading


(Khai Vu) #10

Here is a response from Smartthings:

Hi there,
Thanks for reaching out! I’m sorry to hear that your app keeps giving you an error. It is a known bug on the Windows platform and we are working to fix it.
I have tagged you so that we can follow up with you when it has been fixed.
Kind regards,
Josh
SmartThings Support


(Khai Vu) #11

My current work around is reaching over for my wife’s galaxy :smile:


(Erik) #12

Same problem here on my Lumia 1520.

And my work around is also to grab my wifes iPhone…LOL


#13

Same issues on my 1520. I’m trying to add a mobile phone for presence and I get the same “unexpected error” or when I try to import existing the text disappears then the app force closes. What a mess…


(Kevin Baugh) #14

Same problem the only reason I went for Smartthings was the windows app
It has many problems and a Poor ui before this and missing features of the android app
Now it is BUSTED


#15

My workaround is to grab my fiancée’s note 4 :confused:. C’mon SmartThings! If you’re going to update features on iOS and Android, surely you know you need to fix Windows too! It’s called regression testing!


(Stuart Buchanan) #16

so I’ve just logged a ticket, i suggest every other windows phone user also does the same otherwise it will never get fixed. as it seems ST are far more likely to respond to issues with multiple tickets as they work on their problem management


(Mal Ball) #17

Just started getting the same, red error box at top of screen when trying to go into groups, only way is to delete group to get at any things. Unfortunately, the way that things are listed in the Windows Phone app means you don’t have a clue what thing it is until you go into it, names don’t appear.

As a Windows Phone developer myself I know there is much better ways of displaying THINGS than in little round buttons that cant display much data


(James) #18

This started happening to me last night as well. Same problem on the other Windows Phones in the house. I emailed support before finding this thread. Let’s hope this gets fixed soon.

The good news is that Amazon Echo, IFTTT and the actual “smartapps” seem to be working just fine.

Edit: On 8.1 here. Haven’t jumped over to 10 mobile yet.


(Alison) #19

I have the exact same issues on Windows 10 mobile (lumia 950). It just started in the last day or two. I will put in a ticket also.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #20

Try shaking your phone … yes… seriously, that worked in the Android and iOS 1.x versions… :confounded: