Windows Phone SmartThings NOT Working


(Cuan Brown) #1

Just as a warning to Windows Phone users (before I get flamed for this device - its a work un!), the registration of the Smartthings Hub does not currently work in the UK on Windows Phone. I have been battling with it (and support) since Thursday. My understanding from the team is that the WP8 App is pointing to the US servers and failing to successfully setup the hub. I have been told by the support team this will be resolved (on Monday). Clearly its not the case, so just a warning to other users. Will wait with bated breath in the meantime


(jhoff80) #2

Just to check… there was an app update yesterday that I thought mentioned UK stuff in the changelog. Have you manually checked for store updates just to make sure?


(Cuan Brown) #3

Yep. Tried it. Still not registering the hub. I don’t get an error anymore it just gets stuck on hub registration page, but the setup does now include which locale I’m from (uk/us).


(Tim Smith) #4

thanks octane, that explains why I’m stuck in the setup wizard when I sign in. I have an iPhone as well and set up SmartThings on that first, so there should be no reason to see the start up wizard when I sign in on the Windows Phone.


(Cuan Brown) #5

Yep, there is something screwy on the windows phone, it doesn’t seem to see configure accounts and wants you to set it up even if the acc is preconfigured (which is what app support tried to do).


(Cuan Brown) #6

-----UPDATE-----

I can now connect to my hub, but for this to occur App Support needed to configure the account for me, I could not register the hub myself. Support came back to me at midnight last night to confirm I should be working.


(Tim Smith) #7

hooray, it looks a lot better today. When I sign in on my Windows Phone now I’m not asked to setup the hub (even though it’s already setup). thanks for the update :smile:


(Aaron S) #8

Your login issue was a bit different than the Windows Phone issue… But equally annoying. That said… I super appreciate you hanging with me, and now WP login should work for everyone. If not, email support@smartthings.co.uk and we’ll brandish bayonets at the US engineers.

Edit. Also, if you are still experiencing this. Uninstall and reinstall the app to reset it.


(Cuan Brown) #9

Thanks chum. I much appreciate the help