Why SmartThings has installed unnecessary Wemo etc drivers to my hubs

I found out over the weekend that for some reason Wemo driver has been installed in both of my hubs.

Name Driver Id Version
Wemo d9c3f8b8-c3c3-4b77-9ddd-01d08102c84b 2023-04-11T19:50:00.6030389

I do not use and have never used Wemo devices.

You are not using Tasmota by any chance, with Alexa also in your system. There is option on the Tasmota panel to configure Alexa to Tasmota using, strangely enough, Wemo. I touched something there once and found a Wemo driver on the hub. Still trying to figure it out - just an idea. Also have no Wemo devices.

1 Like

I’m not using Tasmota or Alexa.
I’m only using Zigbee devices and one Z-wave device and also community developers’ virtual devices and cloud-to-cloud integrations (Tuya and Wiz)

On another hub in another location, I haven’t installed new devices nor installed new drivers in a couple of months.

I’ve just looked and it is the same for me. I’d forgotten what a Wemo was until I just looked.

The driver has been installed from the Production Default channel.

Yes I checked also that it is in production channel. But why it is installed. Have you @orangebucket
Wemo devices in use?

I do not see it installed on either of my hubs (V3 and Station)

Nor do I. And I DO have Wemo devices, lol.


No. I’d actually forgotten what they were. My only LAN based device is an IKEA/Sonos speaker.

I don’t really understand the flow with LAN devices in the default channel. It seems to me that the driver needs to be installed in order for there to be a discovery routine to run. However until the discovery routine is run, how do they know which driver to install?

Perhaps I accidentally triggered installation of the Wemo driver somehow without being aware of it. If so I’m surprised I did it on two hubs.

Well I do now and they converted my devices over.

Hi, everyone

Yes, it is expected that you have the driver installed on your hubs despite you don’t have a Wemo device, unlike Zigbee and Z-Wave drivers, LAN drivers don’t have fingerprints, so, it wasn’t detected that you installed them at some point or not since they are not “identifiable” sort of speak.
So, it’s normal that you have it, and, as you don’t have devices using it, it won’t be running on your Hub.

1 Like

This is probably not the sort of thing I should be lying awake pondering in the middle of the night when I can’t really investigate for myself, but …

Does this mean we can expect to see other LAN drivers installed and more importantly does this mean their discovery handlers will be active?

Just trying to get my head around how they peacefully coexist with beta/preview drivers or community drivers for the same devices and also what the potential is for unwanted discovery.


I ran a Scan Nearby and as I expected the discovery handler for the Wemo burst into life. Not an encouraging sign when you have multiple hubs.

Oh and …

2023-04-26T11:28:15.489441968+00:00 WARN Wemo  recieved discovery response with reported & source IP mismatch, ignoring
2023-04-26T11:28:20.463795678+00:00 TRACE Wemo  Received event with handler discovery

Triple whammy of irritations there. Could they at least fix the spelling mistake?


Wemo drivers showed on both of my hubs within the past couple hours.

Same here.

why aren’t Samsung audio and Bose edge drivers also pre-installed,

1 Like

All 3 of my hubs got it installed.

I deleted it from two of them, but it returned several hours (6?) later.

So no point in trying to remove them if you don’t have WEMO devices? I’m assuming they are taking up precious memory?

exactly, me too or this drive now installed, and instead I have a bose that still hasn’t migrated and remains with its old method of connecrion.
(I have deliberately waited to see if it migrates, but this does not happen, as with the Hue. All other devices I manually switched to Edge)

i tried deleting this drive wemo, but it tells me in use. Who knows by whom :person_shrugging:t2: :male_sign::hugs::thinking:

1 Like

Does the Wemo driver count towards the max amount of drivers allowed by a hub even IF we do not have Wemo devices ?

If so are we to expect more drivers of a prefix (pre installed)?


Today I found that new drivers has been installed in my hub.

New drivers
bose c856a3fd-69ee-4478-a224-d7279b6d978f
SamsungAudio dbe192cb-f6a1-4369-a843-d1c42e5c91ba


I’m seeing the Samsung Audio driver today and yet I don’t have any Samsung devices (beyond the hub) on my network. Is this just like the phantom Wemo one?

I have that plus Bose