What's going on with Wemo switches? Working fine for 3yrs (April 2019)

I don’t know if it’s the same for everyone, but my Wemo switches do send the correct state when refreshed manually, so I set up a webCoRE piston to refresh them every 5 minutes. They also still respond to commands, so by adding the piston, I was able to get them to work again with all my existing automation. It sucks to have to use this workaround, but it does work.

2 Likes

Wemo smart plugs that are set up work fine. I updated the WeMo firmware and the smart things hub was also updated. I don’t know the root cause but now when I take a new Wemo smart plug and set it up I can control it with the Wemo app, I can control it with Alexa, but I cannot get smartthings to find the new device. I don’t know what the root causes but after reading all the comments above it makes me think that WEMO is likely the root problem.

1 Like

For what it’s worth. My Wemo motion sensors are all randomly responding to motion events and are also now useless. Real shame but I’m thinking of keeping them alive within STif I get IFTTT to switch a simulated motion sensor in ST from the Wemo motion sensor. Something like this might keep them usable??

I, too, have been experiencing issues with both Wemo mini plugs, and Wemo dimmers. Everything worked fine in the beginning, and still works with the Wemo app & Alexa, etc. However, the minis started having problems turning off with ST. I finally gave up and ordered a Zwave switch to replace one of the minis.

Today, I decided to take a look at ‘Live Logging’ in the ST IDE and discovered the following error when attempting to turn off the Wemo minis:

There was an error while parsing the response: groovyx.net.http.ResponseParseException: Unauthorized @line 1172 (makeSyncronousReq)

If I’m interpreting correctly, this error is coming from an unrelated smartapp I have installed, but not currently using. (Echo speaks) I removed the smartapp, and, so far, the minis are working again. I’m not saying this is the problem, but it may worth a try to remove any smartapps you don’t need, or at least view the Logging to get an idea of what may be happening.

For what it’s worth, I had Echo speak working until I reset my hub. I hadn’t gotten around to investigating that problem.

I still have problems with one of the two Wemo dimmers.

1 Like

All my Wemo switches and outlets are having issues with status updates again…

What is the update on this? My Wemo switches are completely broken, they do not update when I turn the switch on…So freaking frustrating!! I have to manually hit refresh few times for the status to change.

I just realized my WeMo switch stopped updating its status in St on July 22.
No firmware upgrade around that date.

My WeMo sensor stopped working a couple of months ago, could’nt connect to wifi anymore.

I guess its time to get rid of the, wifi devices are a pain anyway.

I sold all my Wemo switches.
The problem went away…

1 Like

I also removed the last WeMo Devices this weekend, and swapped them with Z-Wave switches. No more issues or missed routines!

That and I didn’t like having a wifi enabled system connected to my hub. Trying to keep as much local as possible and only allowing HTTPS when required.

Any update on this issue? I can turn them on in SmartThings but then the status goes away, leaving me unable to turn them off. I also get a network error message.

Yeah, sell your Wemos.

Any good options for smart plugs that work with both SmartThings and HomeKit?

I don’t know if there’s any that would be considered “good” but there are a few that you can try.

There’s a list in the community – created wiki of devices that work with both HomeKit and smartthings. I think iHome is the only one that has an official integration with both right now, but there are also some that work with both HomeKit and IFTTT, so you can get some smartthings integration that way.

https://thingsthataresmart.wiki/index.php?title=Devices_that_Work_with_HomeKit_and_SmartThings

Kasa Smart Wi-Fi Plug Mini by TP-Link is listed as coming soon to Homekit but no way to know when that will actually happen

Unfortunately TP-Link cancelled their HomeKit rollout.

1 Like

Thanks! SmartThings is my #1 priority and HomeKit is just the icing on the cake. I’ll have to look into other options.

1 Like

After following this advice my [Wemo] problem went away too.

1 Like

They just announced this week that they are not going to provide HomeKit compatibility. This may be coming out of trade war politics. (I don’t want to get into politics in this forum, just an industry reality for Chinese companies which sell most of their products in country.)

Or it may just be a tactical business decision. If Huawei really has to switch to their new OS, harmony, because they lose access to android, it’s likely that TP Link will have to provide harmony compatibility, and there may be a practical limit to the number of integrations they want to support.

Lots of discussion in the Chinese press about this this week, but we will just have to wait and see which way things go.


.

I am not sure it’s Wemo’s issue here. I have been having issues after a smartthings update and I am just bypassing it with a Home Assistant Pi3+ now but i hope they fix it in the future.

So did Wemo basically stop working with updates? I had no issues either for 2 + years and now they don’t control at all. I deleted and tried re-adding them by resetting the wemo switches themselves but they just won’t connect or get discovered