What is up with your automations as of late, Samsung/SmartThings? (April 2021)

Not quite sure whats going on with my Automations. This platform seems to becoming increasingly less reliable.

Not like I have some big, fancy, intricate automations.

Heres my background. Not sure whats relevant, so might be a bit verbose…
a few years ago, Lowes dropped the Iris platform, which sucked since it just worked. I have a number of GE light switches, dimmers, smart outlets, motion sensors, multipurpose sensors, thermostats, etc. All worked fine.

Lowes kills Iris and so i move all my shiz over to SmartThings platform. I started with the v3 ST hub and added a couple more GE switches, smart outlets smartthings motion sensors and multipurpose sensors.
I got most everything dialed-in and working satisfactorily.
This was a couple years ago.

I primarily used the old SmartThings iOS app. I had to use the newer app on occasion. Things worked.
Fast-forward to Samsung kills the old SmartThings app. I ended have to migrate over automations/routines. Things still worked fine for about a year.

I have 2 garages with SmartThings motion sensors setup. They are set to trigger garage lights when motion is sensed. I also have another automation to kill the lights if there is no motion for 15 mins.

This worked great.

Slowly over time… some automations started to not work. I found the occasional hub reboot or a removal/recreation of the automation would remedy the issue.

Fast forward to about 3 weeks ago. I found that the lights in the garage no longer kicked on with movement. I did the usual power cycle of the hub, when that didnt work, i recreated the automations. When that didnt work, i bounced my hub again with my wireless APs, router and modem. Still no dice.

I ended up removing a bunch of the automations and recreating. no-go.

unpaired and deleted switches and motion sensors. Replaced batteries for motion sensors. no-go.

I am at a loss. What used to work great with my automations no longer works.
I have a couple scheduled jobs to kick on a couple lamps and they still work. For whatever reason things will not kick on when motion is sensed.

In the SmartThings app, I can see that the motion sensors pick up my movement just fine. Also, i can manually kick on all the switches from the app.

Whats the deal with the automations and motion sensors? these are SmartThings sensors… not some cheesy 3rd party motion sensors. Why would this fail to work? Anyone else have any issues with automations and motion sensors that was able to remediate?

If it wasnt for my going “all-in” with replacing my washer, dryer and range with Samsung “smart” crap (which seems to just work native with SmartThings) i’d pick-up and move to a new platform.

There have been multiple service outages in the last six weeks or so, it could be that it just failed during one of those.

https://status.smartthings.com/

ping is from March 6th

no smartapps to add, there are only for cooking and washing machines

Thank you @JDRoberts. I was going to touch on this in my initial post, but overlooked it.
I watch https://status.smartthings.com/ from time to time. I dont have much trust its accuracy.
Also, a while ago i signed up for incident alerting. I do get alerts from time to time. I would get alerts previously and my stuff still worked. seems like something just “fell over” and hasnt been put back up again and slipped through the monitoring cracks.

Status now says everything is operational, but my stuff still not interested in working.

I did see that there was a new firmware released today. Maybe that’ll be my silver bullet? probably not.

1 Like

@kabi
Sorry. What?

I don’t know if this has any overlap with your issue or not, but just in case…

Thank you for the link @JDRoberts!
I did have issues a a few months back where my automations stopped working because the devices names were missing. Updating the automation to include the device OR deleting and recreating the automation corrected the issue.

I hadn’t seen that particular issue in a couple months though.

1 Like

What kind of automations are these? Smart Lighting or created with the automation builder in the new app?

Automations created in the ST app. Mainly motion sensors as triggers to control GE in-wall lights switches and dimmers.

  • Found the issue. posting an update.

SO, here is an UPDATE!!!

After a week or so just leaving things alone and leaving the devices and automations setup how i’ve had them for the past year or so, the automations using the motion sensors only worked a couple of times.
For better description of what I have… I have 2 garages. I have 1 ST motion sensor in each garage. The shop lights are all controlled by one switch on one circuit for both garages. This switch is a Z-Wave GE light switch.

If motion detected for 2 seconds, lights switch on. If there is no motion for 15 minutes for each sensor, then lights shut off.
this is how I’ve had everything setup for the past couple years and they worked great, up until a few weeks ago when motion sensor automations started to rarely ever work.

I did removed devices (excluded… ) re-added devices… deleted all automations…
Setup WebCoRE and tested automations there with the motion sensors. NO dice

The very last resort (nuke) was to factory reset my SmartThings Hub. I did everything to avoid having to do this…
Well, a couple days ago, after fighting everything… just to get these motion sensors working with automations again, i launched the nuke and factory reset the hub.

So, After resetting the hub, all devices were excluded… I re-added the motion sensors and the switch in the garage… i then setup the automations how they were set before to trigger the lights to come on when motion detected on the motion sensors for 2 seconds. NO DICE… after all that… it still didnt work…

I felt deflated.

I spent 3 hours the rest of that evening going through the house excluding and re-adding all of my devices to SmartThings… yay…

After dorking around with some settings the next day… i deleted and recreated my automation with garage lights and motion sensors then got distracted…

My wife parked in the garage after a trip to the grocery store. She came in and said “Hey, you got the lights and motion sensors fixed in the garage?” … i was like… “no!”… But I checked and they were WORKING!.. consistently even.

Well, re-checking my automations, I found that I created the automations by setting garage lights to come on with motion with NO DELAY (vs the “2 seconds of movement needed to trigger” setting I had been setting prior).

So, with more testing, i found that ANY automations created including motion sensors as a trigger with any sort of time delay, the automation would NOT work. Once i removed the requirement that "motion needed for ANY amount of time, things worked.

Not clear to me what changed on the ST side, because these automations worked before when i had a requirement for 2 seconds sustained motion before triggering lights on. Now they will NOT work when enabled no matter how much sustained motion there is or what value the time is set to.

After all that, all of my automations now work again if i don’t use that sustained motion setting.
Im happy for now.

TL;DR: automations using motion sensors as triggers to turn on lights requiring 2sec sustained motion used to work for a couple years. stopped working a few months ago. tried everything from deleting/re-adding devices and automation to hard-resetting the hub (full nuclear), and still didn’t work.
Later found, by accident, that if i did NOT enable 'x seconds of sustained motion" requirement, then automations worked.

1 Like