Wemo switch "offline"


(Hugh Ehrenberg) #1

I have been using a wemo swtiched outlet through the wemo connect smartapp. Lst night I find it “offline”. Removing it works, but the smart app cannot discover it now. Any ideas?


(Bobby) #2

It must be something on Wemo side, because all of my Wemo are offline with Echo too, when they are actually not


(Hugh Ehrenberg) #3

Do you think they aren;t compatible anymore? The integration is supposed to be cloud to cloud. I have no problem operating the switch from its own app.


(Bobby) #4

Same situation here with Echo. I no longer have Wemo connected to ST because the integration was never reliable. Wemo may have made changes to their API that killed both ST and Echo. Is not unheard of…they’ve done it before with their IFTTT integration.


(Takis) #5

Same situation with my wemo devices. i have 8 of them and they go offline and online all the time. This has been happening 3 days now…
So tired of it i wanted to change everything to Zwave switchs and sell my wemos but it gets expensive…


(P.Bradford) #6

I just ran into this today. I have three and it seems nothing but trouble with Wemo, I wish I had bought zwave switches instead.

I moved one switch over to a simulated switch and it seems fine. It looks like i need to do the same for this next one that went offline.

I wish there was a better answer than ifttt. The lag kills me…


(Takis) #7

i actually replaced all my wemos with zwave… no more problems.
I have a lot of custom made wifi devices, none of them has issues. its just a wemo issue…


(P.Bradford) #8

What did you end up doing with the Wemo switches?


(Brian R) #9

its weird, some of my wemo’s work still, some don’t. my front and backyard lights keep showing offline, and they aren’t working well with IFTTT the last week. by then my fireplace maker seems to be fine, and my garage maker keeps falling off both the wemo app and IFTTT.

its pretty ugly over on the wemo forum with all of the problems, and lack of reasonable support.


(Hugh Ehrenberg) #10

I tossed the WeMo switch. Not only was it not working via the ST platform, it wasn’t performing any autonomous automations as a stand alone. I replaced it with a Z-wave plug. The WeMo switch had been in a closert before I bought ST. Now I remember why.


(Takis) #11

I have 5 switches on the side, i am thinking of selling them. There is nothing wrong with them, they just dont work with smartthings as good as i would have expected. You want them ? :slight_smile:


(Jason Hearne) #12

Support has updated the Wemo App. They just informed me today. I posted it here (instructions on how to update)


(Francisco Blanco) #13

This update is a piece of junk. The problem now is worst than before


(Francisco Blanco) #14

Does anybody knows where can I find a previous version of wemo connect app. The current version is a nightmare


#16

Since the lastest release of Wemo Connect, despite the fact that at times a switch may show as being offline they still work fine when triggered via a routine or smartapp. To control them directly from within the app, pressing Refresh will bring the switch online.

I had been using Polster with mixed results but now I know that despite the offline state the switch still functions, this app has been disabled.


(JD) #17

WEMOs connect via wifi.
Most likely the router assigned a new IP address due to the DHCP lease expiring. Most routers have the lease set to 24hrs.
My Netgear Nighthawk x8 has been known to reassign my WEMOs new IPs which causes Smartthings to lose visibility until it recognizes the new IP.
Even once Smartthings sees the new IP I usually have issues.

I assigned static IPs to the WEMOs
Then add them back to Smartthings.
I have not had a WEMO go offline since.


#18

Give it time :smile:
My “permanent” wifi devices have has static IP since the beginning. Despite that, my wemos still go offline at times.


#19

Just want to say that today I found my WeMo light switch reporting “Offline” and my loan Insight Switch, while not showing Offline, hadn’t been controlled by ST app in a few days, though working fine with the native WeMo app and Amazon Echo . After reading this thread, I went to the WeMo Connect SmartApp and simply unchecked both devices, clicked done, then went back in and checked them as enabled again. Sure enough, when I returned to the Things list for My Home, they were showing up active again. I went in to details on the devices, switched to the “Recently” tab and each have an event (IP changed to 192.168.1.“n”) at the time i re-enabled them. I will be going in to my router and setting these to static IP assignments for the devices.


#20

Dont mean to be a wet blanket but my wemos have had static ip for years. Makes no diff. They still go offline. Like you, I go into the app and (un)checked and they come back. Next time it happens I’ll have to check the log


(Bob) #21

Mine do the same.
I have downloaded ‘Pollster’ and do a refresh every 15 minutes. This seems to do the trick.
I know it is not the answer but it does keep them on line apart from brief instances when they do go off line.

BTW. Mine are set up with static ip addresses.