WeMo Devices offline in ST App and Open Senseo

My WeMo devices show as offline. Looking at the WeMo app all of the devices appear and work without an issue. Not sure why ST see them as offline but I am not sure how to get it to see them. I tried the device refresh and that didn’t work.

Additionally, my door sensor is stuck in the open position in the ST app. Unfortunately it isn’t open and is infact closed. Not sure how to have ST realize the sensor is off.

I’m seeing the same issue with just 1 of my WeMo switches that started yesterday.

The developer site doesn’t show issue with WeMo and support hasn’t replied to any of my tickets.

1 Like

I’ve been having the same issue for a while. Now my Wemo switch has advanced to showing as offline in Echo as well. Automations work with ST, but not app triggers. Echo is hit or miss. " Alexa turn on back yard lights" , " Sorry that command does not work on that device" . I " got smart" and put both the Wemo switch and the ST iteration of the wemo switch in an Echo group " Back Yard lights" so "usually one or the other will actually hit.
Of course better than 1/2 the time my lonely Wemo switch shows offline in the native Wemo app as well. Yet will work with ST triggers and Echo. Which is why it is 1 lonely switch.

I have the exact same issues with my Wemo switch… But it never fails to work…

Still doesn’t work and support that took two week to reply said it is a known issue and are working in a fix but can take months. Glad I switched from Vera…

All of my Wemo devices went offline in ST last night too without warning. I just happened to stumble across the fact that they were all offline. They worked fine manually, and in the Wemo app, and with IFTTT triggers, just not in ST. I open Wemo Connect in ST and pressed edit and then save and all but one device came back online. Two more attempts brought the last device online again. I guess I need to rethink using any of my Wemo devices in my security setup.

my WeMo stuff has been flakey for weeks, and also showing offline, and not updating status in smartthings. I have my outside lights on a IFTTT rule and it works 90 percent of the time, but I get endless entries in my events history saying they are offline, then 15 min later they are back.

I also had an issue with a door sensor showing open when it was closed, but that seems to have fixed itself.

im also getting excessive notifications for things that I have never got notifications for before.

1 Like

The door sensors seem to have been fixed but the WeMo devices just are a mess. I do need to use them. Not sure how I can use IFTTT with a WeMo motion sensor and a GE link light or Zwave light switch which is why I used ST in the first place.

Any resolutions with WeMo issues and smartthings? At this point I have decided to just remove WeMo devices from smartthings. I would lose connection with them after about a day anyway.

It seems like it was more reliable a few months ago, but no more.

I just rebooted my hub and all the WeMo devices are offline and now the hub cannot control my GE link lights.

It’s ine issue after another. I don’t understand why it has so many issues.

wemo is still whacky, but I had to remove one of my link bulbs last night because it wasn’t responding, and was able to relink it thru hue, and then add it back with hue connect. I thought this was going away as hue wants to just support hue products on their hubs.

I have (had) an open ticket with support about a routine not properly triggering one of my Wemo devices. Apparently there has just been an update to the Wemo Connect SmartApp. See the January 7 reply from support below:

I didn’t realize at first that this particular switch you’ve been having problems with is a Wemo device. So, historically the Wemo integration has been very inconsistent (as I’m sure you’ve seen). But the good news is, we have a new and improved integration that was released a few days ago. To take advantage of the new integration, you will need to remove the Wemo devices from the SmartThings setup, delete the Wemo (connect) SmartApp, then re-add them all. When you re-add the devices they will automatically get added back with the new code, and the whole thing should be MUCH more stable.

I followed the instructions. We’ll see if things improve.

That’s good to hear. I will re-add mine as well then.

Have you seen improvement with WeMo? I tried it. Still isn’t picking up all of my devices.

Wish they would push firmware update for GE links too.

I’m still experiencing the app intermittently not knowing the current status of my Wemo devices. But the triggers seem to be working more consistently.

1 Like

I’m getting the same. Control seems better but status is still buggy.

my friend deleted all of his wemo devices and deleted the wemo connect and then re-added everything and said it was a little better but still issues.

I did the same thing. It was good at first but seems like it’s back to it’s old tricks.

1 Like

I did the remove/add procedure and the problem is not solved.
Does Anybody knows something else about this?