Visonic MCT 340E issues

I ordered these and used the thread here to add a device handler to my hub. All went well with that but now when in pairing mode I can’t get my smartthings app to detect the sensors. Any help? Thanks.

Bring them close to the hub. Put the hub in discovery mode. pull the cover off the visonic sensor, remove the battery and put it back in. try that and see if it connects.

By putting the hub in discovery mode you mean “add a thing “ in the app?

Yes (filler here to get 10 characters)

No go on the batter pull. I was three feet from the hub. I also deleted and reinstalled the DH

How close is your ST hub to your WIFI router?

Sitting right on top of it. Literally

If you have a long ethernet cable, try moving it at least 10 feet from the wifi router. Something to try - may or may not solve the issue.

Also delete your custom handler. Not needed anymore.

I actually tried it without the handler when I deleted it to retry it. Also tried two different devices. This has me puzzled.

I feel like I have tried everything suggested. On two different door sensors. Any other suggestions would be greatly appreciated. I may try to contact their customer service.

I’m not in front of mine but if memory serves they have a tamper switch. What happens if you toggle that? I also remember they took up to a couple min to find sometimes.

What handler does if use if not the custom one? I’d like to remove my custom handler, but would rather not have to unpair a sensor to figure it out.

device type: SmartSense Open/Closed Sensor

1 Like

Nice. That converts them to local also, good deal. Thanks.

I received one of the MCT-340E sensors today, ordered via Amazon. I was able to pair it easily about 20 feet from the hub. I just clicked “add a thing” in the app and then pulled the plastic tab that isolated the battery; it started blinking red, then showed up in my app about 20 seconds later.
It originally paired as a Visionic Door/Window sensor, because I had the 3rd party handler installed. It works great, however, with the SmartSense handler now that I’ve switched it over.

I hope your batteries last longer than mine :wink:

Tried three of these so far with no luck. Let each try to pair for 5-10 mins without the device handler. I toggled the tamper switch. Left it open left it closed. Pulled the battery etc. can’t get them to pair. Here is a picture of the ones I have.

I still think you should try moving your ST hub 10 away from your WIFI router :slight_smile:

1 Like

how many other zigbee devices do you have?