Need Help with Visonic MCT=340E

Hi all! I’m a brand new ST user (formerly with Iris and then with Wink). I’m trying to connect about 30 Visonic MCT-340E Window/Door sensors that I was told worked with ST. I can’t get them to pair. I contacted Samsung and they said they are not supported and do not work. Any help would be appreciated.

Try resetting the visonic sensors then attempt to pair them to ST. :slight_smile:

Ha ha I had a momentary lapse and was thinking z-wave but they are zigbee

To reset: For the visonic Sensor, you should be able to reset by opening the cover and removing the battery. Then reinsert the battery, put the cover back on and try to pair it.

Thanks @jkp! Since Visonic is not listed on the “Add Device” list, I assume I just click “Scan nearby”? I just tried that and still nothing.

Remove the cover, remove the battery, replace the battery, press that little button inside the sensor, then scan nearby in the ST app. Then put the cover back on the sensor after ST discovers it. I added more more step I left out. Sorry.

Still no luck. The light is flashing 3 times every 5 seconds or so but still can’t get ST app to find it.

You’ve been able to add other devices to ST so far? Any of those zigbee devices?

I had about 6 of these for a year, just be prepared, they will disappear completely at random. This same model did that to me about every 2 months, had to set them up all over again and rebuild all scenes/pistons involving them. I finally sold them all and went back to z-wave for all of my sensors, trouble-free since then.

I have 6 or 7 of these and they work perfectly for me! Although, it’s been a few years since I’ve paired one so I think it was all done with the classic app. I did not have to do any custom DTH to get them to work.

Thanks for the help everyone. I got them working. Turns out…I didn’t have the hub synced to the app completely which is why nothing would sync. So now I’m all good. Now I just need to set up the alerts.

1 Like

Hi Bryan, I lost all my Visonic 340 E open/close sensors. They still work in classic app but in the new app it will not connect. The device handler says they are working in the cloud. I talked with Samsung and we tried a bunch of things and nothing worked.

Can you please explain in detail what you did to get yours back online? And, are you sure yours are still online? Can you click on the visonic device and see everything?

Thanks in advance.

change the device type to smartsense open/closed sensor and see if they work. you can change one to test :slight_smile:

JKP, thanks for the response more so seeing you are on vacation!

I attempted to do what you said.

I deleted one of my Visonic 340E open/close sensor
I then pulled the battery, replaced, red lit briefly
I went to new ST app, hit the plus, scrolled down to “devices/sensors” clicked MULTIPURPOSE SENSOR. Note: there is no SMARTSENSE option. It then pulls up the approved companies. There were a few companies, I chose SMARTTHINGS. Then it brought up two choices I clicked the second one "Multipurpose Sensor (STS-MLT & Others). Note: I did try first choice but did not connect. It then found the device and even labeled it Visonic. ST App said it was successfully added. I then clicked on the newly added device and it says “Cant connect…”.

I then tried a reboot. That did not work.
Lastly, I tried the regular open/door sensor, again picked ST as company, it could not connect.

Is it possible because I have a device handler for the Visonic? I tried to delete the device handler and it won’t let me saying there are devices connected.

Any thoughts?

No! No! I didn’t mean for you to remove the device :slight_smile:

Sorry, I should have been more clear.

Login to IDE
Go to the Devices section
Find one of those sensors, open it and click on Edit
Change device type to smartsense open/closed sensor
Click update
Then check it in the new app to see if it works.

Too funny, get this. So I went into IDE, changed the sensor to SMART SENSE OPEN/CLOSE. Clicked saved, then a green message in IDE came up and said the device has been deleted??? what the heck.

Any chance you hit the delete by accident? The placement of that button is really in an ackward location.

Let me try on another Visonic 340E. I now can’t get the Visonic that got deleted to add back.

Blame me! I am deleting all your devices :slight_smile:

I cause destruction everywhere

LOL, you know what, you were right, I thought i was clicking the UPDATE button but it seems even if you are on the UPDATE button to the right side within the button, it gets the DELETE button. This time I went to the very left of the UPDATE button, and it updated and now I can see the device!!!

Any idea how to add back that other one? Maybe through Classic App? but not sure there is a way to bring over to New App. Classic App by the way is suppose to die tonight.

Sure, try the Classic and see if it adds. If, by chance, you have a custom device for those visonic sensors, open it in ide under device handlers and click on publish for me. Reset the device and try to add.

Once, you get them converted to the new device handler and verify they work, delete the old visonic device handler from ide so it does affect any future visonic sensors you may add or need to reset any of the current ones.

I will try that now. Thanks for helping me out here. I supsect there are millions (maybe thousands) that are finding or will find out that their devices are not actually connected although it appears they are in the new APP. I spent an hour with ST support yesterday and they determined (several people were involved) that I would have to buy all new sensors. I pointed out that seemed ridiculous given I am not the only one and oh by the way you know exactly how many are using these Visonic devices around the world. I also pointed out I went from having security to no security. I wrote Hubitat a letter late last night which I asked the sales team stating that the iron is hot to get people to transfer over by deeply discounting people coming from ST. They responded the Visonic work on Hubitat and that they forwarded my letter to sale boss. Last night I didn’t want to leave but there has been a culmination of mistakes made in past couple years with ST so I was at the end of my rope.

You JKP on the other hand, got my house and two places in Mexico up and running. Thank You. Vacation well deserved!!