Hub not finding Visonic MCT-340 E Door Window Sensor

Hello, NOOB here…so please stay with me.
I am trying to add ‘Visonic MCT-340 E Door Window Sensor’ to my hub.
In the developer account, I created a device handler with this code:
Then created a device using that device handler. While setting up the device, I put in random number for Network device id e.g. 0017884D2FC7/5…I already have other devices with network IDs from 0017884D2FC7/1-0017884D2FC7/4.
Now, after logging into the Smartthings app on my phone, I can see the newly setup device and it says ‘Open’. If I click on ‘Configure’, nothing is happening. I have not attached this device to the door yet. If I manually place the sensor and magnet next to each other and check status in the app, it still says ‘Open’.
How can I test if the device is working as intended or not? Am I doing anything wrong.

Are you saying you created a device in IDE? If that is the case, you need to discover the device in the ST app when you click to discover devices, then put your visonic Sensor into pairing mode.

This device supports native integration now, so you don’t necessarily need to have a custom DH. Just put the the sensor in pairing mode and add new device as normal.

I factory reset the device and put the sensor into pairing mode. ST found the device and said it will configure it. After that, I see the device in the list but says Unavailable with a red ! mark. Also, in IDE, I see that the device is OFFLINE.

This did not work for me :frowning_face:

Are you pairing close to the hub and then moving it further away?

I was sitting close to the hub, but that didn’t help :frowning:

if you left it close to the hub (within 10 ft), range probably isn’t an issue. Even though it shows offline, does it update the status when you move the magnet away and back close?

No it is not updating the status.
Noob question…once DTH is published, do I add the device as a thing from ST app or from IDE?

I followed the instructions provided here:

I have successfully managed to get the devices integrated into ST. Problem was that my hub is in a corner position and I think devices were not able to talk to it due to range issues. As soon as I brought hub forward, it detected the devices.

Yeah, you want your hub in a central location of the house at least 10 far away from any WiFi access points.

I thought they were natively compatible now, so why is a device handler needed?

They are. Not sure why he used a custom device handler.

Just tried to pair another one of these and it seems like the hun is finding it and configuring it in the API as I can change its name but it continues to blink and does not show up on the phone

Just like the bunch, I am one of the affectees. Kinda still a newbie in the Smart stuff world, making my way by following the instructions to the word.

Bought and kept Visonic MCT340E for quite a while, untill i planned to pop it open and plug it, however after multiple retries, this aint showing in the “add things” search in the mobile app. I did read that it was now natively supported by SmartThings, dont know why isnt it showing up.

Has it got something to do with the SmartThings hub version (I have v1 the oldest original one), or this multisensor revision number. Mine is Rev A, probably an overstock low price throw away piece.

I also did try adding the code to device handler and publishing it (only for me), however after all kinda of device/sensor restarts, it still aint showing up.

My hub is placed next to my Wifi Router and can see and talk to other things quite well (a motion sensor and multisensor from original kickstarter bundle). Is it of any significance, I have tried however by turning off the wifi transmitter of the router, and then trying to add with the same results.

Also i noted apart from my default “Home” location where my hub and devices are residing, there is an extra “ghost” home location showing up in my account , which I am not sure when did I add. I tried to remove this empty location , however got the following message.


500: Internal Server Error



Reference Id



Sun Nov 18 13:22:16 UTC 2018

Would appreciate the kind guidance anyone can bring to address to my mentioned issues.


  1. When adding the sensors, bring them within 1-2 feet of the hub.

  2. For removal of the empty location.

You may want to login with an incognito/private tab in your browser.

In order to delete a Home Location that has nothing in it:

  • Login to IDE at
  • Goto Locations
  • If you have multiple Locations, select the invalid one
  • Make sure there is no Hub associated to it
  • Scroll to the right and click Edit
  • If the Default Location shows “true” (will be read only)
  • If it is “true”, go back to Locations and select your primary (Real) location and set the default location to “true”
  • Now you can edit/delete the additional Home location as it will automatically be set to “false”.

If that fails to resolve the issue, contact ST support and they can do it

Thanks for your reply,

For the ghost location I will try your suggestion.

For adding the stubborn “thing” I have literally tried it by placing it over the hub physically and then running a search. Still refuses to show up. Maybe the piece is faulty, I have tried inserting a new CR2032 battery as well, the red LED keeps blinking 3 times (5 seconds apart), however never shows up in the app.

Any ideas.

Maybe try removing the battery in the sensor, putting the hub in pairing mode, then insert the battery into the sensor.

Or try rebooting the hub.

Checking up after a while. I guess my problem is somewhat similar to this thread, since I am using a Hub V1 circa 2013 (when they back ordered thru SmartThings web store).

Hoping to find a clue as I have sent an email to support team.