Visonic MCT-340 E - just won't pair (always paired before)

I’ve got about 8 or or more of the Visonic MCT-340E open/close sensors paired w/my hub. Never had a problem pairing/using them.

I had several unopened extras and wanted to add one to my hub today. Tried two new sensors and neither will pair w/my hub. I’ve never had any problems in the past.

Troubleshooting so far:

  1. Rebooted hub
  2. Shut down/restarted ST
  3. Pulled battery from sensor
  4. Put ST in add device mode
  5. Put battery back in sensor, pairing mode starts, three blinks, pause, three blinks
  6. Put sensor 1 foot away from the hub

Also tried above with a new battery in one of the sensors.

The Visonics are just not being found by the Smartthings app - it searches and searches but never finds the sensor. Since I tried w/two different never used sensors, so it’s not the case of one sensor randomly being problematic.

Anything change here? These have been natively supported for a long time, and I’ve added them in the past w/out issues.

Any suggestions? Appreciate any help with this.

if you are using a custom device handler, login to IDE and open it, save and publish it again. then try adding them.

as a side note - you may want to consider switching them over to the stock smartsense door/window sensor and remove the custom device handler. the smartsense DTH runs locally and also works in the STSC app.

Nailed it, @jkp.

Not sure how it happened, but a DTH in my IDE was duplicated, two copies.

Removed the one that wasn’t being used and then the Visonic was found w/the custom handler (one that allows me to adapt them to be water sensors if I want to). Then I switched the Visonic back to the Smartsense DTH (since I’m using this one as a door sensor) and all is well again.