Unable to update my hub firmware


(Dana) #1

Hello!
I just got my smartthings yesterday but I’m having issues updating the hub firmware. When I select to update from the smartphone app, it just gets stuck. The progress bar is stuck and it doesn’t move. I let it do its thing for about 30 minutes and the progress bar is still at like 1%.
I tried plugging the hub directly to the modem Instead of through router but that just disabled the hub. I tried disconnecting the hub for couple minutes and that didn’t fix it.

Any help is greatly appreciated!


(April Wong) #2

Hey Dana!

Welcome! Shoot an email to support@smartthings.com, and they can assist you with it.

Cheers!


(Nick) #3

I just got mine yesterday as well. Exact same problem. It hangs on update. I have been unable to sync any devices except the phone proximity sensors. My hub show a solid blue light and from the docs said it should be solid green if connected and working properly.

Reset my router, cable mode and left the hub unplugged for 10 minutes a few times.

Is something possibly down on the SM side?


(Dana) #4

So my husband contacted support and was informed that many users are having the same issue. The support told him to keep trying. So far we haven’t had any luck. The update progress bar isn’t moving…


(Nick) #5

Mine finally worked. Green light an all. All devices now connected as well. Live is good.


(Dana) #6

Ours finally worked too! I left the update running last night before I went to sleep and this morning the update finally completed.


(Karl) #7

Hey all,

Sorry for the delay in getting your new hubs up and running. It looks like it was caused by an issue on our side. Our guys are working on it.

In most cases, it looks like the hubs get up to date after a few hours.

If you’re still having issues, please let us know. @ support@smartthings.com