Smartthing Hub V3 (2018) fails setup

I am pulling my hair out trying to get this thing setup. I’ve done everything possible including opening the various ports on the firewall, factory reset, hard reset, uninstall and reinstall app but no luck. The app starts the set up and gets hung at 48% and then times out and says my hub is offline. If this is a firmware issue then it’s hard to upgrade firmware if you can’t even register the device to your account. I can’t believe something that’s suppose to be a simple PNP device would require hours of troubleshooting with shoddy tech support. I chatted with 2 support people and they just sent some links and were no help. Looks like this is a known issue but there’s no official acknowledgment and fix from Samsung that I could find. Would appreciate it if someone can please provide some suggestions.

1 Like

Exact same issue here, try for almost 6 HR, Did you figure it out, did tech support fix this, I’m still waiting for samsung tech person for solution.
I’m almost about to smash this MF THING with hammper to pieces.

It turned it was a defective unit. I got the replacement and it came up right away as suppose to.

I ordered mine from Amazon so, I got a replacement within a couple of days. Tech support was a waste of time.

John, I also order it from amazon and thought it was defective unit, they send me a another one, same problem, try set-up with tech support, same issue, stuck at 48% and Hub is offline.

We can even set-up hub properly yet, and i wonder how many more issue it will have trying to connect all 14 of the z-wave, zigbee devices i already ordered. ???

using Android? what is the ST app version?

Hi jkp, Samsung A50, 1.7.38-21

I have a feeling that some of these units in the warehouse have an older firmware. The trouble is that you can’t upgrade the firmware until the set up completes. I just lucked out, and the replacement that I received came up normal. You may want to pick up a unit from a local place like Best Buy and try that.

John, so replacement hub set up go thur ?

The replacement hub set up normally and I didn’t have any issues.

Thanks John, Bought one from best buy, but still not working, this is third Hub, try Ethernet with cable & wifi, different router, ph with wifi connected or with ph network connected, Connect with two different router, many
different combination possible, still not work, I’m afraid is my samsung A50 ph is culprit,

I’m about to ditch this ST and go with Home Assistant route,
And please don’t tell me my samsung ph is problem,
Samsung device is not compatible with samsung PH.

Are you saying that the ST App is not compatible with your phone? I have a Samsung Galaxy S7 and it works fine on that. Did you check with tech support to confirm that the App is not compatible? Sorry to hear that.

Hi John, I read somewhere that certain phone having issue with setting-up ST, I gave my ph spec to last samsung tech i talk to and still waiting on them. I mean it can’t be this hard to do, I had set-up wifi thermostat & etc many times with very few issue, I’m a HVAC guy now and use to be electronic techie as teens. not very good at network stuff, and still leaning.

ST app seems working fine on my A50, it show all my wifi and bluetooth device.

During initial setup the ST App communicates with Hub via WiFi connection that it establishes directly with the hub. This WiFi network is a separate connection and not your home network WiFi. It’s possible that your WiFi setting on the phone is always locked on to your home network WiFi so it can’t communicate with the hub. You may try disabling your WiFi on the phone first and let the ST App turn it on automatically. The phone has a setting to automatically connect to your home WiFi. Something worth trying.

When I try set up in wifi mode, Yes, ST hub is connected to my ph wifi

, but it seem ST hub and my PH is never connecting to my home wifi.
In wired networks set up option, my PH is always connected to my home wifi.

I was having almost the same problem with my first unit. I tried using the wired LAN connection to the Hub and I was getting the issue where it would get stuck at 48% during setup. You should do a factory reset (pin plug, 30 seconds routine). In normal condition after the phone connects to the ST Hub directly through it’s own WiFi (Not your home WiFi) you will get a screen which will ask you to put in your Home WiFi network security info password etc. Once you do that then the Hub will connect to the Internet. When you first turn on the App to do set up, it asks you how you want to connect Ethernet or WiFi. If you choose WiFi you’ll later be prompted with the screen I mentioned above. If you choose Ethernet then if everything is working then it’ll start downloading the latest firmware and continue. I would try the Ethernet route instead of WiFi. Hope this helps.

If you ever get this thing to work, it’s pretty good and I’ve had no issues. My feeling is that it’s firmware related (buggy software) since you can’t have so many units with defective hardware. Their tech support should be aware that so many people are having the same exact issue and have an explanation.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.