Issue with Firmware update

Hey guys. Newbie here. I’ve been using SmartThings mesh in my house for a couple of years and never had any issues. Today one of the sub hubs stopped working. The unit was flashing red. On the SmartThings app that hub just says “firmware update needed” the when you click on it, it says “it may take one hour to update”. This has been going on for several hours with no change. The main hub across the house is working just fine. I tried unplugging it and plugging it back in and I just get green blinking light on the unit but same message on the app. What should I do?

I’m sure that’s very frustrating. You will probably need to contact SmartThings support if the firmware update failed: they can see more things from their side then we can.

You can start by opening the smartthings app, Choose Menu, then Contact us.

Or if you are in the US, you can start from the webpage:

In either case, make sure you give them the model number of your hub, that will save one round of questions.

This sounds very similar to my situation, but with added twists.
My hub decided it would no longer connect to anything, about the same time as you say you had the problem.
That meant that the two devices on it were disconnected. One was a Philips Hue bulb, which is now re-connected. The other is my front door lock - Yale Conexis L1 with Z-Wave Module 2. I now can’t use the one function I bought the whole kit for - remotely unlocking the door.

I spent hours last night, eventually resetting the hub multiple times. The instructions for resetting are not at all clear. Anyway, it used to be connected to my home network by Ethernet cable. It was working fine up until about a week ago, when I first noticed I could not unlock the door using Alexa. I didn’t get around to doing anything until I noticed that Alexa could not turn off the Philips Hue bulb. The hub was showing solid blue. I repladced its Ethernet cable and also tried connecting the hub directly to my modem/router rather than to my mesh device. The hub would occasionally go green and become partially visible on my LAN. Trying all combinations, I never got it to get back visible via the mesh device.

I eventually found out that I could ask the hub to connect wirelessly (which I’ve never done before). Lo and behold! It connected straight away. The WiFi is via the mesh devices and then on to the router by Ethernet.

It promptly insisted that I install updates, which took several minutes. This is the point where I manage to reconnect to the Philips Hue bulb, which is back in the home network perfectly.

I wonder if the hub software attempted this update a week ago, and partially corrupted itself?

Nothing I do lets me get my door lock to reconnect. I’m thinking that Samsung may have dropped support for it in this update.

@JDRoberts The Samsung “Contact Us” route led me nowhere, with an initial dropdown list that was a required field and had no applicable entries on it.