Unable to add devices after reset

Over the last year I’ve experienced frequent drop-outs of my Xiaomi Motion and Temperature sensors, so last night I reset my hubs, deleted the “Location” and started all over from scratch. Only this time not one device would even connect to my hub when resetting the device(s). I have tried all ZigBee channels and a second reset. Also tried another hub as the “main” hub during the reset. My hubs are from the US and used in Norway. Wifi works as normal.

Device list:
3 Smartthings Wifi (US version)
22 Ikea Lights (ZigBee)
6 Ikea plugs (ZigBee)
7 Xiaomi Motion Sensors (ZigBee)
3 Xiaomi Temperature Sensors (ZigBee)
1 Neato Vacuum Cleaner (SmartApp)

Edit: added info from below

I don’t know if you’ve tried this yet, but each individual zigbee Device Has to be individually reset before you can join it to the hub again. Normally you would look up the user manual for each model to find the reset instructions

For example, here are the reset instructions for the IKEA Tradfri smart plug:

To factory reset the TRADFRI control outlet, press and hold the reset button (pinhole underneath the light, located at the top of the outlet) with a paperclip until the white light starts fading. Hold onto the button for a few more seconds, then release. After this, the outlet will automatically connect.

Thanks for the reply! I have done this on each of the different types of devices i own. On devices such as the motion sensors i moved them close to the hub just in case. I have also tried switched out the “main” hub to another one to check if it was that specific hub itself. No success yet.

1 Like

Something to try but doubtful it will resolve the issue… open your hub in the ST app and disable secure mode. Reset one of your zigbee devices again and try to add it. If that works, reset the remaining devices and add them.

1 Like