Cannot add any zigbee devices [SOLVED]


(ck) #1

I’ve been working with support on this through email, but not having any luck. (Hub v2)

I’m to the point now that I’ve deleted ALL zigbee devices
When I try to add any back, the app simply continues trying to discover. I’m doing the reset procedures correctly on the various devices.
Support claims that they’re that they’re not seeing any devices being properly reset. What are they looking at? What are they talking about? I’ve added these zigbee devices before…so i know how the process works.
(Z-Wave devices and Hue work just fine)


(Robin) #2

How are you removing the devices?

Do you just delete from ide or go to remove in the ST app, activate remove mode and then press buttons on the devices?

The former won’t reset the devices.

The latter will reset the devices and ST could see that in their logs.


(Ray) #3

There is no way for support to see if a zigbee device is reset. Not all zigbee devices have the same reset procedure so which brand/type of device are you trying to reset?
By reset the device and not remove the device in IDE/Smartthings app. You won’t see a new device during discovery because the device is already in IDE but it starts to work again.


(ck) #4

Initially, I removed 1 or 2 or the non-functioning zigbee devices from the app.
After contacting support, and they mentioned not being able to see things happening, that’s when I decided to actually delete them…and finally all of them, from the IDE.

What is “remove mode” How do I “activate” this mode?

The zigbee devices I have are Samsung motion sensors, Samsung contact switches, and Iris motion sensors.
Since then, I’ve even tried activating a never used Iris contact switch and motion sensor. These new devices wouldn’t register either.

I’m at the point that ALL zigbee devices are removed from the app/IDE and none of the devices are able to re-register.


(Barry) #5

Many (most) Zigbee devices have a method to reset the association from the device itself. Many SmartThings devices, for example, specify that you hold the button down for N seconds (most sensors), or hold the button down while plugging the outlet in…and until you do this, the device will NOT connect to ANY Zigbee master (including the same one it was previously connected to).


(Jared) #6

Apparently no one is actually reading what the OP has said. He HAS reset the zigbee devices and he HAS tried fresh new devices that have never been paired before.

I don’t think not resetting the devices is the issue.


(ck) #7

Latest from support:
“refreshed AppEngine on your Hub, which is responsible for the local processing. This should clear out any cached data from previous ZigBee connections that no are no longer there.”

The results after the refresh are still the same. Devices not discovered.


(ck) #8

Another response from support:

“I was able to pull some additional logs and dig through them and found that your Hub data became corrupted, which was causing it to not discover devices. We went ahead and reset the Hub data on your Location and rebooted the Hub from our end and now the event reporting in your Hub looks to be much healthier.”

I tried re-adding the devices again and continued to see the same failure.
On my own, I unplugged the hub and removed the batteries and waited about 15 minutes.
Once the hub was back online, I hit the button in the app to add a new device and nearly instantly, all the devices that I had tried to add 15 minutes prior showed up on the screen.


(Robin) #9

someone forgot rule 101