Tuya PIR ZM-35ZH-Q - detected in ST hub but stuck

I bought this new zigbee 3 pir, product ZM-35ZH-Q. It gets detected as a thing and then i’ve manually tried changing the device type, firstly as a Zigbee motion sensor then as a Smartsense motion sensor.

When I test it I can see it the logs are written as below so clearly it can detect motion but when I try and configure a routine with it in ST it doesn’t do anything, does anyone have any suggestions?

e6dcea44-fb8e-4a19-a002-aab8a705e77b 8:36:33 PM: debug Parse returned [:]

e6dcea44-fb8e-4a19-a002-aab8a705e77b 8:36:33 PM: debug description: catchall: 0104 EF00 01 01 0000 00 7E61 01 00 0000 02 01 00660C0200040000036A

what was the device type that you changed from?

EF00 is a proprietary Tuya cluster, it won’t work with a generic zigbee DTH or Edge Driver. You’ll need to find one specific to that Tuya model.

Try checking the quick browse lists in the community-created wiki, there should be some there.


Although you could use a DTH today, be aware that support for those is shutting down soon, so you might want to just start with an Edge Driver since those are part of the new architecture.

FAQ: I have no idea what Edge is. Is that a new developer tool? (2022)

From Zigbee motion sensor to Smartsense motion sensor.

Thanks for your help, I had a look here but couldnt see anything for Tuya PIR’s, am I looking in the right place and just no one has written it yet?

That’s the right list, did you ask in this thread? (The image is the quick browse list for Edge Drivers for sensors, the same one you linked to). At least that author has been working with Tuya sensors, so they may know if anyone is working on the PIR devices. :thinking:

Otherwise, as you say, it may just be that no one has written one yet, the Tuya devices can be tricky.

Have you already tried this driver below ? It is specific for cluster EF00

How die you even get it to do that?
When I paired mine it jut shows as generic device and I can’t do anything with it.
I tried to install these edge drivers

but now it is showing up as a temp humidity sensor
I can get to the list of the profiles but I can’t select one it is asking for data points but I don’t what those are or where to find them.
I don’t really care about usinf ST routines I just want it to work and show up in Alexa so I can use Alexa routines,
Did you ever get it working in St with routines or have you tried it with Alexa routines?
did it work?