Troubleshooting GE Link Lights

Just purchased a SmartThings Hub v2 from Amazon along with two GE Link PAR38 smart bulbs (spotlight style). Unfortunately, I’m not having any luck getting either bulb to pair with my hub. A number of people in the community have reported success, so I tried their strategies without success:

  1. Straight out of the box.
    1a) Open App on Android device
    1b) Select “Connection New Device”
    1c) Wait until the lights on the hub start blinking
    1d) Turn GE bulb on.
    1e) Wait 5 minutes. Nothing.

  2. Reset bulb
    2a) Followed the reset procedure of: on for 3 seconds, off for 3 seconds, repeat a total of 5 times. On 6th time, light dims and then goes bright. Turn bulb off.
    2b) Open App on Android device
    2c) Select “Connection New Device”
    2d) Wait until the lights on the hub start blinking
    2e) Turn GE bulb on.
    2f) Wait 5 minutes. Nothing.

I believe the GE bulbs are ZigBee, yet I don’t see anything in the logs for the hub that suggests it’s actually looking for ZigBee devices. See the attached screenshot for details. Of course, I’m not sure I really understand what I’m doing, so… :slight_smile: My Schlage lock, which is Zwave, worked great right out of the box.

Any suggestions on how to troubleshoot this? Or ideas on what to try next? Any advice would be greatly appreciated.


How close is your WiFi router to the hub? Try to o get some distance between the two, or turn off the WiFi temporarily. Also, try to move the bulbs closer to the hub when pairing.

What Dan said, plus turn the GE Links first, then select “Connect New Device”. Close to hub to pair, you can move them after.

Do you live in California? Do you have an iTron/Openway smart meter for your house?

Excellent suggestions. I did forget to mention a few helpful details about some of the issues people brought up. When I attempted to pair the GE Link and the SmartThings hub, I made certain of the following things:

  • GE Link bulb and the hub were approximately 18" apart with direct line of sight.
  • No obstructions of any kind between the two devices
  • Wireless access point is probably 30’+ away and a floor below.

I did try the suggestion from @ogiewon and completely turned off my wireless access point. Sadly, that didn’t seem to help.

Per the question from @benji, I do live in California. San Francisco to be precise. And PG&E does use smart meters. While they’re made by Silver Spring Networks, not iTron/OpenWay, they still use ZigBee. :frowning: Unfortunately, I work for a company that locks down their internal network, so I can’t bring my hub into the office and plug it in. I’ll see if I can think of an alternative way to test that idea.

Since my Schlage zwave lock works perfectly, if hub and bulbs work outside of my home, does that mean I have to avoid any and all ZigBee devices and stick with Zwave?

Placing money this is the issue…

I finally got the two GE Link Bulbs paired with my SmartHub v2. I wasn’t able to test them at work, since I couldn’t find a desk lamp to try. However, when I returned home, I moved the SmartHub to an entirely different part of my house and then tried pairing the bulbs. They paired within seconds and work perfectly fine now. :smile:

At this point, I can’t prove the PG&E smart meter is the cause of my problems. But, my original placement for the SmartHub was one floor directly above the smart meter. Now the SmartHub is on the opposite side of the house and everyone is happy. Interestingly enough, just like the linked issue, once the bulbs were paired they work fine.

I still think it’s bizarre… I mean, I find it really strange that it only seems to interfere with pairing. If I were a little more ambitious, I would unpair a bulbs, move the hub back to it’s original location and put a Faraday cage around the smart meter. Sadly, I’m not up to that tonight. But maybe I’ll give it a shot this weekend.

Thanks again to everyone for the help. I would never have thought of moving the hub to a different location without these suggestions. You guys rock.

1 Like

Thanks again for letting us know, definitely chalking this one up to the smart meters again!

@slagle we’ve got another one!

We have reached out to iTron. No new to report yet

Looks like this one is made by a different company (Silver Spring Networks) so the problem might not be unique to iTron.

By the way I apologise if I’m tagging the wrong person, I can just remember ‘slagle’ easier for some reason :smile:

1 Like