Trouble Connecting Switches with 2.0 Hub

hubv2
communitydevices

(Jason) #1

I recently purchased a Smartthings 2.0 Hub after becoming exasperated with my previous controllers (Almond+ & Wink). However, so far I am even more frustrated, especially after doing so much research prior to deciding to go with STH 2.0. Every website stated that the STH 2.0 was the best. However, I cannot seem to conenct any of my light switches. I have GE/Jasco as well as Linear switches. I have just spent a lot of time on the SmartThings website to see exactly what is compatible with the STH 2.0 Hub. Come to find out, none of the switches I purchased this year are losted on the Smatthings website as being compatible. Many of my switches are merely upgrades of the ones listed on the website. So please, someone tell me I didn’t make a huge mistake. Here is a list of what I have not been able to connect:

GE 45613 - 3-way Dimmer Switch
GE 45637 - Light Switch
Linear WS15Z-1 - Light Switch
Linear WD500Z-1 - Light Switch
Linear FS20Z-1 - 20 amp in-wall Switch
Schlage RP200RNX - Plug-in Dimmer Outlet
AEON Labs DSC06106 - Plug-in Outlet
AEON Labs DSB04100 - Door Sensor


(Pizzinini) #2

Have you excluded them from your previous controller before you tried to connect them?


(Jason) #3

pizzinini,
Yes I did delete all connected devices from my Almond+ first. Do I need to do something with the switches themselves too? I did pull the air gaps for a while, which has been suggested in the past as a way of making sure the switches themselves are reset.


(Pizzinini) #4

Did you “delete” them or “exclude” them. Delete may just hide them but not reset the z-wave connection in the device (Sorry, I don’t have a Almond or Vera so I don’t know how exclude works there). I noticed in the past though when moving devices from one hub to another that I sometimes had to re-connect them to the original hub and exclude them again before being able to connect them to the new hub. Also I sometimes needed to un-plug the original hub after excluding them for them to be seen by the new hub.

For the SmartThings hub: Your devices should work. I have multiple GE 45613 connected without any problems.


(Jason) #5

Well, that is great to hear that they actually are supported. I am running out of “tech geek points” with my wife with this whole Home Automation thing I have gotten in to this year. She loves our Amazon Echo, which is one of the reason I got the STH 2.0. My Almond+ does not integrate with the Echo, so I got a cheap WInk Hub just to use the voice feature. However, the WINK Hub would not allow me to connect several things. Now another $100 and I have the STH. The Almond+ only had a delete option, not an exlude. So, perhaps I need to find a way to reset the switches themselves, yes?


(Eric) #6

I think the answer is yes. I think your switch devices are remembering the old hub, so they won’t join/include a new hub until they are reset. The procedure to reset any device can vary from manufacturer to manufacturer so you want printed instructions.

I know that my one sticky plug-in switch Everspring AN163, would not rejoin until I reset it (example by pressing button 3 times in 1.5 seconds - specific to my device).

Also FYI the Schlage RP200RNX in particular is said to forget its settings. I had some trouble including it, and it did eventually include, but I have not been using it.


#7

I have the same switches throughout my house and I just finished migrating them over from a VeraLite setup. You need to do general device exclusion if they refuse to pair with your new hub. Also, it really is much easier if you put your hub on a super long ethernet cable to do all of this instead of relying on mesh.

You can get to general exclusion by

  1. hitting the dots in the upper right corner
  2. hit My Locations
  3. hit the gear icon for your location
  4. scroll down to your hub
  5. hit Z-Wave Utilities
  6. hit General Device Exclusion
  7. hit Remove
  8. double click your switch to complete the process

Now your devices should pair without a problem. Make sure you repair the network once you have your hub back to its final position.


(Pizzinini) #8

Found this:

http://blog.securifi.com/removing-z-wave-sensorsdevices-from-your-almond


(Jason) #9

Thank you all for your support! I can’t wait to get home to try again to connect everything. Very much appreciated y’all! I will post my result.


(Jason) #10

Y’all are the best! I went home and after taking the dog out… I immediately got to work connecting all of my devices. Using my Almond+, I “removed” each and every device. The link you sent me pizinini was the key. I would never have thought that “removing all devices” would not be the same as removing them individually. Once I got them all removed, each one connected with ease with my STH. The only one that gave me a little trouble was my Linear FS20-1, but I eventually got it working. My 2 Schlage plug-in devices…they connected and the STH App says they are turned on or off, but the device doesn’t actually switch the lamp on. I will try them again today. Thank you all for your assistance.


(Jason) #11

One last thing… does the STH 2.0 allow for creating groups? I have 3 GE bulbs in a lamp that I want to turn on together. My old Wink allowed me to make a group out of the 3 bulbs.


(Mike Maxwell) #12

Not currently, however your Echo does!


(Pizzinini) #13

Support said they will bring the “groups” functionality back in one way or another. It existed for v1.

There is a workaround in the meantime by creating a virtual device and using the Smart Lighting app. It does not show you how many lights in the group are on/off but works for aggregating devices into one button.

Create a virtual switch:

  • Log into Developer IDE https://graph.api.smartthings.com/
  • go to My Devices
    • New device
  • Select “On/Off Butoon Tile” as Type
  • Select your Hub
  • The other fields should not matter as long as you fill in something
  • click Create
  • You should now see the new switch as a new device in Smartthings on your phone

Use the Smart Lights app to configure what devices are turned on/off by the virtual switch.


(Kevin Plummer) #14

I am having a very similar issue. Prior I had my Schlage RP200 working at another house. I moved and once settled I started setting up my network again. However when I went to add the RP200 it wouldnt connect. When I go to Things under Marketplace in the App, I then go to: Outlets, and I tried both the GE Plug-In Smart Dimmer and the GE Plugin-Smart Switch. I do not see an option for the Schlage Lamp Module. So I tried the GE which I had done in the past and doesn’t work… If I exclude the device and when I click on the button on the device it will then show one device has been excluded. So the hub does see the device, just not sure how to get it to pair since I don’t have an option for a Schlage Lamp Module. Any suggestions or ideas would be great.

Thank you,
Kevin


(Bob) #15

You could try going to the ‘Things’ tab, scroll down and click on Add a Thing.
Also make sure you device is restored to factory default so that it doesn’t think it is already paired with something. If it thinks it is still paired ith something else, it might not pair.


(Eric) #16

as much as I mistrust Schlage RP200, I have one operating ok for the past month or so. It is defined simply Zwave “Dimmer Switch” which is the same device type I am using for
Ge12729
Remotec ZDS110
Remotec ZDS100 (recalled! hardware not recommended)
if you can pick something similar instead.

The IDE login makes the assigned device type more clear than the phone-app.
https://graph.api.smartthings.com

You can also change the device type in IDE.


(Kevin Plummer) #17

Bob,

That is what I needed, I had never added an item like that before. But I added it with no problems, thank you for the suggestion.

Kevin