Serious n00b who just bought a house full of smart devices in need of guidance

I recently (as in two weeks ago) moved into a new home. The previous owner has something like 30 different smart switches, outlets, buttons, automated front gate. It’s pretty impressive how much work he did.

Unfortunately, the system was down when we arrived because his ISP asked for his modem back. It was a funny moment when he was showing us some of the things about the house and he was having trouble remembering which switch turned off which lights. Anyway, so he said to get our new modem hooked up, reset the SmartThings hub (IM6001-V3P01) to factory settings and then start doing the pairing process all over again with all the devices.

I’m so new to this and feel like I’m drowning as almost nothing is getting detected. The hub is in the same spot he had it in, so I know there is a way to connect to everything but I’ve barely been able to connect anything. I initially found a little luck with some of the switches near to the hub. I was excited that I was finally making some progress, but then I wake up in the morning and check the SmartThings app and two of my switches are gone from the app and two others are in a different room and “not connected” and no longer have names so I have no idea which one’s they are. I also have tried to delete them with no luck.

I feel like I need a crash course in how to do everything, but I also suspect that because all these devices were previously set up and paired, they need to somehow be excluded (which I still don’t completely understand…something about a device having a no longer valid HouseID).

Damn, even the most simple outlet I am having troubles with. I have a NuTone (NPD300Z) plug in module that I put with in 3ft of the hub and followed the instructions on, you know, plugging in a simple lamp and the pressing the button on the module…and nothing. NuTone is also not even a brand I can select in the app. Note, I’ve read about people using SmartThings Classic at times, but I don’t see the Classic app on the iOS App Store, so that’s not going to be an option.

I have starting reading posts on here. Lots of seemingly helpful people. Will keep doing so, but wanted to toss my story up here in the hope that someone might be able to help me get this system back up.


Well moments after I posted this, I took another look at the hub status in my browser (the thing where I can see events, etc.) and I WAS able to delete those extra strange misplaced switches. PROGRESS. Not much, but I’ll take anything at this point.

1 Like

Welcome! :sunglasses:

Let’s start with some basics. Z wave and zigbee Devices each store the network ID of the network they are connected to in the device itself. This is so if you have to take them off power for a while, maybe just to change the batteries, when you put them back on power they still know what network they belong to.

You have to clear that information in order to connect them to a new network. And when you factory reset a hub, you’re starting all over again with a new network so yes, you have to individually get each device to clear the old network information out before it will join your new network.

With Zigbee Devices, you can usually do that just with the end device itself, there’s essentially a factory reset option.

But with Z wave devices you have to have a hub issue an “exclude“ command and then you have to manually do something to the end device so that it will accept that command, and then it will clear out its stored information. And after that it will be ready to add to your new network.

Fortunately, you could have any zwave hub issue the exclude command, it doesn’t have to be the one from the old network.

So for each of your Z wave devices you will first issue the “general exclude” command from your hub, do some kind of physical button press on the device (the user manual for that device will tell you what to do). Then once that’s done, you can then do an include.

Note that you will not see any message about the exclude succeeding because these two devices have never been on the same network. The hub and the end device are not talking to each other yet. that’s OK. Often the manufacturer will have designed the end device so that it blinks or the LED changes color or something like that when the exclude is accepted, but not always. Usually it’s going to work.

Creating a new network

now you’re ready to set up a new network. Both Zigbee and Z wave are mesh networks, which means messages get passed along from one device to another, like a relay or a pony express route. And usually only Mains power devices (plug-in or wired to your electrical system) Will pass messages along. Battery powered devices typically don’t because it would use up too much battery.

So, you want to begin by building your “network backbone“ – – the mains power devices for one protocol. (Z wave repeats only for Z wave and zigbee repeats only for zigbee.)

So you start with the mains powered devices physically closest to the hub. Exclude, include, check to make sure the device is working. Then move onto the next one. Building your way out from the hub.

Once you have all the mains power devices working, then you can start adding battery powered devices.

Read the following FAQ. Start with post 11 in that topic (this link will take you directly to that post), read that, then go up to the top of the thread and read the whole thing.

A Guide to Wireless Range & Repeaters

Once you’re done with that, you should know a lot more about your new system and be ready to set up the network.

Then if you run into any problems with individual devices, you can come back here and ask. :sunglasses:

(I forgot to mention that the Nutone is just a re-brand of linear devices. They are also sold under the gocontrol and nexia brand. All the same device, just in a different box. They will even have the same model number. So you can try searching under those, or you can just add it as a generic device if it’s just a simple on/off or dimmer.)


Tagging @jkp for the questions about the app itself.

@JDRoberts Thank you so much for the info. I had started to read about the devices creating their own mesh which is why none of the devices far from the hub would work until I build the mesh out more. That makes sense.

I was just trying to hook up a switch that’s right next to the hub. It was found (after a little fiddling). I named it and then tested it out a few times turning on and off the lights. Then I added the other switch in that same bank. Same test…then BOOM, they are both missing from the app. I also have a mystery generic switch in one of my rooms in the app that is NOT appearing when I am viewing my hub thru my web browser. Oh my…I know I will figure this out but sometimes it feels like the B Team built this tech.

Yeah, that’s why I tagged @jkp. I am quadriparetic and rely on voice reader technology and the current app doesn’t work well with it so I can’t really help with the app any. Or hopefully somebody else who is familiar with the app will chime in.

Because smartthings is a multi protocol platform with a big cloud component it’s a lot more complex than a regular Z wave network would be. That’s how things get lost in the app. I know it’s frustrating, I just don’t have a solution for you but hopefully someone else will be able to help.

1 Like

Messing around some more tonight…I was finally able to exclude some switches properly. Then, instead of pointing the app towards the Honeywell brand, I decided to try GE (since a random GE Switch appears in my app and I can’t remove it). OMG…I am finally finding some switches. They are Honeywell, so I am a bit surprised, but if this is what it takes I don’t care. I’m guessing there’s a lot of shared software/hardware across all devices. I’m stopping for the night, but will try to build the network more tomorrow. Fingers crossed.

1 Like

Yes, Honeywell and GE are both rebrands of zwave devices made by Jasco. The firmware can be a bit different, though.

welcome to your newest hobby!

1 Like

Just wanted to reply back that once I started to assume everything was GE…IT ALL WORKED. I have a couple of Leviton outlets that needed me to set them up right next to the hub and then I moved them to where I wanted them. I could tell how certain things were not in range until I paired devices between them and the hub. I did have one outlet from NuTone that I just think is broken. Tried everything and it just isn’t working. Perhaps related to a power surge experienced last weekend.

1 Like

Sounds like you inherited a bunch of older Z-wave devices that are not Z-wave Plus. I believe those devices can’t be paired unless they can directly communicate with the hub. @JDRoberts can confirm and provide details.

With the new generation of Z-wave, those devices are now two generations old.

1 Like

That is highly likely. The old owner started this project 5 years ago, I believe.


I’ve been building out smart home for a whole year and a half so vastly experienced! :rofl::rofl::rofl:

Since you’re very fresh to this, I wanted to point out local versus cloud execution.

  • For cloud execution, every action (other than manually operating a switch) require the hub to communicate with the Samsung cloud to perform the operation. There are two implications:
  1. Nothing other than manual operations will work if you lose internet connection or the Samsung cloud has issues
  2. Every operation will have a noticable delay. Which usually causes people to try the switch again.
  • Local operation happens in the hub. While you still can’t use the app or voice assistants during an internet outage, some automations will continue to work. And switch operation will be near instantaneous.

So, with that background… As things currently stand, only devices that use one of a handful of built-in DTHs (Device Type Handlers) will run locally. And only some automations created with the Smart Lighting SmartApp will execute locally.

You can see where things are executing by looking in the “IDE”. Point your browser to and click on SIGN IN WITH SAMSUNG ACCOUNT

There are some models of GE switches that tend to fail after a few years. Search the forums for “click of death”.

1 Like

Zwave Plus was released in 2013, and by early 2015 most of the devices coming on the market were Z wave plus. So my guess would be that the OP has a mix. but you don’t know until you check the model numbers.

Z wave plus devices can generally be “paired in place,“ which means at their ultimate location as long as they can be reached by a Z wave plus device capable of repeating. This is why the backbone matters so much and why you should always pair starting with devices closest to the hub and then building out.

Z wave classic devices may indeed have to be paired within one hop of the hub, but then can be moved farther away.

Z wave locks pretty much all have to be paired within “whisper distance” Of the hub in order to exchange the security keys until you get to “smart start,” the ones which can use a QR scan.

Smart Start combined with S2 security changed everything, but with the exception of the ring security system you really didn’t start to see any of those devices until fourth quarter 2020.

To be honest, I’m not sure one way or the other whether the smart things hub now support Smart start or not. I know they got a waiver when the hub was first released and have been doing partial updates since then to bring it into conformance, but I don’t know if that process is complete yet.

1 Like

This used to be true, but some recent changes to the developer tools now allow a developer to mark a DTH for “local execution“ even when it doesn’t actually run locally. :thinking:

My guess is this is part of the evolution of the platform and they are getting ready to eventually have the possibility of local execution of custom DTHs, but for now, it is true that a device might say local execution in the IDE but still run in the cloud. very confusing. :disappointed_relieved:

1 Like