Trouble adding old Aeon DSC06106-ZWUS device

I have several of these devices already connected and working fine.

I just took two more out of their boxes (ie, brand new) plugged them in. Blue lights are a flashin’.

Except, I can’t add them.

They never show up when I try and scan for devices. Either a general scan, or using the Aeotech Energy monitoring device specific scan.

I tried rebooting the hub, running an exclusion from the web interface, doing a Zwave repair, etc.

The devices are located 3 feet from the hub.

I’ve tried about 20 times and 20 different things and no go.

I’m using a V2 hub and the Andrioid app. Also tried the IOS app.

What else can I try?

Do you know the fingerprint for the existing devices?

Like this?

Z-Wave Metering Switch Device heater

Name Z-Wave Metering Switch
Label heater
Type Z-Wave Metering Switch
Version Published
Device Network Id 0E

|Last Activity At|2023-02-01 11:02 AM CST|

|Metrics|* Received Messages From Device: 565

  • Received Messages From Device (Duplicates): 24
  • Messages Transmitted to Device: 87
  • Messages Transmitted to Device (Failures): 0
  • Updated Time: 2023-02-01 10:12 AM CST|
    |Data|* MSR: 0086-0003-0006|
    |Raw Description|zw:L type:1001 mfr:0086 prod:0003 model:0006 ver:1.43 zwv:2.78 lib:03 cc:25,31,32,27,70,85,72,86 ccOut:82|

Yep. The Z-Wave Switch Edge driver from @philh30 has that device in its fingerprints. Assuming you don’t have a custom DTH driver installed in the IDE, I’d install his driver on your hub and see if that helps.

That driver is not in any public channel as yet. The GE driver linked only supports Jasco models.

My bad. I thought the zwave-switch was available in your Z-Wave Drivers channel.

Thank you anyways…But that device handler shouldn’t affect discovering the device though, should it?

You’d think not, but with so much change going on, you never know :slight_smile:

It shouldn’t matter… The driver is assigned after discovery.

I know you’ve done some of this already but things to try:

  • Put your hub in general exclusion to exclude the devices first. The app should give confirmation that it excluded a device.
  • If the device has a factory reset procedure then try that.
  • Try adding by brand and choosing something that is definitely z-wave only. I prefer going through the GE switch prompts since it gives a clear choice of ZigBee vs z-wave. The brand doesn’t really matter for inclusion, but choosing z-wave means the hub won’t run LAN or zigbee discovery at the same time.
  • Bring the devices close. Try 3 inches instead of 3 feet.
1 Like

I was able to add the devices this morning. The Zwave utilities option wasn’t there yesterday in my Android app, it’s there today. (I did put in a ticket with SmartThings asking them to resync my account, not sure if they did that or not…).

Ran the exclude, it didn’t seem to do anything. Ran it again, and this time forced the device to exclude itself. The app acknowledge that a device was removed! Ok…The hub can now at least see the device. Tried adding it again, no go…Tried adding again, this time I forced the device to into exclusion mode during the add and it added!

So all is well now!

Thanks for all the assistance!