Unable to add new devices after Edge - zwave and Zigbee

I have been using ST for many years now, and have been able to add and remove devices. I am now struggling to add any new Zwave or Zigbee devices. I recently got Aeotec Door Window Sensor 7 Pro to replace the original Smartthings door sensors. I have tried adding unused SmartThings Button, a new Aeotec Wallmote. They just wont’t add in. Here are the screenshots:

Most of the times it get stuck as above. Once I could get to the below:

The nothing…
I checked the Advanced settings in My Smartthings account, it shows as the device being added, but it goes away after that. The app remains in the hung state or crashes. Tried reaching support through app, but it has been of no use. My last resort is to factory reset the whole setup and start again. Don’t want to do that remove years of automation.

Any help is appreciated!

Don’t add by brand or device. Instead use the “scan nearby” option and put those devices in join mode. Ive found that to be the most reliable way for me.


Yes, tried that as well. Doesn’t work.

  • which hub do you have?
  • firmware version of hub?
  • iOS or Android and version of app?
  • how many devices do you have installed on the hub?

Smartthings 2018 v3
F/W: 000.049.00009
No. devices - ~55

Ok, well how about rebooting the hub? I suspect you did already though.

I don’t have an iOS device handy at the moment to try to add a device on my hub (Android user), but I can’t believe it would be a mobile app issue because a lot more people would be posting about that.

For the zigbee devices, your can factory reset them and try again, and for the Zwave devices you can initiate an exclusion process from the mobile app to make sure nothing wonky with the device happened during your first attempts to join them. Have you tried that?

I find the new onboarding flow a little strange. It doesn’t seem to be designed for people who know what they are installing.

Have you tried the tiny “Can’t find your device?” link on the “Searching for devices” screen? From what I remember that should bring up a list of specific devices that can be installed, just like the old way of doing things that no one seemed to be complaining about.


Yes, rebeeoted many times. Tried Zigbee resetiing, and for zwave entered exclusion mode from new Advanced interface( IDE), and unpair and tried again.

Yes did that too, that also hands at the same step. It seems the device is found it tries to adds it appears briefly in the Device list on IDE (Advanced account page of Smartthings), and then disappears.

It does not seem to be an app issue, it is platform/hub specific issue.

So… finally had to factory reset the hub. Can add new devices after that. Had to recreate the routimes etc. painful but a clean start. Have other interesting probelms with Wallmote (battery lasting 1-2 days). Z-Wave contact sensors showing up as multiple capability sensor… will probably create another post for these.

1 Like