Aeon Labs DSC06106-ZWUS - Unable to re-add


#1

I noticed the energy readings of my DSC06106-ZWUS were no longer getting updated so I’m trying to remove and re-add it.

I seem to be able to exclude it (I get a Device successfully removed message) and I’ve removed the device in the ST app.
However, I’m unable to add it back.

I select Add a Thing and when it starts scanning, I plug the device in. The blue light flashes and continues to flash but the app just continues to say “Looking for devices”

any ideas?

thanks


#2

I have a similar problem with my Iris keypads. I had to open a new account and start over and my keypads would never re-pair to the new hub. I believe this occurs when the SmartThings platform thinks that these devices are already paired, maybe in another place or account on the system. I know that they are correctly reset and they will immediately pair to an Iris hub, so the problem is not with the keypads. So far support has not been able to fix the issue. I have supplied them with the device id’s to see if they can find them and remove them from the system. I’ll be watching to see if you are able to get your issue sorted out and will let you know if they are able to solve my issue.


#3

To add to the weirdness, after trying several times… unplugging it…plugging it back in… pressing the power… etc.

If I perform a General Device Exclusion again, it comes back with a “Successfully removed a device” and the power light starts flashing.

I immediately try to Add a Thing but it just stays Looking for devices…

quite frustrating.


#4

Are you sure that it is not adding it to your list of devices anyway? I’ve had that happen.


#5

I thought that as well but once it says it’s excluded, I checked my devices and it’s at 57 and doesn’t change.

the logs show that it never discovers a new device.

[04a8c491-2341-4ae9-845a-bef9dc9d72d4](https://graph.api.smartthings.com/ide/logs#04a8c491-2341-4ae9-845a-bef9dc9d72d4) 3:13:35 PM: debug No devices to add, verified devices: [:]

[04a8c491-2341-4ae9-845a-bef9dc9d72d4](https://graph.api.smartthings.com/ide/logs#04a8c491-2341-4ae9-845a-bef9dc9d72d4) 3:13:35 PM: debug detecting status for e81a8d42-4397-4edb-9957-7403b5a7cc46 : true

[04a8c491-2341-4ae9-845a-bef9dc9d72d4](https://graph.api.smartthings.com/ide/logs#04a8c491-2341-4ae9-845a-bef9dc9d72d4) 3:13:35 PM: trace in ssdpDiscover

[04a8c491-3414-4ae9-812a-bef9dc9d78d4](https://graph.api.smartthings.com/ide/logs#04a8c491-3414-4ae9-812a-bef9dc9d78d4) 3:13:35 PM: debug scheduled run, numberOfRuns: 3

#6

@surge919 I’ve had these devices before, and they’re finicky. I’ve always gotten it to pair very close to the hub, and then moving it to it’s final location. Do a general exclude on it again to be safe.


#7

After messing with this for about an hour with several combinations of exclusions… scanning, unplugging and pluging back it, it finally paired. I had moved close to the hub but eventually got it to pair while at it’s current location.
When it paired, it came up with the Zwave outlet device handler. I updated it with the Z-Wave Metering Switch and it detected 10 watts (the correct wattage of my light bulb). I moved it to it’s real location (my washing machine) but it never dropped back to 0. I turned on the machine and it stayed at 10.

Which handler should I be using for this device? I don’t care about power on/off, I’m using it strictly to monitor the power for usage notifications.


#8

I was using “Z-Wave Metering Switch” as well, and for the same application. Now that you have the right handler defined, try a Replace on it. Watch the hubs IDE event log if you can while doing that, or at least go back and see what it did.

Does the watts value change when you tap on refresh?


#9

I did have “Z-Wave Metering Switch” but hitting the refresh button had no affect on the Watts value. I changed to another device handler and changed it back. unplugged and plugged it back in and now when I turn on the washing machine and hit refresh the values change.

I tried a different handler which would allow me to change the interval since the Z-Wave Metering Switch is set to 1920 (30 minutes).

I’ll keep it on this one for a few days and monitor its behavior.


#10

Cool. You can try my custom DTH if you want:

https://raw.githubusercontent.com/jsconstantelos/jcdevhandlers/master/devicetypes/jscgs350/my-aeon-metering-switch.src/my-aeon-metering-switch.groovy


#11

I think that’s the one I tried but it wasn’t refreshing the watts. I had set it to type 0 and getting the watt value every 10 seconds (for testing)

I’ll give it another shot when I get home.

I did like all the options it had.


#12

I pointed by device back to your DH and set it to type 0 and report watt every 10 seconds.
Should I expect to see the watt value is 0 every 10 seconds in the log?

For comparison, my Dryer logs show the following: (this is using Aeon Home Energy Meter and is the clamp type device)
Parse returned Dryer power is 0 W

Here are my setting for the Washing Maching device:

Z-Wave Device Device Washing Machine
Disable On/Off switch?   
true
 Enable debug logging?   
true
 Display all events in the Recently tab and the device's event log?   
true
Enter your cost per kWh (or just use the default, or use 0 to not calculate): - Tap to set   
0.16
ReportType: Send watts/kWh data on a time interval (0), or on a change in wattage (1)? Enter a 0 or 1: - Tap to set   
0
For ReportType = 1, Don't send unless watts have changed by this many watts: (range 0 - 32,000W) - Tap to set   
50.0
For ReportType = 1, Don't send unless watts have changed by this percent: (range 0 - 99%) - Tap to set   
10.0
For ReportType = 0, Send Watts data every how many seconds? (range 0 - 65,000 seconds) - Tap to set   
10.0
For ReportType = 0, Send kWh data every how many seconds? (range 0 - 65,000 seconds) - Tap to set   
60.0
How many decimal positions do you want watts AND kWh to display? (range 0 - 3) - Tap to set   
3.0

#13

Perhaps. SmartThings will not update if the previous value is exactly the same as what was just sent from the device. If the device keeps sending 0’s, then the only one that will be “recorded” will be the first 0 until it changes. It’s the same way battery powered devices work. They may send their value every hour, but ST won’t update until it changes. You’ll see that in the IDE if you specifically look at the current state for a device’s battery capability. Since logs are only kept for 7 days, you’ll likely see an empty event log for battery readings:

image

You’re settings look fine, but they’re also the default with the DTH. In some cases, ST won’t recognize that and throw errors that you can catch in Live Logging. Go ahead and change each one, just to be safe. You can keep the default value, but I suggest editing each one. Once you do that, keep an eye on Live Logging for any errors and let me know what you see.

I like these devices, but they can be a little pain to get joined up right.